3 Replies Latest reply: Jan 18, 2013 2:13 AM by Sosoyan
minihui Level 1 Level 1 (0 points)

OK this is a long story but in short: something's preventing my MacBooks from connecting to 802.11n networks exclusively on OSX, and it's very strange.

 

I spent quite a long time to isolate the problem and finally it seems that 'something' is doing the trick. Because it happens only in my office and around.

 

MacBooks involved: MacBook Pro (Core 2 Duo running 10.6.8), MacBook Air 11 (Mid 2011 running 10.7.4), Retina MacBook Pro (running 10.8 GM)

Wireless base station involved type 1: NETGEAR WNR3500 v2 (2.4G 300M), TP-LINK TL-WR941N (2.4G 300M), TP-LINK TL-WDR4310 (2.4G 300M & 5G 450M)

Wireless base station involved type 2: TP-LINK TL-WR700N (2.4G 150M), TP-LINK TL-WR800N (2.4G 300M)

 

Those MacBooks will only connect to 2.4G networks from base station type 1 at 54Mbps if set to b/g/n mixed or so. If set to n only, the MacBooks can find the network but connection time out occures (if the network is deleted, it does require a password but either 'contact network administrator' or 'connection timed out' appears). And they all can not find the 5Ghz 802.11n network from TL-WDR4310.

 

---- strange enough ----

 

They all can connect to the 802.11n networks from base station type 2 and once connected, EVERY network above will connect without any problem until next restart / sleep / toggle WiFi off and on.

 

This issue is on MacBooks running OSX (seems with Broadcom wifi chips only, iMac with Atheros wifi chip is fine, not 100% sure though).All iPhones (3GS, 4, 4S) connects to 2.4Ghz networks well. All iPads (1st gen, iPad 2, new iPad) connects to both 2.4Ghz and 5Ghz networks well. And I even tried to install Windows 7 on Retina MacBook Pro and it was all fine.

 

Above problem can be reproduced time by time with no miss, while the wireless base stations' preferences keep the same.

 

And I tried to bring my MacBook Air and TL-WR941N to another room which is about 50 meters, more than 5 bricks wall away, and it is all fine.

So obviously there is something preventing almost all MacBooks connecting to 802.11n networks on both 2.4Ghz and 5Ghz.

 

Tried to delete all known networks, delete keychains, zap PRAM, reset SMC with no help. Tried router mode and AP mode with no help. Again, obviously there is something out there causing the problem which happens only on OS X.

 

As you can see I'm not beginner and I am experienced (kind of, hopefully not missing something stupid). I'll try to continue my troubleshooting. If any of you have any suggestions, I will be very glad to hear. And I will post the result here, if I can.

 

Thank you in advance.

Minihui


MacBook Pro (Retina, Mid 2012), Mac OS X (10.7.4)