Skip navigation

Can't open Youtube on Safari

2211 Views 15 Replies Latest reply: Feb 1, 2013 9:49 AM by nuseybe RSS
1 2 Previous Next
Nisan A. Calculating status...
Currently Being Moderated
Jan 16, 2013 8:16 AM

It's been about three days since youtbe suddenly stopped loading in my mac. It loads a tiny bir in the adress bar and when I wait a good few minutes it says that Safari can't open the page.

I've alreay tried several DNS settings but that doesn't seem to be the case. Also, none of my proxies are checked.

 

Any ideas on what may be the problem?

iMac, OS X Mountain Lion (10.8.2)
  • KarenSelena Level 4 Level 4 (1,905 points)
    Currently Being Moderated
    Jan 16, 2013 8:18 AM (in response to Nisan A.)

    Did you already try resetting Safari??  If not, click on the word safari beside the apple, then select "reset safari". 

  • KarenSelena Level 4 Level 4 (1,905 points)
    Currently Being Moderated
    Jan 16, 2013 9:05 AM (in response to Nisan A.)

    Try uninstalling then reinstalling a fresh copy of the Flash Player plugin.

     

    Uninstall Flash - http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html.

     

    Re-install Flash - http://get2.adobe.com/flashplayer/.

  • dominic23 Level 6 Level 6 (18,540 points)
    Currently Being Moderated
    Jan 16, 2013 10:22 AM (in response to Nisan A.)

    YouTube videos not playing?

     

    One of the following steps should help.

     

     

    1. Install Adobe Flash Player.

     

        http://get.adobe.com/flashplayer/

     

        Restart

    2 .Are Plug-ins Enabled?

     

        Enable Plug-ins

     

        Safari > Preferences > Security

     

        Web Content:

        Click in the box for "Enable Plug-ins".

     

     

    3. Check  whether you are currently  in  YouTube HTML 5 trial.

     

         http://www.youtube.com/html5

     

        At the bottom  left of the page  uncheck the box for

     

       "You are currently in the HTML5 trial".

     

     

         Now try YouTube.

     

    Best.

  • Linc Davis Level 10 Level 10 (107,995 points)
    Currently Being Moderated
    Jan 17, 2013 11:08 AM (in response to Nisan A.)

    Select the text below (not including the blank space at the end of the line), then copy it to the Clipboard (command-C):

     

    youtube.com

     

    Launch the Network Utility application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Network Utility in the icon grid.

     

    Step 1

     

    Select the Lookup tab and paste (command-V) into the address field. Press return. Post the output that appears below – the text, please, not a screenshot.

     

    Step 2

     

    Select the Ping tab and do the same.

  • GoldenAvenger Calculating status...
    Currently Being Moderated
    Jan 17, 2013 11:10 AM (in response to Nisan A.)

    try to reinstall safari /update it /install the latest adobe flash player

  • Linc Davis Level 10 Level 10 (107,995 points)
    Currently Being Moderated
    Jan 18, 2013 7:34 AM (in response to Nisan A.)

    You wrote above that you had changed your DNS settings, so I assume you know how to do that. In your router, change the DNS settings to use your ISP's DNS servers. Usually all you have to do to make that happen is to delete whatever you put in. The DNS server addresses should be populated automatically.

     

    On the clients, also remove the DNS server addresses. Your router should then be used as a DNS proxy, which will refer all queries to your ISP.

     

    Test. If there's no improvement, please repeat the Network Utility tests and post the results.

  • nuseybe Calculating status...
    Currently Being Moderated
    Jan 24, 2013 3:29 PM (in response to Nisan A.)

    Hi. I have the same problem. My macbook pro doesnt open youtube in any browser (safari, chrome, firefox..). I tried the solution you gave us here but i cannot save the changes in the host file. Actually the file was locked to change anything but i gave permission. Then still it doesnt accept any change in the file. I am trying this on Textedit because I dont have smultron. So is there any other way you know, to solve this problem? thanks.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.