3 Replies Latest reply: Jan 18, 2013 11:34 AM by Tagstewart
Tagstewart Level 1 Level 1 (0 points)

Hello,

 

I tried to update the Safari browser on my Mac OS X 10.5.8 and now when I try to use Safari it says 'You cannot use this version of the application Safari with this version of Mac OS X'.

 

Foolishly I don't have Firefox or another broswer installed and so can't download the older version of Safari. I'm stuck!

 

Can anyone solve this problem for me please? I'd really appreciate it.

 

Tom


MacBook, Mac OS X (10.5.8)