Skip navigation

Software upgrade needed ?

411 Views 5 Replies Latest reply: Jan 29, 2013 10:26 PM by MlchaelLAX RSS
krishk24 Calculating status...
Currently Being Moderated
Jan 18, 2013 10:01 AM

I have version 10.5.8 on my 2007 iMac

Its been a while since i noticed any software upgrade and I worry about security.

do i need to upgrade to a newer version of OS X to get the latest security update and patches ?

is 10.5.8 not supported by apple anymore for software upgrade ?

 

ps: My safari also crashes frequently and haven't noticed so much with other applications. it may also be due to limited RAM I have (1GB 667 MHz), but other apps don't seem to be affected. I am hoping a software upgrade will help with the instability issue

iMac, Mac OS X (10.5.8), 1 GB 667 MHz RAM, Intel Core 2
  • Gary Scotland Level 5 Level 5 (7,555 points)
    Currently Being Moderated
    Jan 18, 2013 10:17 AM (in response to krishk24)
  • AnaMusic Level 9 Level 9 (55,060 points)
    Currently Being Moderated
    Jan 18, 2013 10:21 AM (in response to krishk24)

    The first step in Upgrading... is to Snow Leopard = OS X 10.6.x

     

    It is Not available as a download... It is a Paid Upgrade.

     

    Do this first...

     

    Check that your Mac meets the System Requirements for Snow Leopard...

     

    Snow Leopard Tech Specs

     

    http://support.apple.com/kb/SP575

     

    If so... Purchase a Snow Leopard Install Disc...

     

    http://store.apple.com/us/product/MC573Z/A/mac-os-x-106-snow-leopard

     

     

    Other countries...

     

    http://support.apple.com/kb/HE57

     

     

    After the Successful Install, run Software Update to get the latest updates for Snow Leopard.

     

     

    Be sure to make a Backup of your Current System Before Upgrading...

     

    More RAM is a good idea... Increase the RAM first...

     

    It is important to get the Correct and Matching RAM

     

    See Here  >  OWC RAM  >  http://www.macsales.com

     

     

    That site also has Videos on Installing RAM should you need it...

  • AnaMusic Level 9 Level 9 (55,060 points)
    Currently Being Moderated
    Jan 29, 2013 7:30 PM (in response to krishk24)

    See here for upgrading to ML...

     

    Upgrade to Mountain Lion

     

     

    With Regard to ML...  Check here for compatibility of 3rd party Software you may be using... as Power PC Applications are Not Supported.

     

    http://roaringapps.com/apps:table

  • MlchaelLAX Level 4 Level 4 (1,530 points)
    Currently Being Moderated
    Jan 29, 2013 10:26 PM (in response to krishk24)

    krishk24 wrote:

     

    so does apple support software patches (specifically security update) for Snow Leopard ? or will they require me to upgrade to the latest version Mountain Lion again after the upgrade to Snow Leopard to get the security patches  ? I believe that can be done over the internet instead of a disc (upgrade to Mountain Lion), correct ?

    I think this question was misunderstood in its answer, so I will try and answer it for you again:

     

    Did you confirm that your iMac can be upgraded to Snow Leopard?

     

    Once you install Mac OS X Snow Leopard from the DVD that you purchase from Apple (be sure to select Rosetta in the OPTIONS or CUSTOMIZE button before you start the installation), you will probably have version 10.6.3 on your computer.  Apple does continue to support Snow Leopard and when you run Software Update... under the Apple Menu, it will update all applicable Apple software that it finds necessary to update.  It may require a Restart as well.

     

    Keep attempting another Software Update... until it tells you that no further updates are available.  At this point you will have the laterst version of Mac OS X Snow Leopard 10.6.8. –– this is NOT Mountain Lion.

     

    It is doubtful that a 2007 iMac can be upgraded to Lion, let alone Mt. Lion.  You will have the most security available to this Mac. 

     

    It will not include version 6 of Safari (which requires at least Lion), only the last revision of version 5; but I personally am not sure of the security implications of using version 5.x. 

     

    That being said, I was using version 5.x up until recently on my MacBook Pro because I had forgotten to check for updates for quite a while while using Lion.  I saw no adverse effects from this usage, but of course, your mileage may differ!

     

    Good luck!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.