Skip navigation

iCloud contacts do not sync under ML

80775 Views 46 Replies Latest reply: Apr 5, 2014 5:41 AM by scottrussell-kc RSS
  • TangerineTurtle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2012 11:21 PM (in response to Winston Churchill)

    Yeah, like dumping iCloud and going with the Google solution.  I already use Google calendar because it is far superior to Apple's calendar.  I have mooved to Gmail, because Apple decided to change my @mac.com address to a @me.com.

     

    Now my contacts on my Mac won't sync with iCloud.  I am tired of Apple passing out Beta solutions.  

  • Tak_if Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2012 7:44 AM (in response to Muehlenbungert1)

    I had the same problem as above. All I did is opened the contacts app on my Macbook Pro --> preferences --> iCloud acc --> enable this account. All contacts have synced without any problems.

  • kingdomoffurr Calculating status...
    Currently Being Moderated
    Dec 6, 2012 12:22 AM (in response to Tak_if)

    I have had this issue with my iphone not syncing between ML and Ipad.

     

    After finding nothing my solution was this...

     

    Go into settings mail, contacts, calendars and under contacts look at what the default account is. If it doesnt say Icloud change to to Icloud.

     

     

    Contacts syncing perfectly now.

  • sj0721 Calculating status...
    Currently Being Moderated
    Jan 17, 2013 11:46 PM (in response to kingdomoffurr)

    That was my problem exactly. I had added my work Exchange account, and my iPhone switched my default Contacts to that account instead of leaving it on iCloud. Thanks for the heads up!

  • RWMU Calculating status...
    Currently Being Moderated
    Jan 18, 2013 2:33 PM (in response to Muehlenbungert1)

    I have an email address in contacts, stored in iCloud, that just refuses to appear in Mail.

     

    If I search contacts by typing "mek" without the quotes, the address appears perfectly, yet typing the same thing on the same computer into Mail and the address refuses to appear.

     

    Like others on this thread, I also use Gmail and have had far fewer issues, which makes me wonder about the capabilities of Apple.  With all that ca$h and they still cannot write decent software and employ people to test it thoroughly.  Very frustrating and time wasting for me.

  • H-m-d Calculating status...
    Currently Being Moderated
    Jan 29, 2013 11:59 AM (in response to Muehlenbungert1)

    Hi

    I've held contact numbers in iCloud  is carried ، He then delete the numbers P original

     

    How do I get off the figures again

     

    Please help

  • K4Jo Calculating status...
    Currently Being Moderated
    Apr 4, 2013 9:20 AM (in response to Muehlenbungert1)

    I have just had this issue and resolved it for myself by doing the following.....

     

    1. I made sure that my iMac & iPhone had the same amount of contacts in the all contacts.

    2. I checked that both devices had the icloud settings configured correctly.

    3. I turned off syncing contacts on my iPhone, and selected the remove from my phone option.

    4. I turned syncing back on and again was happy that all contacts were still there.

     

    [ The groups showing wrong contacts bug was still there ]

     

    5. I created a new group with a new name on my iMac.

    6. Selected all contacts of a bugged group and dragged them into the new group.

    7. I confirmed that the new group and members had moved to the iPhone.

    8. I deleted the old group on my iMac.

    9. I confirmed that the old group disapeared from my iPhone.

     

    [ Repeat steps 5-9 for any bugged group ]

  • Absit Invidia minimus Calculating status...
    Currently Being Moderated
    Jun 25, 2013 8:51 AM (in response to jneb)

    jneb.

     

    You have saved my sanity.

     

    This has fixed the problem entirely.

     

    For others reading this I now realise why the problem arose.  I was loading contacts (from a Windows Mail application) onto my Mac using multiple vcard files.  By loading the vcard files too quickly the Contacts application froze and my only solution was to Force Quit.  This has obviously corrupted the sync information on Mac Contacts.  jneb's solution is elegant as it allows the whole of the Mac Contacts to be cleared and started afresh whilst providing a mechanism for saving and restoring data.  My Mac Contacts and iCloud contacts now sync perfectly. 

     

    I shall now be happy for at least the rest of the week and it is only Tuesday.

     

    Thanks again jneb.

  • shmereny Calculating status...
    Currently Being Moderated
    Aug 1, 2013 8:24 AM (in response to Muehlenbungert1)

    SOLUTION:

     

    In Contacts on your mac you will see several categories in the left-hand column:

     

    All Contacts

    On My Mac

    iCloud

    Smart Groups

    (including any sub-groups you have created in these categories)

     

    Make sure you are only creating new contacts under "iCloud"

     

    If you have any contacts under "On My Mac," these will NOT sync. Drag all of them into iCloud to copy them. Then you can delete them from On My Mac.

     

    Now they should sync!

  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Aug 1, 2013 8:34 AM (in response to shmereny)

    Also you should use the iCloud account as the default account for new contacts, that way they are added to the correct account in the first place, avoiding the need to move them later.

  • roly2409 Calculating status...
    Currently Being Moderated
    Oct 22, 2013 10:22 PM (in response to Muehlenbungert1)

    i figured it out for me, maybe it might be the case with everyone else,

    on phone go to settings>>mail,contacts,calendar>>(scrolldown to contacts)change default account to icloud

     

     

    in icloud on web make sure that your primary apple id is the desired one, in my case i deleted apple's own icloud email and just left my email and everything worked fine.

  • clrdangel Calculating status...
    Currently Being Moderated
    Nov 22, 2013 2:30 PM (in response to roly2409)

    Contacts in "Settings" doesn't have a default option--it's only available for mail.

  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Nov 22, 2013 2:32 PM (in response to clrdangel)

    clrdangel wrote:

     

    Contacts in "Settings" doesn't have a default option--it's only available for mail.

    If you have more than 1 Contacts account then there will be an opton to select a default, if you only have 1 account then obviously it is already the default, no option required.

  • eye_one Calculating status...
    Currently Being Moderated
    Dec 7, 2013 8:32 AM (in response to Muehlenbungert1)

    I'm switching to Google. I'm fed up with all the problems Apple is giving me.

    Google Drive/Mail/Contacts and a lot of free online apps is frankly unbeatable.

    Everyday I'm more convinced that Apple should have stuck to making fantastic hardware and op sys.

  • bardwell03 Calculating status...
    Currently Being Moderated
    Jan 28, 2014 10:55 AM (in response to Tak_if)

    you star. you absolute bloody star. thank you so much. This has been crazing me for 2-3 months. Well done you.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.