2 Replies Latest reply: Jan 19, 2013 2:58 AM by Klaus1
Darrell R Coe Level 1 Level 1 (145 points)

I recently tried to bring up  up  a website that requires Adobe Acrobat Reader and he site stated it could not detect Acrobat Reader on my computer.  I went to the Adobe website, which listed reader 9.4  for OS X 10.4.11.  Is Adobe Reader similar to  Flash Player where Adobe is not Supporting Mac Power PC and you are not able to load the most recent Reader for your computer?  After loading from the Adobe site, I tried to mount the web page again.  This time I did not get the notification that it did not recognize Reader on my computer.  But it produced a dark screen with an in-progress circle rotating in the middle of the screen.  After 5 minutes the web page still had mounted and I started wondering what the cause might be.  Is there a later version I can load that will support OS X 10.4.11?