1 2 3 Previous Next 32 Replies Latest reply: Oct 7, 2013 1:15 PM by B1nzy Go to original post
  • 15. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    Mike3020 Level 1 Level 1 (0 points)

    I've been having strange conductivity issues between my iMac24HD running 10.6 and my iOS 5.x iPad2 along with my iPhone 3GS for 6 mos, and my ATV2.

     

    I've searched the Community Forums for solutions and found references to Port Forwarding Ports 5353 3689 & 123.  I've done that and the best I been able to achive is:

    • ATV2 works, but some times you have RESET it in order find your home share library again.
    • iPhone couldn't find Home Share at all.
    • iPad2 would Home Share, but about 10min into anything you were watching, and the controls (you normally find to use when touching the screen) would not be available, the Video's would play find, and when the video was  done you had to kill the iPad Video App restart the App in order to watch something else.

    When iOS 6 was released I updated my iPad2, iPhone, along with the normal iTunes updates. I was hoping this could fix those issues as nothing seemed to work so far, I was starting to think my iMac was the problem. 

    I decided to make the jump to Mountian Lion 10.8, that puts everything on the same playing field.  This only MADE THINGS WORSE.

     

    I've been searching for a week, for a solution that I have not yet attempted. Then I decided to search the forums for (Home Share, Resolutions), and found your post. It seems to work.

     

    I have a Dlink DIR-655 router connected to my Comcast Cable modem.

    IGMP was not enabled, but UPnP was, so I disabled it.

     

    Upon the reboot of the Dlink, I checked my iPhone to see if Home Sharing would be available, Bingo it was, I watched a TV show to validate the functionality.

    iPad2 was my next test, Home Share was found, and I played a few episodes of the Big Bang Theroy, in fact I was able to watch two with out having to restart the Video App.

    ATV2 has not been tested yet, but I'll do that later. 

     

    The real test will take place when I get home tonight and see if Home Sharing is found and working on all my Apple devices.

     

    If the problem returns, I'll update my post, but for now it looks to be working, it's been now 8 hours since the router reboot.

     

    Please pardon any typos, my brain writes much faster then my fingers can transfer it to text on screen.  (baud rate mis-match)

  • 16. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    h77bjj Level 1 Level 1 (0 points)

    Thank you!! BigWorm is amazing.  Not sure how you figured this out, but it worked and saved several more hours of insanity.

  • 17. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    TaZorro Level 1 Level 1 (5 points)

    Been slamming my head against a wall for about three weeks! I have a lil tech sense and all my apple products and one of my PC's on wifi worked great but my only wired PC in the house (my music server) *suddenly* stopped being accessible. booooo. I tried restarting and updating and checking/rechecking/tweaking my network settings.. everything I could think of to no avail... searched sites and asked questions, still no answer. Finally backdated and realized the problems started right around my FIOS installation, changed my search term to include FIOS and BAM! this chain came up, I was already messing around with my router settings and with one click (disabling the IGMP proxy as suggested), all is good again. Thanks so much BigWorm76!

  • 18. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    Jshoe2000 Level 1 Level 1 (0 points)

    Thank you Bigworm76. simple easy resolution.

  • 19. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    Peter V Cook Level 1 Level 1 (40 points)

    I was able to resolve a similiar problem by updating my Router firmware.

  • 20. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    metakism Level 1 Level 1 (0 points)

    IGMP tweak for Fios solved home sharing problem - thanks!

  • 21. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    cmedwards2006 Level 1 Level 1 (0 points)

    Thanks so much, when we saw you had Verizon Fios too, we were able to try this solution for the IGMP & it finally worked!!! We've tried everything from the IPv6 disabling to checking Firewall settings to enabling all the Home Sharing ports, etc...but nothing worked until I found this. Not sure if it was a combination of everything else (possibly), but this definitely has to be done if you have a PC with a Verizon Fios router!!! Thanks again BigWorm76!

  • 22. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    ddsimonsr Level 1 Level 1 (0 points)

    Thank you BigWorm !!! You saved me a great deal of time. I just switched 'back' to FiOS after a disatrous stint with Optimum Online and couldn't figure out why the HomeShare suddenly stopped working. I searched a couple of other posts, but this was the simplest and (more importantly) ... it WORKED !!! Again, thanks.

  • 23. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    fett1988 Level 1 Level 1 (10 points)

    So, does anyone else have the issue I seem to have?

     

    After times when my computer re-starts or is shut down, it takes forever for the home sharing to be seen by ipad, ipod, iphone and Apple TV.

     

    Very, very frustrating.

  • 24. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    LusardiSG Level 1 Level 1 (0 points)

    Thanks for your comments.  I could finally see the home sharing library after disabling UPNP.  Any side affects from this after you disabled this router feature?

  • 25. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    DCantor Level 1 Level 1 (0 points)

    After calling Apple and Verizon with the same problem and not getting a working solution from either of them, I tried the disable IGMP trick. And darn it, it worked immediately. While I hate to support anything where there's not a full description of what else might happen by using a trick, it's the only thing that worked. I then asked Verizon about it and they said the sky won't fall for doing it so I'm sticking with it.

     


  • 26. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    Anaz989 Level 1 Level 1 (0 points)

    I had all the above issues with home sharing and FINALLY i found the issue was with my itunes not the network. I had to go to my control panel then services and activate a program called bonjour, which apple uses for home sharing. Fixed the problem immediately. I am on windows 7.

  • 27. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    yorkydoggy Level 1 Level 1 (0 points)

    Since the update version of iTunes 11.0.4.4, I lost airplay on the side volume in the upper left. How do I get it I can not find it. I have a pc with windows vista. I read all your solutions and that doesn't work. No problem on iPad and iPod .... only on pc.

    On ITunes, in preferences and then sharing, it says'' Bonjour service has been disabled. It is necessary to share music with other users. Reactivate the service to use this feature.''

    But I don't know where activate the Bonjour service ... does anyone know?

  • 28. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    spavlis Level 1 Level 1 (0 points)

    Hello, Ive been having this problem for the last week or two and its been driving me crazy. I cant Airplay to my ATV from iTunes and I cant see my library in my ATV with home sharing on and signed in with the same ID on both.

     

    I have a Wondows 7 Pro (64bit), I'm running iTunes 11.1.0.126, I have ATV 3rd Gen and they are all hard wired. I have a verizon router as well. I have tried everything from disableing virus software, opening ports, uninstall and reinstall iTunes, restarted everything like computer, router, ATV, unplugged and even restored back to factory settings. No luck.

     

    I was reading about how to change the setting for IPv6 but for mac only. cant find anything for Windows. So I figured it out myself by:

     

    1. Go to "Start"

    2. Click "Control Panel"

    3. Click "Network and Sharing"

    4. On the left click "Change adapter settings"

    5. Right-click your current/in-use "Local Area Connection"

    6. Click on "Properties" and a window will open up.

    7. Uncheck "Internet Protocol Version 6 (TCP/IPv6)

    8. Click "OK"

    9. Close all opened windows and if iTunes was open thru all this, just close it and open it again and you should see the ATV icon in itunes to allow you to Airplay. You should be able to see your library in ATV as well, since It works for me too.

     

    Changing these setting might cause something else to not work. I dont know yet but so far so good and no problems. Hope this helps people as it worked for me.

     

    UPDATE:

     

    I just read this post and saw that disabling the IGMP worked for some people. I tried this and it didn't help me. I still have to disable my IPv6 as I show above for it to work.

     

    I undid my IPv6 seeting and enabled it again. Then I went back to iTunes to make sure that my Airplay and Home Share didnt work again and went to my verizon router settings to change my IGMP settings. I have the Actiontec M124WR rev. 1 and this is the upgraded router you have to pay for which allows a higher Gigabit transfer rate (hard wired only). Since the IGMP causes problems with the bandwidth and the IGMP blocks larger traffic requests, this might not be the problem with me as I have the faster router. Just an observation might not be the reason this doesnt work for me, but a possability.

     

    For those of you who dont know where the IGMP setting might be or have a different router, I have showed how to get there below. Please use this as a reference only as all settings of Actiontec or other router brands might not be exact but similar.

     

    I got there going to my routers IP address by:

     

    1. Opening a web browser and going to "192.168.1.1" (which whould be for everyone)

    2. Click on "Advanced" (click Yes to proceed)

    3. Click on "Routing" (bottom right for me)

    4. Check off the box that says "Internet Group Management Protocol (IGMP)

    5. Click "Apply"

    6. Close down browser and check to see if it works.

     

    Good Luck!!

  • 29. Re: Resolution Found! -  Home Sharing/AirPlay failure with Apple TV
    Anaz989 Level 1 Level 1 (0 points)

    Bonjour is likely not activated. In order to activate Bonjour, on a windows computer: Go to control panel/administrator tools and then services.Find bonjour and right click on it.Set it to automatic and start the service.

     

    Before making your self insane, try this out, it likely is the problem. I have even found at times after reinstalling components bonjour will deactivate and my itunes library will again no longer be visible on my ATV.

    spavlis wrote:

     

    Hello, Ive been having this problem for the last week or two and its been driving me crazy. I cant Airplay to my ATV from iTunes and I cant see my library in my ATV with home sharing on and signed in with the same ID on both.

     

    I have a Wondows 7 Pro (64bit), I'm running iTunes 11.1.0.126, I have ATV 3rd Gen and they are all hard wired. I have a verizon router as well. I have tried everything from disableing virus software, opening ports, uninstall and reinstall iTunes, restarted everything like computer, router, ATV, unplugged and even restored back to factory settings. No luck.

     

    I was reading about how to change the setting for IPv6 but for mac only. cant find anything for Windows. So I figured it out myself by:

     

    1. Go to "Start"

    2. Click "Control Panel"

    3. Click "Network and Sharing"

    4. On the left click "Change adapter settings"

    5. Right-click your current/in-use "Local Area Connection"

    6. Click on "Properties" and a window will open up.

    7. Uncheck "Internet Protocol Version 6 (TCP/IPv6)

    8. Click "OK"

    9. Close all opened windows and if iTunes was open thru all this, just close it and open it again and you should see the ATV icon in itunes to allow you to Airplay. You should be able to see your library in ATV as well, since It works for me too.

     

    Changing these setting might cause something else to not work. I dont know yet but so far so good and no problems. Hope this helps people as it worked for me.

     

    UPDATE:

     

    I just read this post and saw that disabling the IGMP worked for some people. I tried this and it didn't help me. I still have to disable my IPv6 as I show above for it to work.

     

    I undid my IPv6 seeting and enabled it again. Then I went back to iTunes to make sure that my Airplay and Home Share didnt work again and went to my verizon router settings to change my IGMP settings. I have the Actiontec M124WR rev. 1 and this is the upgraded router you have to pay for which allows a higher Gigabit transfer rate (hard wired only). Since the IGMP causes problems with the bandwidth and the IGMP blocks larger traffic requests, this might not be the problem with me as I have the faster router. Just an observation might not be the reason this doesnt work for me, but a possability.

     

    For those of you who dont know where the IGMP setting might be or have a different router, I have showed how to get there below. Please use this as a reference only as all settings of Actiontec or other router brands might not be exact but similar.

     

    I got there going to my routers IP address by:

     

    1. Opening a web browser and going to "192.168.1.1" (which whould be for everyone)

    2. Click on "Advanced" (click Yes to proceed)

    3. Click on "Routing" (bottom right for me)

    4. Check off the box that says "Internet Group Management Protocol (IGMP)

    5. Click "Apply"

    6. Close down browser and check to see if it works.

     

    Good Luck!!