Skip navigation

iTunes 10 add to library not working

270998 Views 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew RSS
  • michael.gill Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 26, 2012 11:33 AM (in response to Mj662)

    For missing videos, try making sure that they haven't been imported (added to library) as 'Home Videos'. These videos will not appear in the 'Movies' section but will still sync to Apple TV.

     

    If they have, right click, Get Info, change Media Kind in Options to Movies.

     

    Hope this helps with one of the problems mentioned.

     

    M

  • johnbonham98 Calculating status...
    Currently Being Moderated
    Dec 29, 2012 7:17 AM (in response to Boudjtastic)

    okay i found a fix for the mp3 problem at least the one that was happening to me. If you change the extension .mp3 to .m4a and add the file to library it should work. you'll know it has worked when a little progress bar flashes in the apple window in the top for a second and a pop up comes up confirming success.

  • chinaFitter Calculating status...
    Currently Being Moderated
    Dec 31, 2012 11:08 AM (in response to johnbonham98)

    Fixed!!

     

     

    hopefully helpful to you, let me know if this works, like my post or something so can help other people.

     

    the thing is i did two things and suddently it works, so do not know which one trigged. try both.

     

    1. go to preference, then go to advanced, then you should see the window say where all the music saved, my originally says the end location is "itunes media", which i went there and had a look only some other emply folders there. and I changed it to "music", which is the 1st sub folder in macbook, same level with film and photos etc..

     

    2. i un-checked the 2nd option box in "advance", which says "by adding to media library by copy the music to the mediafolder" (which should be the folder in the aboved mentioned location folder, sorry that my computer is in german so maybe i recite the option not in the precise english)

     

     

     

    wierd thing is after i did those two things, i reset them back to before i changed it, and still working... wierd....anyways, worked now.

     

    so i suggest u do those two things back and forth and try, i am pretty sure the solution should be in this advance perference window. just try.

     

    hope that helped.

     

    happy new year

  • chinaFitter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2012 11:09 AM (in response to LadyBD)

    Fixed!!

     

     

    hopefully helpful to you, let me know if this works, like my post or something so can help other people.

     

    the thing is i did two things and suddently it works, so do not know which one trigged. try both.

     

    1. go to preference, then go to advanced, then you should see the window say where all the music saved, my originally says the end location is "itunes media", which i went there and had a look only some other emply folders there. and I changed it to "music", which is the 1st sub folder in macbook, same level with film and photos etc..

     

    2. i un-checked the 2nd option box in "advance", which says "by adding to media library by copy the music to the mediafolder" (which should be the folder in the aboved mentioned location folder, sorry that my computer is in german so maybe i recite the option not in the precise english)

     

     

    wierd thing is after i did those two things, i reset them back to before i changed it, and still working... wierd....anyways, worked now.

     

    so i suggest u do those two things back and forth and try, i am pretty sure the solution should be in this advance perference window. just try.

     

    hope that helped.

     

    happy new year.

  • pmk1986 Calculating status...
    Currently Being Moderated
    Jan 8, 2013 12:03 PM (in response to chinaFitter)

    This was happening to me but as per a user earlier, going to Store > Sign Out, then issues appear in library.

     

    Sounds like a illogical and silly fix but worked for me!

  • laineyue Calculating status...
    Currently Being Moderated
    Jan 9, 2013 2:51 PM (in response to Boudjtastic)

    Sorry I skimmed some of the replies in this post.

     

    I tried the General > Preferences > Imort Settings > Higher Quality but still did not change the AAC encoder suggested here but it still doesn't work

     

    I'm adding .pdf files for Books in iTunes.. It worked fine for the past 2 days after upgrading my iTunes, but now neither add File nor add Folder options worked anymore.

     

    I restarted my computer still my iTunes does not add my .pdf nor my .mp4 files. The iCloud icon near the Music, Movies, TV shows and Books on my itunes sidebar seems to be processing (diagonal lines moving) but when I look on each Library folder no new files has been added.

     

    I'm using my ACER Aspire One netbook w/ a Windows 7 Ultimate in a 32 bit Operating System. The app I'm using to view my .epub & .pdf is iBooks, it just a free app.

     

    Any other suggestions please? or should I just uninstall and re install the iTunes program in my netbook, again?

  • pSyLoX Calculating status...
    Currently Being Moderated
    Jan 9, 2013 2:57 PM (in response to Boudjtastic)

    Hi All,

     

    I had exactly the same issue

     

    I have just installed a fresh Virtual XP, installed iTunes 10.7 (Yes i know not the latest version)

    I simply could not add most of my purchased movies

     

    However Cars2 & The Advengers could be added to the library

    The rest of my movies just didn't (with drag and drop / add folder to library)

     

    As mentioned above, Cars and the Advengers could be added

    If i Double Click them, there was some kind of a "pre-start-movie screen" with "play movie" buttons  etc

    (the movie could not be played)  < no quicktime installed

     

    Anyway.... i assume because of this " pre-start-movie" screen i could added them

     

    the solution to my problem was to install Quicktime !

    itunes 10.x doesnt have quicktime included !!

     

    After installing Quicktime i could add my other movies to my library

     

    Conclusion ????

    Could it be that itunes need some kind of a "pre-view"  of the movie ? before it can be added ??

     

    I mean, the 2 movies mentioned above could be added, because there some kind of a screen visible before the movie start (without quicktime they could not be played)

     

    Ciao

  • ncantor Calculating status...
    Currently Being Moderated
    Jan 11, 2013 6:29 AM (in response to Boudjtastic)

    Signing out of the iTunes Store worked for me, as well.

     

    Thanks, adams_apple

  • vrazionale Calculating status...
    Currently Being Moderated
    Jan 13, 2013 6:59 AM (in response to ncantor)

    signing out of the itunes store seems to be the trick. worked for me!

  • mike 2.0 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 17, 2013 10:22 PM (in response to Captinsmooth)

    signing out and in worked for me as well, so thanks!

     

    weird tick. hope they address this soon. was CRAZY frustrating.

  • DesKen44 Calculating status...
    Currently Being Moderated
    Jan 18, 2013 8:03 PM (in response to pmk1986)

    fantastic, works like a treat, after weeks of frustration this is a relief

  • minjigo Calculating status...
    Currently Being Moderated
    Jan 20, 2013 9:06 AM (in response to chinaFitter)

    DAnke, it worked like a treat for me!

     

    The Sign Out thing that worked for others didn't work to me. Your suggestions did. Can't say if it was either of them specifically because I tried both together, but bottom line is, it didi the trick!

     

     

    running mountain lion in a early '09 iMac.

  • farfetched0011 Calculating status...
    Currently Being Moderated
    Jan 21, 2013 5:40 AM (in response to Boudjtastic)

    Change your view to "Songs", instead of "Artists" or "Albums". My mp3 were displayed there.

  • denrun12 Calculating status...
    Currently Being Moderated
    Jan 24, 2013 11:10 AM (in response to ken.atwell)

    I, too, have been experiencing this problem with adding folders and files to the Music Library.  After trying numerous suggestions, I simply uninstalled iTunes completely and did a fresh install.  The library returned in its entirety and I can now add folders and files with no problem.  Took about fifteen minutes to do the whole process. 

  • Carl Bach Level 2 Level 2 (260 points)
    Currently Being Moderated
    Jan 31, 2013 11:41 AM (in response to Boudjtastic)

    I have been trying to fix this for weeks. It is true that if my MBP is asleep for several hours, when it wakes up, the music appears. However, what if I want to hear it now?

    I kept reading about the "recently added" playlist. It took me time to realize that this has to be created. I created a smart playlist called recently added and made the rule "added in last day". Now when I select this playlist, the music I just added does appear, however, it still doesn't show up in my "Music" yet. That is what I will have to wait for.

    Surprising that Apple hasn't addressed this. I imagine many people less technical have just given up.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.