Skip navigation

Apple Wireless Magic Mouse does not track/move but I can click and scroll/swipe

19682 Views 9 Replies Latest reply: Feb 10, 2014 11:14 PM by 95bulls RSS
Pedro Taquelim Level 1 Level 1 (25 points)
Currently Being Moderated
Jan 19, 2013 5:48 AM


My Apple Wireless Magic Mouse does not track/move the cursor on screen, but it's connected to the iMac bluetooth. The batterys are full. I also replace them with new ones.


I can left-click, right-click, double-click, scroll and swipe with one/two fingers. You name it! Everything works, except I cannot move the cursor, it does not track at all.


I started having this problem when I went on vacation and turned the iMac off and also disconnected the power cable from the power socket for a couple of weeks. When I came back and turn it on, the Apple Wireless Mouse had this problem. But still, I could make it work if:


1) I remove the mouse from the Bluetooth Preferences list clicking the "-" (minus) button and then put it back on again in the Bluetooth Configuration Assistant.

2) After a while I noticed that after a restart I could click the mouse and I could just wait a while (3 to 5 minutes) and the mouse will start moving again, although the cursor would not track/move and behave as expected for 1 or 2 minutes (jittery, jumpy, slow, fast), but after that 1 or 2 minutes would eventually come back to normal.

The problem would return after I would Pause the iMac. After I wake him up again the Mouse was not moving again and I had to go trough the process described on step 1 or 2 to make it behave correctly again.


I think, in the beginning when I restarted the iMac in Safe Mode (keep pressing Shift in the restart process) the mouse would behave normal. So I thought that this was a software problem/conflict with some third party login files, etc. I deleted the LaunchAgents form the User Library. Didn't work. And also look inside the folder StartUpItems in the System Folder, but it was empty. But now, even if I restart in Safe Mode the mouse doesn't move. :-(


Also, I tried all of this without success: less-mouse-clicks-but-won-t


Any ideas, please? I need help.



iMac (24-inch Early 2009), OS X Mountain Lion (10.8.2), 8 GB RAM DDR3 - NVIDIA GeForce 9400


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.