3 Replies Latest reply: Jan 20, 2013 3:48 AM by Demonlawyer
Demonlawyer Level 1 (15 points)

One of my aperture vaults is no longer backing up photos and when I try it crashes Aperture and causes Aperture to be rebuilt. Another vault works fine, so unlikely to be the program but the vault. Any ideas on what to do?


Presumably delete the dodgy vault and make a new one? Or is there a more simple fix known?

  • Frank Caggiano Level 7 (25,722 points)

    The quickest thing to do is to create a new vault. As vaults are just snapshots of the current sate of the library nothing will be lost by doing this.


    Of course trying to figure out what happened would be nice. If you have the room you can leave the bad vault in place for now and try and troubleshoot it later.


    One question I have, have you tried to recover from the bad vault and if so what happened?

  • Demonlawyer Level 1 (15 points)

    Hmm, this one is odd. I deleted the old vault and created a new one one the same external drive and it hit the same problem. I used Disk Utility which confirmed there was nothing wrong with the external drive. I then rebuilt the Aperture links using Opt-Alt keys when opening Aperture.


    I haven't restored from backup, only because my current library is more up to date and I wouldn't want to lose latest photos etc when its the backup drive that's experiencing problems. I have however created an additional backup drive now on a different external drive and that works fine.


    Sounds like it's an issue with the external drive maybe, but Disk Utility can't find any problems. I might just stop using it anyway just to be sure.


    All very odd.

  • Demonlawyer Level 1 (15 points)

    Second time lucky. Deleted it again and tried from scratch and it worked. I'm guessing it must have got corrupted at some point.


    The last time I created a new vault it got interrupted, so perhaps the fact that it created an uninterrupted back up this time it all worked fine.