Skip navigation

Much slower wake-up from sleep since upgrade to ML

77916 Views 191 Replies Latest reply: Nov 29, 2013 8:56 PM by whappen\'d? RSS
  • Erik421 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 18, 2013 1:13 PM (in response to leodanger)

    Ok leodanger I will go to try this tonight as your current setting.

     

    But why do you leave autopoweroffdelay to 14400 and autopoweroff to 0?? aren't they connected?

     

    Thanks, I hope also solve my problem!!

  • Erik421 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 18, 2013 1:55 PM (in response to Erik421)

    Ps: sorry… and standbydelay why 4200??

     

    Thanks

  • leodanger Calculating status...
    Currently Being Moderated
    Jan 18, 2013 2:10 PM (in response to Erik421)

    If it's turned off, the delay is irrelevant. You could leave it on and give it a massive delay if you wanted.

     

    Should add that I DO still get a problem waking if the machine enters dark wake after pulling the lead, before opening the lid. However, this is still far less of a problem that the issues before (and if I open the lid before pulling the lead, it's fine).

     

    Hopefully Apple will bring us a real solution soon...

     

    Nt sure about standby delay. All I can tell you for sure is that setting autopoweroff to 0 solved it for me, and others. Please let us know how you get on...

  • Erik421 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 18, 2013 2:25 PM (in response to leodanger)

    Ok thanks.

    Learn please my post on page 7 (post with image o loading bar). Had the same problems??

     

    Thanks but this problem it's driving me crazy!!

  • leodanger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 18, 2013 2:32 PM (in response to Erik421)

    This is the same issue I had Erik, and have now solved.

     

    By the way – if this solves the problem, please click like on the post giving the solution. Hopefully this will make it clear for others looking for an answer.

  • crackers8199 Calculating status...
    Currently Being Moderated
    Jan 18, 2013 2:35 PM (in response to leodanger)

    i'm giving this a shot, but modified a little...instead of changing autopoweroff to 0, i changed autopoweroffdelay to 86400 (24 hours).

     

    i'll leave it plugged in when i go out tonight, and we'll see if anything happens when i get home six hours or so later..

     

    Active Profiles:

    Battery Power                    -1

    AC Power                    -1*

    Currently in use:

    standbydelay         4200

    standby              0

    womp                 1

    halfdim              1

    hibernatefile        /var/vm/sleepimage

    sms                  1

    networkoversleep     0

    disksleep            10

    sleep                0

    autopoweroffdelay    86400

    hibernatemode        3

    autopoweroff         1

    ttyskeepawake        1

    displaysleep         5

    acwake               0

    lidwake              1

  • crackers8199 Level 1 Level 1 (0 points)

    i want to confirm that my above solution seems to have worked. i left the MBP plugged in and lid closed with the above settings for around 9 hours or so, and came home to open the lid and have an instant wake.  no white screen with the loading bar...

     

    seems leodanger is onto something...autopoweroff and autopoweroffdelay seem to be the settings we need to focus on.

  • leodanger Level 1 Level 1 (0 points)

    Cool – If you leave you computer for 24 hours, then check your sleep logs (pmset -g log), you'll see the issue happen then.I spent a few weeks trying stuff to track this down, and also found another user on another thread who was coming to the same conclusions. He'd posted the settings for turning autopoweroff off, which I didn't know how to do.
    I set myself an alarm and watched my MBP as it approached 4 hours... at that time, I watched the lamp on the front of my laptop extinguish, so I knew it was going to be a problem to wake.
    The proof is found in looking in the sleep logs.I decided agaist setting a long time to autopoweroff, as if I don't use the machine for a while, it'll still annoy me.
    I'm going to send these pages, and what I've done, to the very helpful Apple technican who's been looking after my case. It must be difficult for them to diagnose problems based on our ramblings (though there do seem to be quite a few people complaining of this issue now).

    I still have an minor issue with unresponsiveness if the computer has just been put to sleep then is re-awoken, but this is the same as my old MacBook. We still have that machine, running Snow Leopard, and there is no option for autopoweroff... makes sense to me to turn it off. However, I will ask Apple what this setting actually does!

  • Erik421 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 3:20 AM (in response to leodanger)

    I confirm that the solution of LEODANGER has FIX  MY PROBLEMS!!!

    I used the same setting of leodanger. All night plugged in, and when I open the lid mbp was ready to go

    Today I'm gone try to set standbydelay.

     

    Great LEO!!! You are ours hero!!!!!!

  • mxo11 Level 1 Level 1 (25 points)

    @crackers8199: I'm trying your solution, too (rather than changing the autopower off to 0).  I'll keep you all posted...

  • leodanger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 7:56 AM (in response to mxo11)

    Or you could just try changing the delay to 300, which would be five minutes. Than watch five minutes after sleep (with the AC in), as the light on the front goes out completely, then your laptop won't start up cleanly. All you're doing by turning autopoweroff off, is stopping what happens at the end of the time you set.

  • W M R Level 1 Level 1 (145 points)

    I deleted the Power Management preference file (com.apple .PowerManagement.plist), then I shut down my MacBook Pro, I did a SMC reset (shift control option and power) and a PRAM reset (Option Command P & R) before booting it again.

     

    I never had any problems ever since! Big relief, because it really bugged me!...

  • leodanger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 10:46 AM (in response to W M R)

    That was lucky! I tried that and didn't have any joy! I also reset all my permissions, but still no luck. See you also have a Mid 2012 MBP... weird! Am going to try that now, and see what happens tomorrow morning. Will turn autopoweroff back on first...

  • W M R Level 1 Level 1 (145 points)
    Currently Being Moderated
    Jan 19, 2013 10:47 AM (in response to leodanger)

    I didn't do anything else and waited a few days befor posting, but it really fixed it!

  • crackers8199 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 10:58 AM (in response to leodanger)

    also worked flawlessly this morning...just for the **** of it, i pulled the power cord this morning before opening the lid.  normally, that would have triggered the problem...but it worked fine.  autopoweroff and autopoweroffdelay seem to most definitely have something to do with the issue...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.