Skip navigation

Captions in Aperture not exporting to versions when original already has a caption

1774 Views 15 Replies Latest reply: Apr 19, 2013 11:04 AM by CactusTree RSS
1 2 Previous Next
CactusTree Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 11, 2013 2:36 PM

I’m having problems with captions written in Aperture not exporting to exported versions. If anyone has ideas, please post them. Also I would like to see if others are having this problem. Sorry about the long post.


I’m having a difficult problem with the inability to write captions in Aperture and have them saved in exported versions. This occurs only when the original master already has something in its caption. While in Aperture, everything looks fine, but upon exporting as a VERSION, the exported version will still show the previous caption that was in the original master and not the new caption from Aperture. This can be seen by looking at the information in Preview, Graphic Convertor (which shows the both the correct newer caption in the “IPTC caption abstract”, and the incorrect original caption in the IFDO Image description, XMP-dc and EXIF image title), or upon reimport to Aperture. When the newly exported version is reimported into Aperture, it will continue to show only the incorrect older caption. This will occur with photos from any camera.   Exported MASTERS with “include IPTC” checked will export correctly, unless the problem comes from a camera caption preset (see below).     Keywords and “most” other metadata do not seem to be affected (there are some issues with copyright and contact info).


It is easy to test: Import a photo into Aperture, add a caption to the photo in Aperture, and export it as a version. Then reimport the exported version, then change the caption to something different, and export it again as a version. Then open it in Preview and review the information (command-I), or reimport this photo into Aperture and look at the caption - it will continue to show the first caption, and it will not show the newer caption.


A related problem with somewhat different behavior occurs with several camera models which seem to have a preset caption in the metadata which is exported with their photos (many Canon models have many “empty spaces”, and several Olympus cameras  have “OLYMPUS DIGITAL CAMERA”, and I believe some Nikons also have a similar issue). In these cases, the original master already has a “caption” (even if it appears blank), and even though you have added a caption in Aperture, upon exporting a version, the caption will retain the camera caption preset, and the caption written in Aperture is not visible.     This problem must be slightly different because if you export a Master (with IPTC) from these photos with a camera caption preset, the caption is still incorrect (ie empty spaces for the Canons and Nikons or the “OLYMPUS DIGITAL CAMERA” for the Olympus cameras); whereas for photos with embedded captions in the originals (i.e. previously exported from Aperture),  then the exported MASTERS (with IPTC) will have the correct caption.


Both problems (ie the one with previous captions from any source in the original and the one with the camera preset captions) have surfaced since updating from Aperture 3.3.2 to subsequent versions, currently at version 3.4.3.  I have a Cannon PS-230 HS camera, which previously did not have any issues; but since updating from version 3.3.2, Aperture always reads the initial caption upon import as a series of about 20-30 empty spaces. When a new caption is written in Aperture, the “empty spaces” caption overrides the new written caption in all exported versions and exported masters. This is the very same photo without any changes and in the same Aperture Library which exported correctly with Aperture version 3.3.2.  The same behavior is noted in photos from 2 different cameras of the same type, so it is not a corruption in the metadata of one camera.  It must be something in the way Aperture reads and writes metadata.


I am able to avoid this problem with the camera presets if PRIOR TO IMPORT to Aperture I take the photos and use terminal and EXIF TOOL, and after changing directories to the location of those particular photos run the terminal command


exiftool -P -r -overwrite_original_in_place -m -EXIF:ImageDescription= (place file path here)


(I placed a previous post about 2 years ago with more details on how to do this, but notice that parts of the command are incorrectly underlined in that post; they should be as posted above. Here is the long winded link: Loss of Captions only in Olympus Camera photos  that might help a terminal neophyte like me).


I can then import them and they will behave normally (i.e. they will export a version with a new caption once only). However, once they have been imported to Aperture, this will not work unless you get the original masters, run the EXIF Tool script and then reimport them. You will then have to individually paste all metadata and adjustments to the reimported masters from the ones that you already worked on in Aperture.  Obviously not very practical if you have thousands of photos like this, and then you still have the problem of being able to add a caption to an exported version one time only.


Unfortunately, for some reason this doesn’t help the problem with originals that already have captions in them. I have tried over a hundred different ways of working around this without any luck, including using EXIF tool exiftool -P -r -overwrite_original_in_place -m -EXIF:ImageDescription= -XMP= /Current\ Aperture\ Photo\ Projects/FolderEXIFChange, Exif tool exiftool -iptc:all= -tagsfromfile @ -all:all -unsafe  ./ (I have no idea what that does, but previous posters have had some success with this), different import and export parameters, consolidated vs. referenced, repaired permissions and prefences, etc.  in all kinds of different orders and it still does not work.


The only thing that seems to kind of work is to export a Master “with IPTC” after changing the caption to the way you want it, then reimporting it and pasting all of the adjustments you made from the original in Aperture to the reimported photo. You will have to repeat the whole process any time you change the caption again in the future, but at least any exported versions will have the correct caption.    (Please notice that this will not work if you have one of the “camera preset caption” problem, and you will have fix that with the EXIF Tool as above first.)


This is a very poor solution for this problem. It must be possible for Apple to fix this problem as it was working well before the recent Aperture updates. If you have any ideas on other methods to get this to work, please post a comment!


This is a BIG problem for users, and if it becomes widespread could cause Aperture to lose credibility with users. It's very easy to not notice it until after you've written thousands of captions, and to then realize that it doesn't export is enough to make many people give up on the whole thing. I hope it has a solution soon.

iMac mid 2010 i7, Mac OS X (10.6.4)
  • léonie Level 8 Level 8 (46,335 points)

    I tried to reproduce your issue - and found that indeed the version does not export a modified caption.


    Even with the the command "Metadata > Write IPTC Metadata to Original" or "Metadata > Batch change" in combination with "Apply to original files" did I not succeed to export the caption of the versions.


    That looks buggy to me.




  • Frank Caggiano Level 7 Level 7 (22,745 points)

    I'm also seeing the same behavior.  For some reason there is a tickle in the back of my brain concerning this but for the life of me I can't figure out what it is but it sure sounds familiar.


    I'll try to search for this tomorrow to see if anything turns up.

  • Nigel Paterson1 Level 1 Level 1 (5 points)

    I just found your post after posting my question on the same topic.


    I think the problem is more a field-mapping bug, with Aperture exporting information from the Image Description field (which is non editable, and contains OLYMPUS DIGITAL CAMERA if I'm not shooting with one of my Canon cameras) instead of the Caption field.


    To make matters worse, PhotoShop reads this export as 'Description' and Lightroom as 'Caption'.


    Currently I am exporting from Aperture and captioning in Lightroom, where I can get rid of OLYMPUS DIGITAL CAMERA. Re-importing images back into Aperture displays the correct caption.


  • phosgraphis Level 2 Level 2 (285 points)

    Take a look at this thread:

    Exports Don't Include IPTC/Copyright Info


    What you are seeing might be related, especially the part about IPTC info not showing up in Preview (and others) but showing OK in Photomechanic (and others). Will test it with your situation when time permits.

  • David Strait Level 2 Level 2 (175 points)

    I have the same issue..... Years ago, I added caption information from thousands of older (pre-2006) scanned JPEG photos using PhotoShop and imported them in Aperture in 2006. Recently, I have edited the captions of these old photos extensively in Aperture. On export, the photos only include the old captions and none of the new edited caption information. I first noticed that only the old caption data was exported when I uploaded the photos to a SmugMug gallery and the edited caption data was missing. I then looked in the "Preview" inspector and found that only the old caption data was listed in the IPTC data. I then used "Get Info" from the Finder and again saw the old caption data was listed under "description."


    I searched every metadata field available in Aperture (EXIF, IPTC, Aperture, Custom, etc) and I can not find where the old caption data is stored (interesting that you found that Graphic Converter displays both old and new captions). Only the newly edited caption data is shown. I can see no way to change the caption info from these older files. Newly scanned photos (with no previous caption data) are OK and I can edit the caption data in those files with no problem. This is (by far) the biggest issue I have had with Aperture. I would consider switching to Lightroom (which also has direct export to SmugMug - a feature I've requested) , but I can't even export the metadata for thousands of photos to another application!


    I gave feedback to Apple, but I am very disappointed to hear you have had this problem for years with no respose from Apple.


    This is a HUGE issue for me!

  • David Strait Level 2 Level 2 (175 points)

    Cactus Tree,

    Thanks for your suggestion! I also found out the following:


    I downloaded GraphicConverter (free trial version 8.5.3) to inspect metadata fields not visible in Aperture. For an OLD photo that had a caption before importing into Aperture, I found the OLD caption listed in these locations:

    1) the EXFI tab as IFD0 data field: "Image title"

    2) under the EXFITool tab as IFD0 data field: "Image Description"

    3) under the EXFITool tab as XMP-dc data field: "Description"

    4) under the XMP tab


    The NEW caption (for the OLD edited photo) was listed ONLY under:

    1) the EXFITool tab as IPTC data field: "Caption-Abstract."


    For an OLD photo that had a caption before importing into Aperture AND I never edited the caption, I found the OLD caption listed in these locations:

    1) the EXFI tab as IFD0 data field: "Image title"

    2) under the EXFITool tab as IFD0 data field: "Image Description"

    3) under the EXFITool tab as XMP-dc data field: "Description"

    4) under the XMP tab

    5) the EXFITool tab as IPTC data field: "Caption-Abstract." (where the NEW caption was listed above)


    This indicates photos imported with OLD caption info include captions in IPTC, EXFI and IFD0 data fields.


    I also completed a search of the OLD caption in Aperture and it found the correct photo even though the caption does not show up in any "visible" data field in Aperture (interesting!).


    For a "NEW" photo that never had a caption before importing into Aperture, the caption is listed in these locations:

    1) the EXFITool tab as IPTC data field: "Caption-Abstract." (same as NEW caption above)

    2) under the EXFITool tab as XMP-dc data field: "Description"(same as OLD caption above)

    3) under the XMP tab (same as OLD caption above)


    Its is NOT listed

    1) under the EXFITool tab as IFD0 data field: "Image Description" (where OLD caption was listed above)


    This all seems to indicate that OLD caption data is over-written in the IPTC data field when the caption is edited in Aperture, but somehow doesn't over-write the OLD captions in the XMP data fields (even though NEW captions write in those fields).  Aperture doesn't seem to use the IFD0 datasets at all for caption info.


    FINALLY, I tried your suggestion (Write IPTC to original) and found out the NEW caption writes into ALL the data fields (IPTC, XMP and IFD0), just like an OLD photo with OLD captions that weren't edited (i.e. it writes to the IFD0 field that isn't normally written to when adding captions in Aperture. Weird.


    This seems like it should be a simple fix (for Apple)…… but what do I know?


    Thanks again for your suggestion.



  • David Strait Level 2 Level 2 (175 points)

    This just gets worse.


    I used your suggestion to write IPTC metadata to the originals and it worked OK… once. The second time I tried it caused Aperture to crash and it replaced the caption information with 11 blank spaces (the captions appeared empty, but actually had 11 spaces). I attempted to fix the library with 1) repair permissions, 2) Repair database and 3) Rebuild database. None of these recovered my lost captions so I had to restore my entire Aperture Library from a vault.


    Not all photos I wrote the meta data to lost the captions, so I wasn't really sure if this was the cause of the problem. Since I have no other option to export photos with captions, I (stupidly) tried it again with exactly the same result. The first selection worked fine and the second attempt crashed Aperture and I lost the captions again. I skipped all the repairs and I am currently restring my library again from the vault.


    Apparently you haven't experienced this problem, but I caution you (and others) against using "write metadata to originals."



  • David Strait Level 2 Level 2 (175 points)

    I greatly appreciate your thoughts on this. I have a few comments based on my attempts to fix this issue.


    1) I get the 11 empty spaces with either one of several cameras, plus on scanned images so It doesn't appear to be related to camera preset issue discussed elsewhere.


    2) I may consider exporting the Master as you described (as a last resort). I have thousands of photos with the problem and this will take quite a bit of time.


    3) Not sure if I fully understand this point. I restored the library from a vault that was updated a few days ago, thus it contains the old photos with the old and newly edited captions (The new captions are the only ones visible in Aperture). I think I would prefer to attempt #2 (export, then re-import) if it comes to that.


    4) You may be correct about the crash. The first time I wrote the IPTC data to original, I selected ~5000 photos (it did not crash at that point). First, I exported ~ 100 photos (and it worked properly with updated captions), then I exported the next ~100 photos (when it crashed and caused the "11 space" issue). Oddly, the "11 space" issue impacted not only the 100 photos I exported, but hundreds of others I did not export (but did write the IPTC data to). The second time (after restoring the library from the vault),  I only wrote the IPTC to ~100 photos. I successfully exported ~ 50 photos (with updated captions), but the next 50 I exported crashed Aperture and resulted in the "11 space issue" in ~ 200 photos. This is so flakey I am never going to attempt this again!


    btw - I have all my edited captions after restoring the library…. I haven't lost them.


    5) I am also going to wait on Apple for a fix. I have sent them feedback three time on this issue so far (including the separate, but possibly related "11 space" issue after writing the IPTC metadata to original.


    As a last resort, I may try your #2 suggestion. At least the problem shouldn't come up again after I fix all my old photos.


    Thanks again,


  • David Strait Level 2 Level 2 (175 points)


    I just tried to export captions with 3.4.4. I think it is working correctly now!


    Caveat: I just tried one photo before going to bed. Is it working for you now?



1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.