Skip navigation

Cannot open my pc's shared library.

387 Views 2 Replies Latest reply: Jan 31, 2013 6:14 AM by 75alex RSS
75alex Calculating status...
Currently Being Moderated
Jan 20, 2013 7:25 AM

Hi everybody, since a couple of days i have a problem with home sharing via WIFI on one of my computers. It worked perfectly on both PCs before, but now PC 1 can grab music or others things from pc 2 even if home sharing is disabled, but PC 2 cannot open pc 1's library. When iTunes opens on pc 2, it just says "looking for newly bought products on pc 1 library (something like that, just translated it from french ), and just stays like that forever ! If i click on the cross next to this, and then try to open the shared library it just says "loading" for 15 seconds then nothing, just as if i had not click on it. I tried rebooting both computers, turning off then back on home sharing, disconnect from internet or apple store but none of these had worked so far. Thanks a lot for helping me resolve this problem.

iTunes 11, Other OS, Windows 8 Pro x64


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.