Skip navigation

Aperture 3.4.3 crashing

2258 Views 30 Replies Latest reply: Feb 8, 2013 9:07 PM by pastorpaul RSS
1 2 3 Previous Next
Maneman Calculating status...
Currently Being Moderated
Jan 19, 2013 10:53 AM

I am having continual problems with Aperture 3.4.3 crashing when uploading to Facebook.  I am currently using MAC OC 10.7.5.  Does anyone have any ideas how to fix this?

Aperture 3, Mac OS X (10.7.5)
  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Jan 19, 2013 12:11 PM (in response to Maneman)

    Did this happen directly after upgrading to Aperture 3.4.3?

     

    The problem with the Aperture 3.4 update is, that in some cases it did not install the correct "Account Configuration" plug-in, and so the FaceBook publisher plug-in will not work. This is supposed to be fixed  by installing the update 3.4.1 update, but if you directly upgraded to 3.4.3 you might have missed the bug fix with the 3.4.1 update. When you look at your crash log - does the crashed thread contain calls to the "FacebookPublisher"? Then it probably will help to reinstall Aperture from the original media, as described in this support article:

     

    Aperture 3.4: May quit unexpectedly on launch after updating

     

    If the crash log does not contain calls to "FacebookPublisher", then post the first 60 lines of the log, maybe we can learn something from the error message.

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Jan 19, 2013 2:23 PM (in response to Maneman)

    Yes, that is exactly the kind of crash, that requires reinstalling Aperture.

     

    How to reinstall will depend on how you bought Aperture. Didyou buy from the AppStore, Apple Store,or do you have the boxed retail version?

     

    The support article I linked to, explains how to reinstall, depending on the way you bought Aperture.

    Aperture 3.4: May quit unexpectedly on launch after updating   http://support.apple.com/kb/TS4412

  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Jan 20, 2013 8:27 AM (in response to Maneman)

    Then follow the reinstall instructions in this paragraph - it contains a download link for the

    Aperture 3.1 Trial.

     

     

    If you originally installed Aperture 3 from a trial version:

    1. Go to the Applications folder and delete Aperture.
    2. Download the Aperture 3.1 Trial.
    3. Open the Aperture Trial disc image.
    4. Double-click the "Aperture Trial.mpkg" file.
    5. Follow the onscreen instructions to install Aperture.
    6. After the installation completes, choose Software Update from the Apple () menu.
    7. Install the Aperture 3.4 update from the list of available updates.

    It is essential to update immediately after reinstalling, before you try to launch Aperture. The 3.1. version will not be able to open your Aperture library.

     

    Good Luck

    Léonie

  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Jan 20, 2013 10:39 AM (in response to Maneman)

    Would it just be better if I trash my Aperture application and purchase the latest version from the App store?

    That would not help. You'd buy exactly the same code as you are running now.

     

    Have you sent your crash reports to Apple?

    if you deleted Aperture and reinstaled from the original disk image this particular bug should have been fixed.

    Unless other preference settings, startup items, installed helper items particular to your user account are interfering. Do you have firewall software, or other software that might be preventing network access?

     

    Can you upoad to facebook, if you export your images from Aperture and upload directly using Facebook's web interface?

  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Jan 20, 2013 11:29 AM (in response to Maneman)

    It should install all updates correctly, if you go directly from 3.1 to 3.4. It is essential to skip the 3.3 updates. One of them installed a wrong account configuration plug-in.

     

    It might be a good idea to upgrarde 3.1.  ->   3.4.1  -> and then to the current version. The 3.4.1 upgrade contains the FaceBook fix, see  http://support.apple.com/kb/DL1597

    I do not have firewall software that I know of

    No Little Snitch?

    What preference settings and startup items should I check?

    Any non-Apple software that deals with media or network.

    For checking preferences and presets see: Aperture 3: Troubleshooting Basics

  • Frank Caggiano Level 7 Level 7 (22,805 points)
    Currently Being Moderated
    Jan 20, 2013 11:49 AM (in response to Maneman)

    Has this been tried with diffeent images>? Has this been tried from a different library? Different user account?

     

    Message was edited by: Frank Caggiano

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.