Skip navigation

Canon MX870 Printer will not recognize network

3089 Views 5 Replies Latest reply: Jun 7, 2013 1:31 PM by Paul Boyer1 RSS
puckish88 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 20, 2013 12:15 PM

Just moved to a new apartment that uses an airport express as a wireless router (instead of the linksys router I had at my old place).  When I turn on my Canon MX870 printer to connect it to the LAN, the network simply does not show up.  All my other devices (multiple other computers, iphone, etc.) have no problem recognizing and connecting to this network, but for some reason it's not showing up on the MX870, and so I cannot get it connected to the LAN.  It is recognizing other networks in my building, just not mine.  Is there somekind of compatitbility or security setting issue with connecting the MX870 printer to a LAN via an airport express?  I even tried turning security completely off on the airport to see if that would do the trick to no avail.  I have installed all drivers, etc., on my computer, but that should not make a difference as the issue is one of simply getting the computer to recognize and connect to the network created by the airport express.  Tried restarting printer, router, modem.  Any help would be appreciated.  Thanks!

MacBook Pro, Mac OS X (10.5.6)
  • CMCSK Level 6 Level 6 (10,215 points)
    Currently Being Moderated
    Jan 20, 2013 12:28 PM (in response to puckish88)

    Snow Leopard & Lion Printer solutions and suggestions.

     

    Printer troubleshooting for AirPort Base Stations and Time Capsule

     

    Installing the Gutenprint and Gimp-Print for Mac OS X (10.2 and later) may help.

     

    I have installed all drivers, etc.,

    Updated drivers?  What are the etc. if other than drivers?

     

     

     

     

     

     

     

     

     

     

    dancingsmilie.gif

  • Den4tennis Calculating status...
    Currently Being Moderated
    May 31, 2013 9:21 AM (in response to puckish88)

    Hi all,

     

    Had same problem with Canon Pixma MP640. Printer is directly connected by Ethernet to Netgear wireless router to join the LAN. Laptops around the house (on wireless) stopped seeing the printer, it wouldn't appear in the "add printer" list and we couldn't print (no matter how many canon software reinstalls/updates and resets we did!). FIGURED IT OUT TOO. Its a CANON NETWORK IJ discovery problem. IT DOESN'T like 5 GHz band routers!!

    I had recently changed router to a DUAL BAND Simultaneous 5/2.4 GHz Netgear. (previously Belkin 2.4 GHz). Also installed a Trendent Access point DIRECTLY connected by cable to router to extend wireless coverage. Access point is 2.4 GHz only.

    So when laptops are near enough to the Netgear router, they join automatically (by preference) on the 5 GHz band. (you can see what access point/router and what band your device has joined on by holding down ALT key + click the wireless icon up in the menu bar. Get detailed info then). Laptop becomes 'blind' to the printer.

    When move away to another part of house laptops tend to join on the 2.4 GHz band (because signal is stronger because 5 GHz suffers more attenuation and doesn't travel as far as 2.4 GHz) and hey presto!! can now print!

    So its some subtle wirelss protocol thing with the Canon even though the canon isn't communicating directly via its own built-in wireless (use this if you wanted an 'ad-hoc' network instead of a proper LAN). The canon is directly wired to router and should use the router's wireless link thereafter but 'objects' to the 5 GHz wirelss link band.

  • Paul Boyer1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 7, 2013 1:31 PM (in response to puckish88)

    When I try to print with my Canon imageCLASS MF4370dn, I get: “No destinations have been added to the [Destination List].”

    What is the Destination List?  What am I supposed to do with it?  What is the destination whereof they speak?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.