Skip navigation

Home Sharing Not Working

525 Views 6 Replies Latest reply: Feb 22, 2013 12:25 PM by slashinpdx RSS
taddfromjenks Calculating status...
Currently Being Moderated
Jan 19, 2013 1:29 PM

I turned on Home Sharing on both PCs, but the shared libraries aren't showing up where they should be.  I closed and restarted both PCs.  what am I missing?

  • jushooks Calculating status...
    Currently Being Moderated
    Jan 19, 2013 2:46 PM (in response to taddfromjenks)

    It's a software issue with Apple and it's driving me nuts as well.  I don't know why apple doesn't care and isn't fixing this.

  • Steve Taylor1 Level 5 Level 5 (4,660 points)
    Currently Being Moderated
    Jan 19, 2013 10:05 PM (in response to taddfromjenks)

    It works exactly as advertised on my machines. Try working through the Troubleshooting guide to see if you missed anything

     

    TroubleShooting Home Sharing

  • ronj2012 Calculating status...
    Currently Being Moderated
    Jan 20, 2013 12:39 PM (in response to taddfromjenks)

    I am having this issue too, but I don't know who to blame: me, Apple, or Microsoft.

     

    Can anyone help me out please?

     

    My home sharing was working perfectly fine until about three days ago. Nothing changed that I know (I know this just doesn't sound right but it's the case!) has changed in my setup.

     

    Itunes is running on a Windows XP PC. I have an iphone 5 and an apple TV (about 1 month old) that have been working with home sharing flawlessly. Iphone 5 has been working flawlessly with home sharing since October 2012.

     

    I updated iTunes to 11.0.1.12 on Jan 7. Everything was still working fine until about Jan 17th.

     

    Now Apple TV doesn't even see the pc is available. My iPhone does not offer up the "shared" library name any longer as it used to when in my wifi zone (I know where to look: under the three dots in "Music" it always became available when I was home and I selected it and all was fine- all automatic and all seemless.

     

    What has happened? I have read posts for days and restarted everything, toglles all home sharing settings, toggled the router in all sorts of combinations. What has changed? Any help at all from anyone would be gretly appreciated!

     

    Thanks!

  • ronj2012 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 20, 2013 1:01 PM (in response to ronj2012)

    I have been wokring on this for days and about 20 seconds after posting my previous post, I found the problem. Thanks to everyone on here who contributed to the solution - which looks to have been around for quite a while. It wasn't me, Apple, or Microsoft - it was VERIZON's ACTIONTEC router setting.

     

    I *disabled* the setting (advanced->igmp->enalbed/disabled) and instantly everything worked. There are lots of posts and happy responses to this fix in these forums.

     

    My only questions are 1.) HOW did this value change on it's own or 2.) if it didn't change, why did its "enabled" setting start misbehaving and prevent the Bonjour services from working properly? I am absolutely confident that I did not change this setting manually - I never touch the "advanced" stuff in the Verizon gear.

     

    Anyway, in case you have the same problem, to summarize:

     

    I have a windows xp machine (hanging on to XP for dear life :-) hosting my iTunes 11.0.12.1 library.

    iPhone 5, Apple TV 3, and an iPad mini.

     

    I upgraded to iTunes 11 long before the problem started, and the home sharing was working fine for months, even well after the iTunes upgrade to version 11.0.12.1.

     

    Home sharing was working and then unexplainably stopped - copletely stopped. Apple TV acted as if no PC was available at all. I stopped getting the "shared" option on my iPhone and iPad under the "three dots selection" in the "music" task. I had toggled everything multiple times...

     

    CHECK YOUR IGMP SETTING IN YOUR VERIZON M1424 ROUTER! :-)

  • Jortega3 Calculating status...
    Currently Being Moderated
    Jan 20, 2013 5:43 PM (in response to ronj2012)

    Thank you for this!!!! Disabling igmp proxy on my Verizon router worked for me.

  • slashinpdx Calculating status...
    Currently Being Moderated
    Feb 22, 2013 12:25 PM (in response to Jortega3)

    Home Sharing wasn't working.

     

    Dlink DIR-651 - enable multicast streaming worked for me. It's found on the Advanced / Advanced Network page (at the bottom).  It was disabled by default.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.