2 Replies Latest reply: Jan 20, 2013 1:55 PM by Stephen.Smith
Stephen.Smith Level 1 Level 1 (135 points)

My Canon t3i takes mpeg4 video as MOV files.  I could import those into iPhoto but they wouldn't sync to my iPad or iPhone.  So I had created a quick script to batch convert them to M4V with lower bitrate so they could import to iPhoto and sync to my devices just fine.  This had been working for a long time.  But... now when I try to import the transcoded M4V or even the original MOV I get an error "Unreadable Files: XX The file is in an unrecognized format".  My M4V that are already in my library can play just fine within iPhoto and continue to sync.  I cannot import new movies but photos work fine.  I even tried opening the original MOV in Quicktime and exporting it there to iPad/iPhone with the same failed result on import.  My iPhoto library is on my network share which has not changed.

 

Anyone else having the same issue recently or any idea what could be the problem?  Thank you.

  • 1. Re: iPhoto 11 no longer imports camera movies
    Terence Devlin Level 10 Level 10 (123,850 points)

    My iPhoto library is on my network share which has not changed.

     

    That's the problem.

     

    iPhoto needs to have the Library sitting on disk formatted Mac OS Extended (Journaled). Users with the Library sitting on disks otherwise formatted regularly report issues including, but not limited to, importing, saving edits and sharing the photos.

     

    You've been lucky that it worked till now.

  • 2. Re: iPhoto 11 no longer imports camera movies
    Stephen.Smith Level 1 Level 1 (135 points)

    You are right about the network share.  I put the movies on my mac mini server and was able to import them into iPhoto running directly on the server.  Pretty odd though since the share is AFP on an external disk formatted Mac OS Extended Journaled and had been working great all this time with no changes in the network or sharing.  I'm guessing something Apple slipped into an update may have broke it.  Oh well, guess I'll have to keep importing movies on the server itself from now on.