Skip navigation

iphoto corrupting photos from iPhone while importing

12514 Views 64 Replies Latest reply: Jul 28, 2013 11:34 PM by Terence Devlin RSS
  • kalkalith Calculating status...

    Me too. MacBook Pro 15" 2010, iPhone 4, Image Capture & iPhoto.

  • jaydeman Calculating status...

    Me too. MacBook Pro 15". OSX 10.6.8  iPhone 4 , iPhoto '11 9.2.3 .  I've reported this to their iphoto feedback page, for what its worth.

  • peter_watt Level 2 Level 2 (395 points)

    Terence Devlin wrote:

     

    Not sure the issue is with iPhoto. It may still be on the phone.

     

    ...

    I think you were right. With the only common factor in all these posts apparently being iphone4, and all the different versions of osx and iphoto and image capture reported, i would favour an iphone4 interface problem.  All the theories that emailing is OK so it can't be the phone are flawed arguments.

  • Zshan Calculating status...

    I am also facing same problem iphone 4s

    All photos are corrupted....how to get them back very important Photos...

  • cannon1000 Calculating status...
    Currently Being Moderated
    Aug 12, 2012 5:47 PM (in response to Emmangt)

    I am having the same problem as well.  iMac OS X 10.6.8   iPhoto '11.  I have been using macs for years and updated iPhoto on just this mac.  All software up to date.

     

    iPhone 4S - updated w/latest software

     

    I record a lot of videos...and iPhoto will reject most of them as incompatible format (but will import some of them - approx  2 out of 15).   One video was corrupted, the other was fine.     Also corrupted a photo w/same type of vertical striping as in these photos.

     

    I do not get any of these issues when using iPhoto 10 on my MBP.

     

    One note - for some reason - iPhoto refuses to automatically start w/either SD card or my iPhone...so I did a manual import using the menu option.

     

    Since iPhoto failed to import most of the videos, i used iExplorer and copied the videos without any issue.

  • eidolonical Calculating status...
    Currently Being Moderated
    Sep 29, 2012 10:27 AM (in response to Emmangt)

    Obligatory me too, however I have overcome the base issue by simply never syncing photos whilst iTunes is syncing the iPhone.   My workflow is now using Image Capture to download the photos after the sync with iTunes is complete.  When doing this I have not had a single corrupted photo ... Yet ...  I delete after I've confirmed the photos are safely on disk, and then import into iPhoto.

     

    I still have problems with iPhoto as parts of the library is corrupt with a batch of photos linking to the wrong originals, yet have the correct thumbnail (two iPhones sync to this library).  So this problem, or something related has lost/corrupted ~ 100 photos.

  • odysseus Level 3 Level 3 (910 points)

    For what it's worth, the corruption issue is fixed in Mountain Lion (10.8).

  • keepongrowing Calculating status...
    Currently Being Moderated
    Nov 18, 2012 12:43 PM (in response to odysseus)

    I do have the most current Mountain Lion (10.8.2), and iPhone 5, and the problem is worse than ever. Ugh.

  • Kren Calculating status...

    Hello, iPhone people -- wanted to let you know that this is NOT an iPhone problem as I do not have an iPhone and have the same problem as y'all. It is a Mac problem. I have corrupted images that are imported on my computer; I go to my husband's MB and import the same images and they're fine on his computer.

     

    He's got a newer MB, a newer OS and a newer iPhoto.

     

    Too many variables to nail it down at this point, but wanted to alert you that this is not your iPhones.

  • odysseus Level 3 Level 3 (910 points)
    Currently Being Moderated
    Jan 19, 2013 7:05 PM (in response to Kren)

    There aren't too many variables. As I had written earlier on this thread, the corruption issue is fixed in Mountain Lion (10.8). One has to upgrade to Mountain Lion in order to solve the problem.

  • BigFellaNZ Calculating status...

    odysseus wrote:

     

    There aren't too many variables. As I had written earlier on this thread, the corruption issue is fixed in Mountain Lion (10.8). One has to upgrade to Mountain Lion in order to solve the problem.

     

    I don't believe Mountain Lion fixed the issue - I'm on 10.8.2 with iPhoto 9.4.2 conecting to an iPhone 5 (firmware 6.0.2) on a 2010 Macbook Air and still have the same problem.

  • odysseus Level 3 Level 3 (910 points)

    Well, Apple believes that the issue is fixed in ML, so if you think otherwise, it's best to submit a bug report ;-)

  • hughfromnewquay Calculating status...
    Currently Being Moderated
    Feb 18, 2013 4:54 AM (in response to Emmangt)

    I just returned from a trip to the UAE and took 34GB of photos using my iPhone 4S and a Panasonic Lumix G2 camera.  I had a **** of a lot of trouble transferring photos from the iphone to my MacBook Air (2008 running Lion as it will not suport ML) using iPhoto (latest vs).  It would just bomb out declaring a corrupt image and not transfer a single picture after several minutes furious activity.  I ended up doing it about 10 photos at a time which was a real pain in the ***. Clearly Apple have a bug they are simply not addressing.  Transferring images from the Panasonic camera was trouble free -- SD card plugged into USB card reader and a few hundred images whizzed across to iphoto without a hitch.  So the conclusion I draw from this is there is a serious bug in data transfer between iPhone 4 and iPhoto.  I also tried it with Aperture and had some better success in that it transfers all it can but lists the images not transferred, where as iPhoto just gives up and transfers nothing if it encounters any kind of problem.  This looks to me like the result of skimping on software testing and terrible quality control. Are Apple going to fix the bug in Lion?  Or do I have to buy a new laptop with ML just to do what used to work perfectly well in Tiger!

     

    Please Steve, rise from the grave and kick some butt!

  • Terence Devlin Level 10 Level 10 (121,655 points)

    Apple are unlikely to fix any bugs in Lion as it is no longer developed. But they might if you tell them about it

     

    iPhoto menu -> Provide iPhoto Feedback

     

    Are you sure the problem isn't on the phone?

  • Old Toad Level 10 Level 10 (113,105 points)

    Ask in the iPhone forum but you might try connecting the iPhone to your Mac, launch iTunes, backup the iPhone, restore the iPhone to factory settings and restore the backup.  Then take some photos and try again.

    iTunes001.jpg

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.