2 Replies Latest reply: Jan 20, 2013 8:21 PM by stevejobsfan0123
Tiffhotard Level 1 Level 1 (0 points)

I bought a 5th gen ipod touch and my itunes says I need to download itunes 10.7 to use it. Once I downloaded itunes 10.7, it said I need OS 10.6.8 but I cannot find where to download the ios 10.6. When I check my software updates, my computer says my software is up to date. I am stuck now and not sure what to do. Can anyone please help me?


MacBook Pro, iOS 5, not sure which version I have