Skip navigation

VGA Projector problem since 10.8.2 update

13928 Views 30 Replies Latest reply: Feb 20, 2013 7:05 AM by PowerPage.org RSS
  • WGary Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 6:01 AM (in response to bodhi1960)

    This worked for me! I didd not do the PRAM reset, just restarted the computer and everything worked again as expected!

  • Maui Todd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 29, 2012 3:02 PM (in response to kimmarie)

    Same here....rMBP....using it daily for presentations. Updated to 10.8.2 and VGA connections are all crazy. Thunderbolt port closest to rear of machine doesn't seem to work at all, and forward port is wonky....shows the standard Mountain Lion desktop which I don't even use.  Resolution is off, too.  Hae duplicated the problem with three different projectors...

  • jpga Calculating status...
    Currently Being Moderated
    Oct 2, 2012 3:10 AM (in response to kimmarie)

    Same problem with my MBP retina and same fix. Thank you very much.

  • Saladin Calculating status...
    Currently Being Moderated
    Nov 14, 2012 2:02 PM (in response to kimmarie)

    I really hope someone from Apple is looking at this.

     

    New Retina MBP. On the first day I connected it up to my VGA monitor (a Dell 2407WFP-HC) through the Apple adapter and it worked first time flawlessly. Then connected it to the TV through HDMI; also fine.

     

    Then I got the notification to update the software to 10.8.2, and also the MacBook Pro update 2.0. Installed both of those, and now neither HDMI nor the VGA connection work.

     

    On 3 separate occassions now, I've had to delete com.apple.windowserver.plist and reboot in order to connect an external display (either HDMI or VGA). Basically, a key feature of the machine just doesn't work. It's a major bug.

     

    Again, I really hope Apple is looking at this. I'm not happy spending all this money on a new machine to have these kinds of major software issues.

     

    I should add that I'm not seeing the same thing as others appear to. Here's what happens for me:

     

    - Plug in cable (HDMI cable or VGA/MDP adapter): nothing happens. OSX doesn't react at all, and the screen shows no connection.

    - As I'm unplugging the cable, I get a flash of blue from OSX as it adjusts the displays. Pushing the cable back in now doesn't do anything. The cable is also fine: it works with other devices (the HDMI is actually from my AppleTV), and the issue can be worked around by deleting those plist files on the MBP.

     

    I don't see any massive cursor or aything. The external display doesn't register any sort of connection at all. The MBP flashes blue as I'm unplugging the cable, but that's it. I've also tried "detect displays", but that also does nothing. I don't see anything on the console during this time.

  • Dennis Hesselbarth Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 15, 2012 1:20 PM (in response to kimmarie)

    I have a MBP 13" Mid 2012, and none of the work arounds described here are working for me. So I'm stuck at this point, unable to use any external monitor or projector. I hope Apple's engineer's are able to find a fix soon. Thankfully I have an old five year old MB that I can use for projection purposes. If not, I’d be more than frantic.

  • DRothenberg Calculating status...
    Currently Being Moderated
    Jan 7, 2013 8:26 AM (in response to kimmarie)

    Thanks for this fix, it worked for me in 10.8.1.

     

    I deleted that file and did NOT reset the PRAM

     

    After a restart the thunderbolt port worked fine for HDMI.

     

     

    DR

  • prosperonazareno Calculating status...
    Currently Being Moderated
    Jan 12, 2013 3:31 PM (in response to kimmarie)

    Same problem on my macbook white 7.1 I tried to reset PRAM but didn't work for me.

  • chuyentt Calculating status...
    Currently Being Moderated
    Jan 21, 2013 12:10 AM (in response to bodhi1960)

    Not work with my MBP Retina 15"

  • PowerPage.org Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 6, 2013 9:12 AM (in response to chuyentt)

    Retina MacBook Pro 13-inch, running OS X 10.8.2, fully patched.

     

    I tried connecting my rMBP13 to numerous Epson projectors where I work using Apple's Thunderbolt-VGA adapter. It displays my desktop on the projector for a couple minutes then spontaneously goes to a black screen. Rebooting the MacBook will fix it, but only for 2-3 minutes before the screen being projected goes black again.

     

    This is a serious P1/blocker bug for me as I need to use a projector with my Mac at work almost daily. My new MacBook has made me look bad in front of audiences several times now and it's a serious liability.

     

    Please fix this Apple!

  • Brian T. Nakamoto Level 1 Level 1 (70 points)
    Currently Being Moderated
    Feb 6, 2013 1:30 PM (in response to PowerPage.org)

    Deleting my com.apple.windowserver.* plist files (as suggested by bodhi1960) solved the problem where my rMBP 15" gradually stopped working with an Epson, and Samsung projector via various Apple-brand Mini DisplayPort-to-VGA adapters after I upgraded to 10.8.2. I did not need to reset my PRAM.

     

    FWIW, I also use SwitchResX since Mountain Lion removed the ability to switch screen resolutions via the menubar.

  • PowerPage.org Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 19, 2013 11:15 AM (in response to PowerPage.org)

    Update: I tried the deleting the "windowserver" files and resetting my PRAM (as suggested above) but it still doesn't fix the issue for me. I can connect to a projector (say, EPSON) with the Apple Mini DisplayPort > VGA adapter and it works for 4-5 minutes, then the projector display goes blank as if nothing is attached.

  • Brian T. Nakamoto Level 1 Level 1 (70 points)
    Currently Being Moderated
    Feb 19, 2013 3:51 PM (in response to PowerPage.org)

    Hi PowerPage.org,

     

    The Mini DisplayPort to VGA adapters in our conference rooms tend to go bad every so often because people bend its cable like a toy during meetings. Have you tried a different adapter?

     

    In my experience, the video working fine, but then flaking out because of a slight shift or vibration is due to the adapter (or a bad VGA cable in one case). The problem originally described in this thread happened immediately upon connection for me.

     

    Also, particularly if the adapter is old (e.g. circa 2009), you can check if its firmware is up-to-date – http://support.apple.com/kb/HT3492

  • PowerPage.org Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 20, 2013 6:40 AM (in response to kimmarie)

    UPDATE 2: Although the "windowserver" fix didn't work for me I was able to resolve my issue by replacing the Apple Mini DisplayPort > VGA adapter that I was using. I brought it into the Apple Store and demonstrated the issue to a Genius (using an external VGA monitor). The Genius swapped my Apple Mini DisplayPort > VGA adapter with a new one and the problem went away. Simply put, my adapter had become intermittant and replacing it with a new one completely fixed the issue for me (I tested it on 2 projectors this morning).

     

    If all else fails, try a new adapter: http://store.apple.com/us/product/MB572Z/B/mini-displayport-to-vga-adapter.

     

    Good luck.

  • Dennis Hesselbarth Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 20, 2013 6:54 AM (in response to PowerPage.org)

    I too found that replacing the adapter with a new Apple adapter solved my issues with external monitors and projectors. Due to the fragility of Apple adaptors, I've been using Monoprice products, but in this case, I've found the Monoprice adapters even more unreliable. None of the other workarounds, resetting PRAM, and so on, really worked in any consistent fashion.

     

    Plunk down your dollars on a new Apple adapter and baby it!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.