Skip navigation

Shared iCloud calendar notification problems

36607 Views 94 Replies Latest reply: Apr 4, 2014 1:56 AM by roccit RSS
  • PZnaty Calculating status...
    Currently Being Moderated
    Dec 6, 2012 3:47 AM (in response to tomizza)

    I can confirm this is not the solution. I have never had that option checked and I still get the notifications.

  • Nico Rohrbach Level 2 Level 2 (155 points)
    Currently Being Moderated
    Dec 11, 2012 3:28 AM (in response to drainsdigest)

    Months later and the problem is still not solved.

    Now I hope iOS 6.1 will fix it.

  • bs$ Calculating status...
    Currently Being Moderated
    Dec 11, 2012 6:08 AM (in response to Nico Rohrbach)

    Wouldn't count on it. I think most of us believe this is an iCloud problem, not an iOS problem. I'll keep my fingers crossed though.

  • amuhlou Calculating status...
    Currently Being Moderated
    Dec 12, 2012 6:07 AM (in response to drainsdigest)

    I also had the excessive email issue and I *think* it had to do with creating the list on iCloud.com vs on an iOS device. I had created a "business" reminder list via iCloud.com, shared it with my husband, and added a bunch of tasks. It seemed that every time he changed a word on the task I'd get an email.

     

    I created a new list from my iPhone, shared it w/ my husband via iCloud.com, and moved the tasks from the 'business' list over via iCloud.com.  So far, the emails have stopped.

     

    I'm not sure if it's a coincidence, but if you're still having the excessive emails that might be something to try.

  • scienceboy Calculating status...
    Currently Being Moderated
    Jan 21, 2013 4:01 AM (in response to amuhlou)

    I found a fix for the problem. I got a windows tablet and use google calendars now.

  • ozcarwylde2 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 26, 2013 3:32 AM (in response to Navy Nurse)

    Does not help!

  • ozcarwylde2 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 26, 2013 3:32 AM (in response to scienceboy)

    This seems to be the only option!

  • ozcarwylde2 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 26, 2013 3:36 AM (in response to Nico Rohrbach)

    I am so annoyed with this problem. This morning I had 30+ alerts for other peoples calendars! What is the point of this! Seriously... Why does apple seem to be messing with the most normal things! I cannont understand it!

     

    Has anyone got a solution this at all. Other than dumping iCal I changing back to Google Cal or similar. This is so frustrating because I am now missing the real alerts as I have to dismiss so many non essential alerts from shared peoples updates.

     

  • jdaulte Calculating status...
    Currently Being Moderated
    Jan 29, 2013 1:06 AM (in response to drainsdigest)

    Hope they will resolve quickly this issue is really really an annoying "feature"...

  • haikuty Calculating status...
    Currently Being Moderated
    Mar 15, 2013 10:32 PM (in response to drainsdigest)

    So I reported this issue via apple's bug reporter and just got a reply saying it has been fixed for some time.  They gave instructions to turn notifications off and on which I did for Reminders which didn't help.  But then I thought to try turning on/off Calendar reminders also and THAT FIXED IT!  Yay!

     

    So, try this:

     

    1. open iCloud in a web browser.
    2. Log into iCloud
    3. click on your name in the upper right to open the settings
    4. click on Notifications in the Account dialog that comes up
    5. In the Notifications section turn on/off both of Reminders & Calendar switches.
    6. (maybe try turning them both on, then both off)
    7. use the back button in the upper right of the Notifications pane to go back to the Account pane so you can save the settings ****IMPORTANT****
    8. Select "Done" to save the settings <- Make sure you do this!

     

     

    If you then want to turn Calendar notifications back on you can go back in and turn that back on.

  • hilde_dog Calculating status...
    Currently Being Moderated
    Mar 16, 2013 2:21 PM (in response to haikuty)

    This did not work for me.  No change in the problem.  All notifications where OFF in this pane.  I turned them on, then off.  Saved via the DONE button.  No change. 

  • hilde_dog Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 16, 2013 2:59 PM (in response to drainsdigest)

    Seeing others posting about Apple Support being able to fix this issue on the server side of iCloud, I called myself.  Worthless.  I had to explain to the tech what these notifications are, and when he later checked in with his "sr. support staff supervisor," that person suggested I turned off Mt. Lion Notifications ... which, of course, is not even in play here.  A sad Apple support experience ... when most have been great, in the past.  Clearly this is an iCloud server side issu, not a device problem.  No tech I talk to at Apple seems able to comprehend that fact.

  • BelfastBadger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2013 12:02 PM (in response to hilde_dog)

    Why is Apple Support being so crap about this?  This issue is clearly server side and has been an issue since iOS 6 was launched.  The issue has been well enough publicised by now, surely - there are a lot of iCloud and iCal users out there.  It is infuriating.  I've tried everything and even turned all calendar notifications off, but they still come through.  Not exactly "amazing" or "wonderful" (cue more of Tim Cook's breathy superlatives....)

  • HarvestFlo Calculating status...
    Currently Being Moderated
    Mar 28, 2013 6:40 AM (in response to drainsdigest)

    I am having similar problems.  My colleagues and I all use Google Calendars, which we share with each other and I sync with the calendar on my iPhone.  I occasionally want to be able to look at their calendars, but usually don't have them selected so I only see my calendar.  Either way I can alerts on my phone any time one of them has a meeting or anything.  It is very annoying to have to dismiss all the alerts for events not involving me.  It is especially annoying when a bunch of them pop up during a phone call and I can't hang up or do anything else until I dismiss them all.  Help!

  • BeauChevassus Calculating status...
    Currently Being Moderated
    Apr 15, 2013 12:33 PM (in response to drainsdigest)

    SOLUTION:


    • Sign in to iCloud.com in a browser other than Internet Explorer. 
        • Note: Internet Explorer will work for this, but from one who works/suffers in Tech Support, this first step is designed to save you a lot of heartache in the future.
    • Click Calendars.
    • Click Preferences (upper right, under the little cog).
    • Select "Advanced."
    • Uncheck "Email me shared calendar updates."
    • Choose "Save."
    • Quietly whisper, "That was way too easy," and politely thank me by signing in here and happily expressing your glee so others may find the solution. 

     

    Handy screenshot here:

    Capture 3.PNG

     

    Love,

     

    -Beau


    YouTube.com/BeauCh

Actions

More Like This

  • Retrieving data ...

Bookmarked By (16)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.