1 Reply Latest reply: Jan 21, 2013 1:58 PM by Niel
abakewell Level 1 Level 1 (0 points)

I have a MacBook Pro with OS X 10.5.8. I need OS X 10.6.8 or later to open TurboTax 2012. How can I update?


MacBook Pro, Mac OS X (10.5.8)