Skip navigation

Problem moving xcode cocoa c++ app to other mac's

1199 Views 27 Replies Latest reply: Jan 22, 2013 3:23 PM by etresoft RSS
  • Dave29483 Calculating status...

    No problem.


    If it turns out that it can not find a lib then you can run from terminal the following command;


    otool -L /path/to/


    This will list all of the libs it needs and where it thinks they should be.


    Post them back here if you need further assistance.

  • Frank Caggiano Level 7 Level 7 (22,770 points)

    armondfromglendale wrote:


    I just tried again with now the minimum version having a value of 10.7 and got the following:


    Click Report to see more detailed information and send a report to Apple.

    IGNORE     REPORT...

    Just noticed this. Did you ever click Report and if so what did it say? Also is anything being logged ? Look in the Console app.


    At this point I would recommend you start with a very simple test case. Create a small C++ binary without the libraries and try moving that. If it works try in bring in the libraries one at a time to see what happens.


    It is sounding move like it is a library problem.  How are you linking the libraries?


    Message was edited by: Frank Caggiano - otool should be in /usr/bin btw

  • Dave29483 Level 1 Level 1 (20 points)



    If you are able to upload it somewhere and provide a link, I can attempt to determine the issue for you.

  • etresoft Level 7 Level 7 (23,895 points)

    armondfromglendale wrote:


    Wow I never imagined developing apps on MAC and getting them deployed to other MAC's would be such a nightmare!

    It isn't. I advise against spouting off such proclamations until you are positive a problem affects more than just you out of thousands of other developers.


    I suggest you try Dave29483's suggestion again and this time PaY atTentIon to cAse.

  • Dave29483 Level 1 Level 1 (20 points)

    For the sake of sanity I put together a quick SDL app on my OSX 10.8 machine, compiled it then sent over to my OSX 10.7 machine.


    I get the same Ignore / Report dialog as you. However, if I launch it via the terminal, it tells me it can't find SDL.framework.


    So I downloaded the SDL runtime from here (Intel 10.5+) and copied SDL.framework from within the .dmg to /Library/Frameworks.


    Relaunch my SDL app and voila!


    So as I suspected, it is indeed a missing library.


    Hope this helps.

  • Dave29483 Level 1 Level 1 (20 points)

    Glad I could be of help.


    Happy coding!


    <Edited by Host>

  • etresoft Level 7 Level 7 (23,895 points)

    armondfromglendale wrote:




    I never said everyone is having this issue. It is only me and I am getting frustrated. I am spout anything I want and you can't say otherwise. If you are not willing to provide assistance (which is why these forums exist), I would highly recommend you close your account.

    I enjoy helping people who don't come in with a chip on their shoulder and leave out crucial details like 3rd party libraries. Had you mentioned that, your problem could have been resolved in 5 minutes instead of 11 days.


    There is a more elegant solution than just copying the missing libraries onto the target machine. I was even going to tell you what it was earlier today but then I got busy with other things. I'm definitely not going to do that now.

  • etresoft Level 7 Level 7 (23,895 points)

    armondfromglendale wrote:


    Etresoft, don't flatter yourself. I don't need your help as Dave was gracious enough to assist me. Next time be nice to people and people may just end up giving you some respect.

    And nobody knows now to be nice to other people like you do

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.