Skip navigation

mail server doesn't work after upgrading from SL to ML

487 Views 5 Replies Latest reply: Jan 22, 2013 8:51 PM by UptimeJeff RSS
giancarlo@bagnetti.com Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 21, 2013 1:13 PM

My Mail server doesn't work after upgrading from SL to ML

Mail client connects with the Mail Server wich seems to run but then they can't receive any email...

the problem seems to be related with dovecot ... in my smtp log i get this:

 

relay=dovecot, delay=324, delays=324/0.02/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: pipe: fatal: pipe_command: execvp /usr/libexec/dovecot/deliver: Permission denied

 

I have to say that in the usr/libexec there wasn't the dovecot directory so I just tried to create one but with no luck

 

Any Ideas?

Cheers

Carlo

 

This is my postconf -n info:

 

server:Data admin$ postconf -n

biff = no

command_directory = /usr/sbin

config_directory = /Library/Server/Mail/Config/postfix

content_filter = smtp-amavis:[127.0.0.1]:10024

daemon_directory = /usr/libexec/postfix

data_directory = /Library/Server/Mail/Data/mta

debug_peer_level = 2

debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5

dovecot_destination_recipient_limit = 1

enable_server_options = yes

header_checks = pcre:/etc/postfix/custom_header_checks

html_directory = /usr/share/doc/postfix/html

imap_submit_cred_file = /Library/Server/Mail/Config/postfix/submit.cred

inet_interfaces = all

inet_protocols = ipv4

mail_owner = _postfix

mailbox_size_limit = 0

mailbox_transport =

mailq_path = /usr/bin/mailq

manpage_directory = /usr/share/man

maps_rbl_domains =

message_size_limit = 20971520

mydestination = $myhostname, localhost.$mydomain, localhost

mydomain = moremoremore.it

mydomain_fallback = localhost

myhostname = server.moremoremore.it

mynetworks = 127.0.0.0/8,192.168.178.0/24

newaliases_path = /usr/bin/newaliases

queue_directory = /Library/Server/Mail/Data/spool

readme_directory = /usr/share/doc/postfix

recipient_delimiter = +

relayhost = mail.mclink.it

sample_directory = /usr/share/doc/postfix/examples

sendmail_path = /usr/sbin/sendmail

setgid_group = _postdrop

smtp_sasl_auth_enable = no

smtp_sasl_password_maps =

smtpd_client_restrictions = permit_mynetworks permit_sasl_authenticated reject_rbl_client zen.spamhaus.org permit

smtpd_enforce_tls = no

smtpd_helo_required = yes

smtpd_helo_restrictions = reject_invalid_helo_hostname reject_non_fqdn_helo_hostname

smtpd_pw_server_security_options = cram-md5,gssapi

smtpd_recipient_restrictions = permit_sasl_authenticated permit_mynetworks reject_unauth_destination check_policy_service unix:private/policy permit

smtpd_sasl_auth_enable = yes

smtpd_tls_CAfile = /etc/certificates/server.moremoremore.it.A358901573EE7B9B4D489725407934780D24D5 36.chain.pem

smtpd_tls_cert_file = /etc/certificates/server.moremoremore.it.A358901573EE7B9B4D489725407934780D24D5 36.cert.pem

smtpd_tls_exclude_ciphers = SSLv2, aNULL, ADH, eNULL

smtpd_tls_key_file = /etc/certificates/server.moremoremore.it.A358901573EE7B9B4D489725407934780D24D5 36.key.pem

smtpd_use_pw_server = yes

smtpd_use_tls = yes

tls_random_source = dev:/dev/urandom

unknown_local_recipient_reject_code = 550

virtual_alias_maps =

server:Data admin$

  • TigerKR Level 1 Level 1 (25 points)

    Hi,

     

    What are the steps that you followed to upgrade from 10.6 to 10.8?

     

    - TigerKR

  • TigerKR Level 1 Level 1 (25 points)

    I don't have Server 10.8 installed yet, so hopefully someone who does can give some insight regarding the mail server configuration.

     

    Did your user accounts and websites transfer seemlessly in the upgrade?

  • UptimeJeff Level 4 Level 4 (3,390 points)

    your second post wasn't complete.

    was that the output of

    sudo serveradmin settings mail

    ?

     

    If you've been down for a day, you may want to roll-back to your clone (hopefully you have a clone) then consider a clean install vs upgrade.... We could probably solve the dovecot issues, but how long would it take?

    Other option would be to hire someone that can track down the issue quickly.

    If the server is in production, I wouldn't want to wait on forum responses.... this could be tricky.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.