Skip navigation

SystemUIServer problem?

33587 Views 69 Replies Latest reply: Jun 14, 2013 11:59 AM by jtclary89 RSS
  • Jaydon134 Calculating status...
    Currently Being Moderated
    Jan 22, 2013 4:38 PM (in response to Dand666)

    Well, I haven't had an issue with it for about a 2 weeks even when I'm running all my third party apps. The only variables are 1. I completely redid my home network or 2. They third party apps must be set as login items.

     

    It's kind of difficult to troubleshoot a problem that doesn't happen, but I will keep trying to recreate scenerios until I get SystemUIServer to act up again. Thanks for all your input,

     

    Jaydon

  • Dand666 Calculating status...
    Currently Being Moderated
    Jan 23, 2013 12:28 AM (in response to Jaydon134)

    I have the spinning wheel nearly all the time, whenever i hover over WiFi in the menu bar.

     

    >.<

  • jas1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 1:15 AM (in response to Dand666)

    Really appreciate people taking time to try to fix this.  I posted in this discussion some months ago and have also called Apple about it but have only seen discussions go around in circles, from work arounds to third party apps and back again.

     

    I no longer suffer from this problem - but only because I removed anything that provides updates from the menu bar - this includes wifi.  It is quite inconvenient not having wifi on the menu bar but at least without it i can use spot light when i like without killing SystemUIServer. 

     

    I have tried reinstalling the operating system (but keeping all my apps/settings) by starting in Recovery Mode but that didn't help.  As soon as i put wifi back on the menu bar I got the beachball again.

     

    I am pretty disappointed that Apple hasn't done anything to solve this issue but don't want to divert this discussion with my gripes Good luck guys in trying to find a fix.

  • Dand666 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 8:29 AM (in response to jas1)
  • Jaydon134 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 25, 2013 4:14 PM (in response to acesta)

    Alright, after performing some steps as directed by a Senior Advisor from Apple, I seem to have solved my problem. This shouldn't affect how your computer functions, and it should allow you to have all your menubar items fully functioning. Here's what you do:

     

    Clear Computer Launch Daemons, Launch Agents, and Startup Items

    1. Open up a Finder window

    2. Click on Go in the menu (it's next to view and window)

    3. Click on Computer

    4. Go into Macintosh HD

    5. Go into Library

    6. Find the folder LaunchAgents

    7. Delete everything inside that isn't a com.apple.xxxxxx file (you may need administrative privileges)

    8. Find the folder LaunchDaemons

    9. Delete everything inside that isn't a com.apple.xxxxxx file (you may need administrative privileges)

    10. Find the folder Startupitems

    11. Delete everything inside that doesn't have apple in its name

    12. Empty Trash and Reboot machine

     

    Clear User Launch Agents

    1. Open up a Finder window

    2. Click on Go in the menu

    3. Click on Home

    4. Click on Go in the menu

    5. While holding down the option key, click on Library

    6. Find the folder LaunchAgents

    7. Delete everything inside that doesn't start with com.apple.xxxxxxx

    8. Empty Trash and Reboot machine

     

    After you have completed these steps, you shouldn't have any issues with SystemUIServer. If you begin to have issues, check in the above mentioned folders for the most recently modified or created file to determine what app is causing the problem.

     

    Thanks for all the input guys and gals. Let me know if this works for you. If it doesn't see if you can find the app that causes the issue.

     

    Jaydon

  • John78735 Calculating status...
    Currently Being Moderated
    Jan 27, 2013 3:53 PM (in response to Jaydon134)

    This looks promising. Wondering if anyone else found Java (or the very recent version of it, I should clarify) in their LaunchAgents folder. I was forced to update Java almost immediately after updating to Mountain Lion.

  • Jaydon134 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 28, 2013 4:04 PM (in response to John78735)

    I don't recall what was found in mine. I did it while I was on the phone with an Apple advisor, but I do know that there were quite a few items in it. Java could very well have been in there.

     

    Jaydon

  • Jaydon134 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2013 8:01 AM (in response to acesta)

    So how is it working out for everyone? Are you still having issues? Did my solution resolve anything? Thanks!

     

    Jaydon

  • demujer Calculating status...
    Currently Being Moderated
    Feb 4, 2013 2:18 PM (in response to Jaydon134)

    silence means yes. your solution is must-do anyway just for ethic reasons admin's secret, if everyone could do stuff like that, no admin would have a job

  • Jaydon134 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2013 4:24 PM (in response to demujer)

    Great. Well, I hope you keep your job! Have fun,

     

    Jaydon

  • LEBrock Calculating status...
    Currently Being Moderated
    Mar 4, 2013 8:10 PM (in response to Jaydon134)

    Jaydon134,

    Thanks so much for the above solution- it is the first time this MBP has been right since I upgraded to Lion.  Java was not in my folders, but there was Adobe, HP, and a banking security program.   I applied your fix this morning and SystemUIServer has not gone nuts since. I put the system to sleep several times to test it, and it continues run oh so cool and quietly. I was thinking I might have to trash the computer and get a new one-- but now it is good as new.

    Can't well express how thankful I am to have found your post.  Finally peace of mind. 

    Need to get this post out there cause I see a lot of people suffering this same issue.

  • LEBrock Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 4, 2013 8:11 PM (in response to LEBrock)

    I was able to restore all the menu icons again- no problems now at all.

  • kneppis Calculating status...
    Currently Being Moderated
    Mar 6, 2013 9:32 AM (in response to LEBrock)

    I had some problems with SystemUIserver used a lot of CPU on my MBP from 2008 with OSX10.8.2. Especially when trying to change Wifi network from the menubar.

     

    You have to excuse me for the translations here, I have a swedish installation.

     

    I reduced the problem with the SystemUIserver by just turning off Menu bar transparancy under System settings - Desktop and Screensaver.

  • iPanda_gm Calculating status...
    Currently Being Moderated
    Mar 9, 2013 1:05 AM (in response to Jaydon134)

    After struggling with this issue for a long time without ever having the time to deal with it properly, I got at bit excited reading this solution and deleted all the files, even the files with com.apple... in the name, in folders LaunchAgents and LaunchDeamons... everything seems to work just fine but still I wonder if I have done some damage.

     

    Thanks for finally solving this issue Jaydon134, my iMac is now a as new!

  • demujer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2013 2:37 AM (in response to iPanda_gm)

    just don't install os x server if you don't know what that is. it is not simply a plugin, it is another concept of operating system with a lot of services to eat most of your system resources most of the time, in my opinion totally useless product of apple from ver. 10.7 on, as server is supposed to eat less resources, less so called "user friendly" graphical interface, apple provides the best graphical interface in the world and is making good money with it, what's the reason of hiding potential server on every iphone of yours into the sandbox i simply don't get it, but it is actually offtopic, if you wanna ruin your wonderful os x , buy server package and end up messing up with config files, i ended up reinstalling os x and it feels like heaven, want server, use macports.

     

    p.s. my dear apple, id love so much also using ports on the ios basis, as i am sure as much as you hate ubuntu like apt broken dependencies ***** which caused me moving to slackware then to bsd and endlessly to osx. i understand you don't want software to be pirated neither do i, but it is like forbid a kid to do dregs and forcing one self to use unclean stuff from the street criminal gangs. (and forcing jailbreak to stay mainstream) just telling my opinion. leave me my terminal and root access to filesystem and you will almost kill the piracy , no kid which is jailbreaking his device would use pirated software as the apps don't cost much anyway. it is just about freedom to take advantage of your hardware at your skill level niaveau, what makes the best of apple all the way, the bsd core, without it it would simply turn to the visual basic dows exorcista blue screen paradise ...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.