Skip navigation

Wifi Constantly Dropping in Lion

522162 Views 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR RSS Branched to a new discussion.
  • Allnuts Calculating status...
    Currently Being Moderated
    Jan 10, 2013 7:45 PM (in response to Doc Dougherty)

    Yeah I know. Just checked and channel 1 works well for me.

  • gphonei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 11, 2013 11:50 AM (in response to Allnuts)

    Allnuts wrote:

     

    Yeah I know. Just checked and channel 1 works well for me.

    The used bandwidth by each of 802.11b, 802.11g and 802.11n is different.  That's an important part of where in the list of channels you might find a more usable environment.  And, because people can change their channels, it can change over time, requiring you to revisit it.

     

    Your othe post showed many 802.11n on channel 6.  Try channel 1 and 11.  If that still doesn't work for you, there could be something else happening with other 2.4ghz devices such as phones or remote audio monitors o wireless video extenders, etc on channel 1 and up.   The Signal / Noise: figures in that list show that several of those signals can be heard fairly well by your router (noise is at -87dbm).  That's where the interferening signals drop out of "view".  Most are being received above -75dbm, and one is as loud as -64dbm.  So, they will definately be a problem for you.

     

    If switching to channel 1 or 11 doesn't improve things for you, you might not have much choice other than to try 5ghz to see if that solves your problem.

  • arsenyspb Calculating status...
    Currently Being Moderated
    Jan 19, 2013 5:36 AM (in response to lhale)

    Hi guys,

     

    QUESTION - what is the latest official remedy from the drivers / oreferences perspective to make 2010-aged MBP with BroadCom WLAN NIC & Driver particulars work as in my case work in a mixed G/N environment?

     

    Beforehand in this thread, I've googled some suggestions to downgrade the driver, or disable the power-saving. What's the status quo?

     

    Let me add some details here. I'm an owner of a mid-2010 MacBook Pro (

    MacBookPro6,2) running Mac OS X 10.7.5 (11G63), if anyone from Apple Resellers screens this - S/N is W8013BPNAGV

     

    I concur to some posts in a middle of this thread that say it's Apple's side of the house that drops Wireless-N connectivity. Switching from IEEE802.11n to 802.11g helps and secures stable connection. No, let me state it  - it's definitely Apple & Broadcom issue. I put total responsibility on untested interop to Apple as they are releasing the OS and drivers that do not support IEEE802.11n.

     

     

    ifconfig en1

    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

              ether 58:b0:35:62:7e:0e

              inet6 fe80::5ab0:35ff:fe62:7e0e%en1 prefixlen 64 scopeid 0x5

              inet 192.168.0.173 netmask 0xffffff00 broadcast 192.168.0.255

              media: autoselect

              status: active

     

     

    FYI, my iface is

     

    en1:

      Card Type:          AirPort Extreme  (0x14E4, 0x93)

      Firmware Version:          Broadcom BCM43xx 1.0 (5.106.198.19.22)

      MAC Address:          58:b0:35:62:7e:0e

      Locale:          ETSI

      Country Code:          SG

      Supported PHY Modes:          802.11 a/b/g/n

      Supported Channels:          1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165

      Wake On Wireless:          Supported

      AirDrop:          Supported

      Status:          Connected

      Current Network Information:

     

    That is the only network, whole spectrum is free and I have other devices (802.11g and 802.11n) on the same SSID working in mixed G/N mode without interruptions. It's only this particular MacBook that fails to work on N.

     

    Please update this thread

  • arsenyspb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 5:52 AM (in response to DRW9)

    Hello DRW9,

     

    Can you advise the way that you made Mac OS X Lion work with Snow Leopard drivers please?..

     

    Thanks!

  • arsenyspb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 5:57 AM (in response to moskovit)

    Hello moskovit,

     

    I'm curious whether you're still in OS X 10.7.x and using the downgraded driver in a mixed B/G environment. Can you advise whether it's your case still?

     

    Thanks!

  • gphonei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 7:11 AM (in response to arsenyspb)

    arsenyspb wrote:

     

    Hi guys,

     

    QUESTION - what is the latest official remedy from the drivers / oreferences perspective to make 2010-aged MBP with BroadCom WLAN NIC & Driver particulars work as in my case work in a mixed G/N environment?

     

    Beforehand in this thread, I've googled some suggestions to downgrade the driver, or disable the power-saving. What's the status quo?

     

    Let me add some details here. I'm an owner of a mid-2010 MacBook Pro (

    MacBookPro6,2) running Mac OS X 10.7.5 (11G63), if anyone from Apple Resellers screens this - S/N is W8013BPNAGV

     

    I concur to some posts in a middle of this thread that say it's Apple's side of the house that drops Wireless-N connectivity. Switching from IEEE802.11n to 802.11g helps and secures stable connection. No, let me state it  - it's definitely Apple & Broadcom issue. I put total responsibility on untested interop to Apple as they are releasing the OS and drivers that do not support IEEE802.11n.

     

     

    ifconfig en1

    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

              ether 58:b0:35:62:7e:0e

              inet6 fe80::5ab0:35ff:fe62:7e0e%en1 prefixlen 64 scopeid 0x5

              inet 192.168.0.173 netmask 0xffffff00 broadcast 192.168.0.255

              media: autoselect

              status: active

     

     

    FYI, my iface is

     

    en1:

      Card Type:          AirPort Extreme  (0x14E4, 0x93)

      Firmware Version:          Broadcom BCM43xx 1.0 (5.106.198.19.22)

      MAC Address:          58:b0:35:62:7e:0e

      Locale:          ETSI

      Country Code:          SG

      Supported PHY Modes:          802.11 a/b/g/n

      Supported Channels:          1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165

      Wake On Wireless:          Supported

      AirDrop:          Supported

      Status:          Connected

      Current Network Information:

     

    That is the only network, whole spectrum is free and I have other devices (802.11g and 802.11n) on the same SSID working in mixed G/N mode without interruptions. It's only this particular MacBook that fails to work on N.

     

    Please update this thread

    My airport interface is shown as:

     

    en1:

      Card Type:          AirPort Extreme  (0x14E4, 0x8D)

      Firmware Version:          Broadcom BCM43xx 1.0 (5.106.98.81.22)

      MAC Address:          00:23:6c:9a:14:ec

      Locale:          FCC

      Country Code:          US

      Supported PHY Modes:          802.11 a/b/g/n

      Supported Channels:          1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165

      Wake On Wireless:          Supported

      AirDrop:          Supported

      Status:          Connected

     

    I've never had this problem on my Macbook pro.  It's always worked fine.  Mine is a little older than yours by version number. I did buy this in spring of 2009. 

     

    I use 5ghz for all my wireless on my devices which support it.  I have 2.4ghz for devices which don't have 5ghz radios.  I've used netgear radios for quite some time.  I also have a TimeCapsule that I use some times when I need my netgear router at some other event/location.  I also have radios from http://ubnt.com that I use, and I've not had problems with those either.

     

    The number one thing that I will stress over and over, is make sure you have the latest firmware installed for your wireless router.  The manufactures are shipping new products before the firmware is finished, and expecting their users to use the web interface to the router to set it up, and that interface usually tries to automatically update the firmware in the router.  

     

    What WiFi router are you using?  Have tried to check and make sure you have the latest firmware update?

  • arsenyspb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 7:21 AM (in response to gphonei)

    Hi gponei,

     

    5 Ghz spectrum is not possible where I'm.

     

    I'm using Cisco DPC3925 yes latest firmware of course, that supports 802.11bgn, bg or G only modes.

     

    As said, I'm only observing the above said behavior on MBP with Wireless-N. I also have few other laptops with Windows 7 on them working excellent on full 802.11n connection.

     

    I've plugged in the kext as per http://rys.sommefeldt.com/2012/05/13/backup-and-restore-os-x-lion-wi-fi-kext.htm l but after this mod for the two last hours 802.11n connection of MacBook Pro experiences enormous latency. Same host from nearby Windows 7 laptop pings with stable 320...350 ms, while MBP kext/driver introduces stack latency up to 1100...1200 ms.

     

    After observing this for 1+ hours, I've downgraded Wireless radio mode on AP to 802.11b/g (not N) mode.

     

    I hate it ((

     

    Any other ideas on any other kexts to drop in?

  • gphonei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 9:18 AM (in response to arsenyspb)

    arsenyspb wrote:

     

    Hi gponei,

     

    5 Ghz spectrum is not possible where I'm.

     

    I'm using Cisco DPC3925 yes latest firmware of course, that supports 802.11bgn, bg or G only modes.

    What security mode are you using?  Can you try WPA2-AES?  It might not be supported on all of your devices, but if you can try it on your Mac, it would be interesting to see if it changes what you are experiencing.  I looked at the manual for your router at http://www.cisco.com/en/US/docs/video/at_home/Cable_Modems/3900_Series/4021192_B .pdf and I am look at pages 38-50 or so.  It seems like you might also turn off WPS so that it's not trying to auto register anything at the router, as described on page 38.  I've never used WPS on routers because I know how to set things up manually.  Turning it off might disable some code in the router which is creating this problem.  The manual says that WPA-TKIP can not be used for 802.11n, so I guess you've already been using AES.  Have you been using WPA or WPA2?

  • eROCK1 Calculating status...
    Currently Being Moderated
    Jan 23, 2013 1:10 AM (in response to lhale)

    I have an update on my issue.  I've pretty much tried every setting that there is - everything listed in this forum, and still had the network drop outs.  I was using a Motorola SB6580 modem with built in wireless gateway.  I spoke with a Motorola engineer who stated that there is newer firmware for the modem that has a lot of fixes for wifi issues.  My cable internet provider has not finished testing this firmware yet, so they are not going to push it down to my box.  However, I wanted to try everything I could, so I had my internet provider send me one of their MTA (modem with built in wireless gateway).   This one is an Arris.  

    It's been a few weeks now, and I have not had any wifi issues yet.  I'm hoping this fixed my issue, but of course time will tell.  I believe the problem and fix is more complex than simply the modem itself.  I think there is an issue with OS X, and the way that it interacts with some firmware from the modem/wifi router.  Not all modem/wifi routers are impacted by this - many use different chips - many vendors use the same chips.  So it's hard to say. It could be signal related...some modems are more sensitive to signals than others (I use to work in the cable industry so I know this for a fact).  I'm just letting you know that I swapped out my modem with built in wireless gateway for a different vendor's product, and now my issue has cleared for now.  If you've just had it with this issue, this may be something else to try.  It worked for me, and I think I've tried just about everything else.

  • gphonei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 3:50 PM (in response to eROCK1)

    eROCK1 wrote:

     

    If you've just had it with this issue, this may be something else to try.  It worked for me, and I think I've tried just about everything else.

    I really can't stress how important it is to make sure you have the right firmware fixes in your router.  It's a computer system and the software it uses is large and complex.  Apple is pushing 802.11n to the max, while many cheaper PCs don't have 802.11n support, or only use 2.4ghz etc.  Glad you found a fix.

  • eROCK1 Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jan 23, 2013 4:26 PM (in response to gphonei)

    I agree about the firmware fix.  The problem I had though is that I did not have an external router that I could get firmware from the vendor.  I had a MODEM with the wireless router built in.  The enduser (me) is unable to upgrade the firmware on this type of setup.  Only the cable company can do this through their CTMS/DHCP server via TFTP.  This is for security reasons.  Since my firmware was the latest release that my cable company approved, they were not going to upgrade my firmware to the absolute latest that Motorola had out in the field since it had not gone through all of their testing yet.

    So my only other option was to swap out the modem/router for a different brand of modem/router - which of course uses different firmware and processors.  So was the issue caused by firmware or hardware?  I'm not sure, but I can say that I have not had the problem return since doing this.

  • kasdba Calculating status...
    Currently Being Moderated
    Jan 25, 2013 8:39 PM (in response to eROCK1)

    Well I had tried just about everything with no success . ! have a 2009 IMAC running 10.8.2.  4 visits to my local Apple store for all sorts of adjustments and reloads....no luck. Finally I started to focus on my cisco router. Did a firmware update which seemed to improve the speed of internet browsing but the connectivity problem slowly retruned. Then on a call with an Apple tech person i was asked about my router/WIFI settings. When I mentioned that my security was set using WEP she strongly recommended WPA2 Personal. I got on line with CISCO (great support 24/7) and they walked me through changing over to WPA2 Personal..they also recommended changing my Wi FI name.

    so a firmware upgrade, changing over to WPA2 and changing WI FI name have produced a combination of a fix. 5 days now and I have not lost connectivity.

    I should add that I first backed up everything and reloaded the Lion 10.8.2  operating system. Now I will reload all my files and data with Time Machine and keep my fingers crossed.

    I'll keep you posted

  • gphonei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 26, 2013 8:23 AM (in response to kasdba)

    kasdba wrote:

     

    ...

    so a firmware upgrade, changing over to WPA2 and changing WI FI name have produced a combination of a fix. 5 days now and I have not lost connectivity.

    I should add that I first backed up everything and reloaded the Lion 10.8.2  operating system. Now I will reload all my files and data with Time Machine and keep my fingers crossed.

    I'll keep you posted

    This is awesome to hear.  Certainly, their should not be WEP bugs in the Apple WiFi software, but apparently there are.  WEP should no longer be used, by anyone, except in extremely rare circumstances with ancient devices that only support WEP.   If that's the case, I'd give serious thought to using two different wifi radios so that you can still have WEP for those odd devices.  The issue with WEP, is that it can take a very short amount of time to "break in" as discussed on pages like http://www.dummies.com/how-to/content/understanding-wep-weaknesses.html.  WPA2 is what Apple recommends, so if you are not using WPA2, or don't know how to make sure, find someone to help you out.  The router manufacturers do usually have support as described here which can help you out.

  • kasdba Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 30, 2013 3:53 AM (in response to gphonei)

    update.....backed up my data with time machine and all continues to go well....so whatever part or combination of the fixes and tweaks I did with support from Apple and Cisco (they were most cooperative), the problem seems fully resolved ! My guess ....the router/WPA2 Personal switch combined with  renaming my WiFi was a big part of the resolution !

    Has anyone else tried this ?

  • Happel Calculating status...
    Currently Being Moderated
    Jan 30, 2013 4:22 AM (in response to kasdba)

    I'm sorry, but this is just a big waste of time and the biggest pile of .... you can imagine. This problem is caused solely by Apple and Apple alone. Apple did something with (Mountain) Lion what's causing these issues, not Cisco, Linksys, Netgear or any other manufacturer of wireless routers. It's great that Apple (supposedly) is pushing 802.11n to the max, but when that means I can only connect reliably to certain hardware of certain vendors and have to mix and match that with certain firmware versions, thanks but no thanks. I'd rather have a connection which is a little bit slower, but allows me to connect to any access point I want.

     

    I have done a lot of testing on this, even tried all of the 'desperate' nonsense solutions, but when you have an early 2008 Macbook running Lion, you can't keep wifi connected to certain access points. It's really annoying, because on the same Macbook, Snow Leopard works fine, Leopard works fine, heck even Windows Vista and Windows 7/8 work fine. Only Mac OS X 10.7 Lion, is having issues. Thus I repeat one more time:

     

    TL;DR

    Apple screwed something up and apparently won't fix it, quit making excuses.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (82)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.