12 Replies Latest reply: Mar 30, 2014 7:55 AM by Chris0071
aixxo Level 1 Level 1 (0 points)
Hi, I'm trying to mount an exFAT harddrive via usb. The disk is recognized and show in the disk utility, but i cannot activate it. The only error I get is in the Console :

28.02.11 20:38:36 kernel exfat: bytes per cluster (4194304) > MAXBSIZE (1048576). Can't mount.

Any chance of getting access to the drive? It mounts perfectly under Windows 7.

Thanks!
Regards,
aixxo

Macbook Pro, Mac OS X (10.6.6)
  • 1. Re: exFAT mounting problem
    Kappy Level 10 Level 10 (226,765 points)
    Do you know if OS X can read an exFAT formatted drive?
  • 2. Re: exFAT mounting problem
    aixxo Level 1 Level 1 (0 points)
    Yes it can. I think it was added with 10.6.5.
  • 3. Re: exFAT mounting problem
    Kappy Level 10 Level 10 (226,765 points)
    I know it has the format option, but did not know if it also had read capability.

    A problem I've often come across in the forums is that sometimes a drive formatted on one platform does not work correctly on the other. It isn't just limited to the Mac or to a PC. I have no idea if a solution has been found other than trying to format on the other platform. Wish I had more to offer.
  • 4. Re: exFAT mounting problem
    aixxo Level 1 Level 1 (0 points)
    Ok,I resolved the issue.
    When formatting a exFAT drive under Windows you can choose the cluster size. If the drive should be used with OSX you should not choose anything higher than 1024!

    Regards,
    aixxo
  • 5. Re: exFAT mounting problem
    the-wanderer Level 1 Level 1 (0 points)

    where did you get this information?

  • 6. Re: exFAT mounting problem
    NetEagle Level 1 Level 1 (0 points)

    You da man! That was it. Thanks for the info.

  • 7. Re: exFAT mounting problem
    lmcurley Level 1 Level 1 (0 points)

    Perfect thanks. I got it working too with 1024, had issues with 4096 cluster size.

     

    Thanks for the link. Hopefully Apple will improve exFAT soon.

     

    I have a 3TB USB drive and want to use with Mac and Windows, exFAT was the only real option.

     

    NTFS can be used with Mac, but not with all Macs as requires that plugin installed. Where as exFAT can be used with any 10.6.5 Macs which is perfect.

  • 8. Re: exFAT mounting problem
    merfi Level 1 Level 1 (0 points)

    Thanks so much for the solution.

  • 9. Re: exFAT mounting problem
    Antares88 Level 1 Level 1 (0 points)

    Hi, i have a similar problem only using USB 3.0 with external hard drive although Disk Utility won't recognise this drive. Disk was formated in exFAT, 1024 cluster size. Works fine on Win7 through USB 3.0 and USB 2.0 port.

     

    Tried pretty much everything. Is there any chance to make this external drive and mac combination work?

     

     

    Thanks, Nino!

  • 10. Re: exFAT mounting problem
    iMteQx Level 1 Level 1 (10 points)

    Thanks to the guy; aixxo I also resolved this issue.

     

    Once again; if you're formatting the drive in Windows to ExFAT you need to change the clustersize to: 1024 to get it visible in your OS X.

  • 11. Re: exFAT mounting problem
    matt.simmons344 Level 1 Level 1 (0 points)

    I couldn't find anything to back your theory up but I tried it and it completely solved my problem! Thanks! and for any other PC to Mac converts out there - if you have an NTSF external HD and want to make it exFAT compatible for both your PC *AND* Mac, just do what this man says lol

  • 12. Re: exFAT mounting problem
    Chris0071 Level 1 Level 1 (0 points)

    I am runing Mavericks and I tried formating one drive in Exfat and a USB 3 thumb drive and both of them when I try to copy large files on them they crash while in the middle of the transfer and it unmounts the drive and says the drive was not ejected properly. Then When I unplug the drive and plug it back some times the drive wont event show up in finder. I can see it in Disk utility but it looks as if the partition has gone. Some times the only way to reuse it is to format it again i Exfat, but then the problem happens again. Has anyone had this problem in Mavericks. I am using a Macbook pro retina display upgraded model late 2013.