1 Reply Latest reply: Jan 23, 2013 1:24 PM by Niel
MeetWalden Level 1 Level 1 (0 points)

Can I upgrade my Mac mini running QS 10.5.8 to accommodate iTunes for my new ipod nano, I think it requires itunes 10?


Mac mini, Mac OS X (10.5.8)