Skip navigation

Safari 6.0.2 Crashes a lot

641 Views 10 Replies Latest reply: Jan 24, 2013 1:51 PM by iHussein RSS
iHussein Level 1 Level 1 (10 points)
Currently Being Moderated
Jan 23, 2013 10:24 AM

Safari Crashes a lot especiallay when I go to "Private Mode". here are Three crash reports if some one can help me get to what is causing it, I would really appreciate it. It looks like the are caused from the same Problem!

 

First Crash Report:

 

Process:         WebProcess [11190]

Path:            /Applications/WebKit.app/Contents/Frameworks/10.8/WebKit2.framework/WebProcess. app/Contents/MacOS/WebProcess

Identifier:      com.apple.WebProcess

Version:         537+ (537.27+)

Code Type:       X86-64 (Native)

Parent Process:  ??? [1]

User ID:         501

 

 

Date/Time:       2013-01-23 01:14:57.466 -0500

OS Version:      Mac OS X 10.8.2 (12C60)

Report Version:  10

Sleep/Wake UUID: DA22B1AA-A8B0-4F48-B5B6-11EB6F08238B

 

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

 

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

 

 

VM Regions Near 0:

-->

    __TEXT                 00000001062ad000-00000001062ae000 [    4K] r-x/rwx SM=COW  /Applications/WebKit.app/Contents/Frameworks/10.8/WebKit2.framework/WebProcess. app/Contents/MacOS/WebProcess

 

 

Application Specific Information:

Bundle controller class:

BrowserBundleController

 

 

 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0   com.apple.WebCore                       0x00000001074360f9 WebCore::NetworkStorageSession::cookieStorage() const + 9

1   com.apple.WebCore                       0x0000000106c0ad08 WebCore::cookiesForDOM(WebCore::NetworkStorageSession const&, WebCore::KURL const&, WebCore::KURL const&) + 40

2   com.apple.WebKit2                       0x00000001063f2f93 WebKit::WebPlatformStrategies::cookiesForDOM(WebCore::NetworkStorageSession const&, WebCore::KURL const&, WebCore::KURL const&) + 207

3   com.apple.WebKit2                       0x00000001063f2fb4 non-virtual thunk to WebKit::WebPlatformStrategies::cookiesForDOM(WebCore::NetworkStorageSession const&, WebCore::KURL const&, WebCore::KURL const&) + 17

4   com.apple.WebCore                       0x0000000106c0a9d4 WebCore::cookies(WebCore::Document const*, WebCore::KURL const&) + 132

5   com.apple.WebCore                       0x0000000106cecc7c WebCore::Document::cookie(int&) const + 268

 

 

Second Crash Report:

 

Process:         WebProcess [14122]

Path:            /Applications/WebKit.app/Contents/Frameworks/10.8/WebKit2.framework/WebProcess. app/Contents/MacOS/WebProcess

Identifier:      com.apple.WebProcess

Version:         537+ (537.27+)

Code Type:       X86-64 (Native)

Parent Process:  ??? [1]

User ID:         501

 

 

Date/Time:       2013-01-21 01:28:07.954 -0500

OS Version:      Mac OS X 10.8.2 (12C60)

Report Version:  10

 

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

 

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

 

 

VM Regions Near 0:

-->

    __TEXT                 0000000105183000-0000000105184000 [    4K] r-x/rwx SM=COW  /Applications/WebKit.app/Contents/Frameworks/10.8/WebKit2.framework/WebProcess. app/Contents/MacOS/WebProcess

 

 

Application Specific Information:

Bundle controller class:

BrowserBundleController

 

 

 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0   com.apple.WebCore                       0x00000001064dd61c WebCore::ResourceHandle::start(WebCore::NetworkingContext*) + 76

1   com.apple.WebCore                       0x00000001064dc132 WebCore::ResourceHandle::create(WebCore::NetworkingContext*, WebCore::ResourceRequest const&, WebCore::ResourceHandleClient*, bool, bool) + 578

2   com.apple.WebCore                       0x00000001064e10c8 WebCore::ResourceLoader::start() + 248

3   com.apple.WebCore                       0x00000001064e3393 WebCore::ResourceLoadScheduler::servePendingRequests(WebCore::ResourceLoadSched uler::HostInformation*, WebCore::ResourceLoadPriority) + 435

4   com.apple.WebCore                       0x00000001064e38ac WebCore::ResourceLoadScheduler::servePendingRequests(WebCore::ResourceLoadPrior ity) + 332

5   com.apple.WebCore                       0x00000001066c0a5f WebCore::ThreadTimers::sharedTimerFiredInternal() + 159

 

Third Crash Report:

 

Process:         WebProcess [13098]

Path:            /Applications/WebKit.app/Contents/Frameworks/10.8/WebKit2.framework/WebProcess. app/Contents/MacOS/WebProcess

Identifier:      com.apple.WebProcess

Version:         537+ (537.27+)

Code Type:       X86-64 (Native)

Parent Process:  ??? [1]

User ID:         501

 

 

Date/Time:       2013-01-21 01:27:05.745 -0500

OS Version:      Mac OS X 10.8.2 (12C60)

Report Version:  10

 

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

 

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

 

 

VM Regions Near 0:

-->

    __TEXT                 000000010c29a000-000000010c29b000 [    4K] r-x/rwx SM=COW  /Applications/WebKit.app/Contents/Frameworks/10.8/WebKit2.framework/WebProcess. app/Contents/MacOS/WebProcess

 

 

Application Specific Information:

Bundle controller class:

BrowserBundleController

 

 

 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0   com.apple.WebCore                       0x000000010d5f561c WebCore::ResourceHandle::start(WebCore::NetworkingContext*) + 76

1   com.apple.WebCore                       0x000000010d5f4132 WebCore::ResourceHandle::create(WebCore::NetworkingContext*, WebCore::ResourceRequest const&, WebCore::ResourceHandleClient*, bool, bool) + 578

2   com.apple.WebCore                       0x000000010d5f90c8 WebCore::ResourceLoader::start() + 248

3   com.apple.WebCore                       0x000000010d5fb393 WebCore::ResourceLoadScheduler::servePendingRequests(WebCore::ResourceLoadSched uler::HostInformation*, WebCore::ResourceLoadPriority) + 435

4   com.apple.WebCore                       0x000000010d5fafd0 WebCore::ResourceLoadScheduler::scheduleSubresourceLoad(WebCore::Frame*, WebCore::CachedResource*, WebCore::ResourceRequest const&, WebCore::ResourceLoadPriority, WebCore::ResourceLoaderOptions const&) + 80

5   com.apple.WebCore                       0x000000010cb94a43 WebCore::CachedResource::load(WebCore::CachedResourceLoader*, WebCore::ResourceLoaderOptions const&) + 1155

 


MacBook Air, OS X Mountain Lion (10.8.2)
  • Linc Davis Level 10 Level 10 (107,650 points)
    Currently Being Moderated
    Jan 23, 2013 1:30 PM (in response to iHussein)

    Please post the most recent crash report only in full. Not more than one.

  • Linc Davis Level 10 Level 10 (107,650 points)
    Currently Being Moderated
    Jan 23, 2013 3:08 PM (in response to iHussein)

    Read this whole message before doing anything.

     

    Back up all data.

     

    Quit Safari if it’s running. Then select

     

    Force Quit…

      

    from the menu bar. A small window will open with a list of running applications. Safari may appear in that list, even though you quit it. If so, select it and press return. Close the window.

     

    Step 1

     

    In the Finder, press the key combination shift-command-A to open the Applications folder. Select the Safari icon in that folder and press the key combination command-I to open the Info window. There’s a checkbox in the Info window labeled Open in 32-bit mode. Uncheck it, if checked. Close the Info window and the Applications folder.

     

    If Adobe Flash Player is installed, select

      

     ▹ System Preferences ▹ Flash Player Advanced

      

    and click Delete All. Close the preference pane.

     

    Hold down the option key and select

      

    Go Library

      

    from the Finder menu bar. Delete the following items from the Library folder (some may not exist):

     

    Caches/com.apple.Safari

    Caches/com.apple.WebKit.PluginProcess

    Caches/Metadata/Safari

    Preferences/com.apple.WebKit.PluginHost.plist

    Preferences/com.apple.WebKit.PluginProcess.plist

    Saved Application State/com.apple.Safari.savedState

     

    Leave the Library folder open. Try Safari again. If it works now, stop here. Close the Library folder.

     

    Step 2

     

    If you still have problems, quit Safari again.

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    Drag or copy — do not type — the following line into the Terminal window, then press return:

     

    rm -fr $TMPDIR../C/com.apple.Safari

     

    Quit Terminal. Launch Safari and test.

     

    Step 3

     

    If Safari still doesn’t work right, quit, go back to the Finder and move the following items from the open Library folder to the Desktop (some may not exist):

     

    Cookies/Cookies.binarycookies

    Internet Plug-Ins

    Preferences/com.apple.Safari.LSSharedFileList.plist

    Preferences/com.apple.Safari.plist

    Preferences/com.apple.Safari.RSS.plist

    Preferences/com.apple.WebFoundation.plist

    PubSub/Database

    Safari

     

    (Note: you are not moving the Safari application. You’re moving a folder named “Safari.”)

     

    Try again. This time Safari should perform normally, but your settings and bookmarks will be lost. The default set of bookmarks will be restored. Delete them all.

     

    If the issue is still not resolved, quit Safari again and put all the items you moved to the Desktop back where they were, overwriting the newer ones that may have been created in their place. You don’t need to replace the files you deleted in step 1. Stop here and post again.

     

    If Safari is now working normally (apart from the lost settings), look inside the “Safari” folder on the Desktop for a file named “Bookmarks.plist”. Select

      

    File Import Bookmarks

      

    from the Safari menu bar. Import from that file. Recreate the rest of your Safari settings. You can then delete the items you moved to the Desktop.

     

    Note: This step will remove your Safari Extensions, if any, and their settings. If you choose to restore them, do so one at a time, testing after each step to make sure you haven’t restored the problem.

     

    If you don’t like the results of step 3, you can undo it completely by quitting Safari and restoring the items you moved or deleted in that step from your backup, overwriting any that were created in their place.

  • Linc Davis Level 10 Level 10 (107,650 points)
    Currently Being Moderated
    Jan 24, 2013 1:21 PM (in response to iHussein)

    Please don't post any more crash reports unless requested.

     

    From the menu bar, select

      

    System Preferences Network

      

    If the preference pane is locked, click the lock icon in the lower left corner and enter your password to unlock it. Then click the Advanced button and select the Proxies tab. If any proxy options are selected, deselect them. You don’t need to change the bypass or FTP settings. Click OK and then Apply. Test. The result may be that you can't connect to any web server, so be prepared to restore the previous settings if that happens.

  • Linc Davis Level 10 Level 10 (107,650 points)
    Currently Being Moderated
    Jan 24, 2013 1:38 PM (in response to iHussein)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.