Skip navigation

Magsafe adaptor dosen't work mid 2012 mbp

93 Views 1 Reply Latest reply: Jan 24, 2013 9:18 AM by leroydouglas RSS
3gh2 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 24, 2013 8:22 AM

The adaptor doesn't charge the battery, doesn't light up,and there is no indication that is connected to mbp whatsoever!

I tried my older T adaptor and also reset the SMC, but it didn't help!

 

Any suggestions?

 

I think there is a problem with the logic board for the second time in 6 months!

MacBook Pro, OS X Mountain Lion (10.8.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.