3 Replies Latest reply: Jan 25, 2013 8:25 AM by LarryHN
JorgenKS Level 1 Level 1 (0 points)

Suddenly, iPhoto starts acting weird on me. In some events when I click on the thumbnail of a picture, it is displayed but at the same time an error message is shown which claims the picture is missing. It prompts me to locate the picture, and if I decline a black triangle appears.

 

I have tried all the alternatives provided by starting iPhoto while holding opt+cmd, but without results.

 

In addition all the photos appear as normal on both my iPhone and iPad, even after syncing.

 

Any clues would be greatly appreciated


MacBook Pro, OS X Mountain Lion (10.8.2)
  • 1. Re: iPhoto claims pictures are missing, although they are displayed
    LarryHN Level 9 Level 9 (56,670 points)

    You are seeing the small display preview or  thunbnail - the original high resolution photo is what is missing

     

    In the iPhoto preferences is the preference to "copy imported items to the iPhoto library" checked (default) or have you unchecked it?

     

    LN

  • 2. Re: iPhoto claims pictures are missing, although they are displayed
    JorgenKS Level 1 Level 1 (0 points)

    Thank you for the reply

     

    It is checked, and has always been. All photos are stored in the iPhoto library folder on my computer.

     

    You might be right about the thumbnail, though it is hard to tell since the photos at hand are taken with an iPhone 4. I was not able to find any missing photos in any events taken with my proper camera. I am able to zoom into the photo while the error message is displayed though?

     

    I do keep bakups of both the Library file itself and standalone photos, but either way I find it absolutely unacceptable that iPhoto just looses photos by itself ...

     

    Any other suggestions?

     

    Edit: I might add that my library exceeds 10K photos if that puts me in a greater risk?

  • 3. Re: iPhoto claims pictures are missing, although they are displayed
    LarryHN Level 9 Level 9 (56,670 points)

    Back up your iPhoto library, Depress and hold the option (alt) and command keys and launch iPhoto - rebuild your iPhoto library again

     

    If that does not do it then restore your backup of the iPhoto library from just before the problem

     

    LN