1 5 6 7 8 9 Previous Next 126 Replies Latest reply: Sep 9, 2013 5:55 AM by Giles Go to original post
  • 90. Re: Mail Connections Lost After Sleep (Ports Fail)
    scott321 Level 1 Level 1 (15 points)

    I've been changing the DNS settings in the Mac's System Prefs only. That was where I was instructed by Apple Support to change them when I was having network connectivity issues before. I didn't even know you could change them in the router.

     

    So yes, I changed the DNS in System Preferences/Network/Advanced/DNS Tab. Try that.

     

    And as far as I know, my DNS settings there have never been the IP address of my router.

     

    Sorry, I don't use Dropbox.

  • 91. Re: Mail Connections Lost After Sleep (Ports Fail)
    lamont_ancient Level 1 Level 1 (5 points)

    Hey, some real progress.

     

    I changed to DNS in System Pref to the Apple suggested ones and I switched the Modem/Router back to the default ones (Let ISP manager DNS) and restarted the computer and the modem.

     

    If I click Get Mail straight away I sometimes get the dreaded triangle, but if I keep my eye on the Dropbox icon and/or the WiFi icon until they come live (usually only a few seconds) all seems well with mail.

     

    This is 99% better than having to restart Mail each time.

     

    Very happy indeed.

  • 92. Re: Mail Connections Lost After Sleep (Ports Fail)
    scott321 Level 1 Level 1 (15 points)

    Great Lamont! Glad to hear it worked for you too.

  • 93. Re: Mail Connections Lost After Sleep (Ports Fail)
    Hugo Stiglitz Level 1 Level 1 (0 points)

    This is all nice and dandy, but under Lion mail would retrive my messages during sleep - it was nice coming into my office in the morning and all my emails are all ready and waiting for me. Considering I work with people all over the world, that can be a good amount of messages. Is there any hope of getting this functionality restored?

  • 94. Re: Mail Connections Lost After Sleep (Ports Fail)
    Rangeressary Level 1 Level 1 (5 points)

    It's working again. I found a pref file from the Google Drive app that hadn't been deleted. Apparently that was it. It seems to me that all of these things can contribute to the problem:

     

    1. Outdated router or router software.

    2. Google Drive app or Archy

    3. Slow DNS servers

     

    Fortunately, it's working now, so I hope it continues.

  • 95. Re: Mail Connections Lost After Sleep (Ports Fail)
    robolz Level 1 Level 1 (10 points)

    I have been getting the problem since I switched to Mountain Lion ten days ago.  As with others, I get the dreaded triangular icons when I come back from Sleep, but if I quit Mail and then re-start it everything is resolved.

     

    I presume that this is a DNS problem, but it is occurring for me in different network set-ups (but not all...).  In most of the set-ups I use, the DNS servers are Google (8.8.8.8 and 4.4.4.4).  I have had for a long time other DNS problems that I have not been able to solve, that seem to affect my Mac and not other computers, and which are visible when browsing (I use Chrome), so I am inclined to be suspicious of DNS.

     

    In the networks where I am administrator, I have ensured that the WiFi access points and the routers (if separate) have the latest software.  However, I have just tested this with WiFi disconnected and Ethernet connected, and the problem is the same.

     

    I usually run Google Drive, but I have quit this program and the problem still continues.

     

    I am assuming that one of these days Apple will release a software update that fixes the problem.  It seems to me to be a bug that one cannot even manually get the Mail program to re-test the connections without having to quit and re-start the program.

  • 96. Re: Mail Connections Lost After Sleep (Ports Fail)
    lamont_ancient Level 1 Level 1 (5 points)

    Yes, the problem is definitely DNS speeds, mine was also initially fixed using the Google DNS Server numbers (actually these are 8.8.8.8 & 8.8.4.4).

    But there is an even better (read faster) way to come up with the best option/s for your own situation.

    Download the free utility 'namebench' and run it multiple times then collate the results to find the fastest DNS servers in your area.

    Mine turned out to be those run by iiNet subsidiaries (Internode and Westnet) and Telstra. It's an interesting exercise.

    Suffice to say I'm delighted by the results.

  • 97. Re: Mail Connections Lost After Sleep (Ports Fail)
    robolz Level 1 Level 1 (10 points)

    Thank you lamont_ancient (for the correction to the secondary Google DNS address and for the pointer to Namebench).

     

    In fact, it turned out that I already had Namebench installed, but I had forgotten about it.  I set it running to check out DNS servers, but it was still running after a couple of hours when I had to move office.  Clearly this has to be run when the computer is going to stay put for a long time (not so suitable for my mobile laptop).

     

    I have tried to test out further the Mail connectivity problem and somehow, for now, I have managed to get the problem to go away...

     

    From Mail's 'Connectivity Doctor' I could see that the problem was only reported from Google's IMAP connections (not others) and that it was the SMTP connection was failing.  I therefore did a tidy-up of the SMTP server definitions.  Nearly all my connections to smtp.gmail.com were going via port 587 (specified by Google for TLS).  I first changed these to port 465 (the other SSL port).  This didn't seem to fix the problem, so I went through and changed all the smtp.gmail.com port definitions to "Use default ports (25, 465, 587).

     

    I have been through the sleep cycle 3 times since without a problem (when there used to a problem on every occasion before at the current location), so fingers crossed!

     

    NB: I got a pointer to this solution because, in my frustration, I installed Postbox as a replacement for Apple Mail, and Postbox complained about the IMAP smtp connection to Google via port 587.  However, when I changed the connections to go via port 465, the problem went away.

     

    I do not believe that that I have any firewall intervention of connections via port 587, but there is quite possibly also some network issue involved.  Nevertheless, I have achieved a major improvement (and maybe a solution) without DNS changes.

  • 98. Re: Mail Connections Lost After Sleep (Ports Fail)
    robolz Level 1 Level 1 (10 points)

    I apologize if I have misled anyone.  Changing the SMTP port settings did NOT fix my problem.

     

    It turns out that I did not get a problem reconnecting via IMAP after Sleep because I was also running Postbox at the same time as running Apple Mail.  Since Postbox is querying the same IMAP accounts (incidentally, without getting any problems), this seems to interact with the queries of Apple Mail and resolve the problems!

     

    When I quit Postbox before entering Sleep, on re-start the IMAP connectivity problem returned to Mail.

     

    It certainly seems that Mail's problem is an incompatibility between Mail and certain network configurations (possible DNS).  On the two networks that always have the problem, DNS is being served from a Linux server running DHCPD - which potentially is a factor in common, since this DHCP service is a little slow to come up.  I do not think that the problem is related to the selection of DNS servers, since I use Google DNS servers in several networks and the Mail problem has not shown itself when the DHCP server is the local router (WiFi access point).

     

    I've used up all the time I can devote to this now, and I am switching to Postbox instead of Apple Mail.

  • 99. Re: Mail Connections Lost After Sleep (Ports Fail)
    robolz Level 1 Level 1 (10 points)

    I have in fact found a few minutes to investigate my latest theory of the role of the DHCP server in this problem.  I changed the DHCP setup to use the local WiFi router as the DHCP server.

     

    This DID fix the problem - and I cycled through Sleep twice to verify this.

     

    Presumably the Linux-server DHCPD set-up is working too slowly for Mail (the only explanation that I can think of, since the other parameters given out by this DHCP server are the same).

     

    The frustrating issue about tracking down and resolving this problem is that there are so many solutions that can apparently provide a fix.  However, I recommend anyone who is still having the problem to change their DCHP server.  All WiFi routers have a DHCP server, that is enabled by default, which could be a reason that many people would never see the problem.

     

    Of course, this solution does not work if you do not control the network...

  • 100. Re: Mail Connections Lost After Sleep (Ports Fail)
    bajawil Level 1 Level 1 (0 points)

    Sorry are you saying to use the router's DHCP server or not?

    I have thsi issue and my router's DHCP server is enabled.

    -w

  • 101. Re: Mail Connections Lost After Sleep (Ports Fail)
    robolz Level 1 Level 1 (10 points)

    Hello Bajawil, I was able to get it to work by changing to the router's DHCP server (which I had disabled before, since there is another DHCP server in the network).  So, yes, I was recommending using the router's DHCP server.

     

    However, I'm sorry that this is not working for you.  There seem to be so many possible conditions that can cause, or fix, this problem - but no single solution seems to work for everyone.

     

    I think that Apple will have to fix this once and for all in an update to Mail.  In the meantime, I have moved to Postbox (that seems to be better than Mail in any case, and only costs $10), since I need to rely on having my email client working wherever I am without having to check it all the time.

     

    Postbox can be found at http://www.postbox-inc.com/    Installation is well automated, and there is a free trial for a month.  You can even use it in parallel to Apple Mail, if you are using IMAP accounts.

  • 102. Re: Mail Connections Lost After Sleep (Ports Fail)
    softwater Level 5 Level 5 (5,370 points)

    robolz wrote:

     

     

    Postbox can be found at http://www.postbox-inc.com/    Installation is well automated, and there is a free trial for a month.  You can even use it in parallel to Apple Mail, if you are using IMAP accounts.

     

    I tried this. Looks nice and has some cute features, but it didn't work for me.

     

    This app won't let me send any mails at all because (it says) it can't connect to the SMTP server even when its connected online. At least Mail works when its connected!

     

    Back to Mail...

  • 103. Re: Mail Connections Lost After Sleep (Ports Fail)
    robolz Level 1 Level 1 (10 points)

    I've just been trying Postbox for a couple of days, and I'm sure to find some shortcomings - although the connections have worked without problems once I changed the SMTP port definitions from 587 to 465 (for connections to Google email accounts).

     

    Softwater, what do you mean when you say "...when it's connected online"?  How do you know if it is "connected online"?

     

    I understand that IMAP (for downloading email titles or contents) works by polling, and that SMTP (for sending emails) works by establishing a connection for every send.  Therefore, I don't think that the low-level connection is ever 'online'.  This terminology is used by Mail and Postbox, but I think that it simply means it is currently configured to poll via IMAP regularly and that this is working.  Mail seems to take the accounts 'offline' when there is a problem with SMTP, even if there is not a problem with IMAP.

  • 104. Re: Mail Connections Lost After Sleep (Ports Fail)
    softwater Level 5 Level 5 (5,370 points)

    Yeah, you're probably right. I have no doubt I could get it up and running if I was prepared to invest the time.

     

    The thing is rob, I spend a lot of time troubleshooting macs and OS X machines that have gone off the rails for one reason or another, but I'm just not really into troubleshooting a 3rd party app whose setup I followed to the letter but which didn't work out of the box. Life's too short.

     

    I'll stick with Mail unless it causes me more timewasting than figuring out what's wrong with Postbox.

     

    Thx for your reply.

1 5 6 7 8 9 Previous Next