Skip navigation

iPhoto won't work, new iMac

772 Views 3 Replies Latest reply: Jan 25, 2013 10:45 AM by steve626 RSS
JoryKing Calculating status...
Currently Being Moderated
Jan 24, 2013 9:00 PM



I recently purchased a new iMac (late 2012), and had all of my photos moved over from my old MacBook. I had a problem where iPhoto wouldn't import photos and instead would crash whenever an import was attempted. After moving all of my folders, files, pictures, music, etc. from my old Mac, iPhoto wouldn't work on my new iMac, either.


I have tried restoring the iPhoto library (Command+Option), I have tried "iPhoto Library Manager" (failed), and I have uninstalled and reinstalled the app. I have also backed up my photos via a flashdrive and they are safe but they won't import. I have also created a new library and tried importing and that also failed. I looked for 3ivx and I don't have it (searched for it in spotlight and Control+UpArrow 3x's, then application support, not there).


iPhoto says: "iPhoto has detected inconsistencies in your library. Please click Repair to avoid any potential problems". I click repair and then it says: A photo has been found in the iPhoto library that was not imported, would you like to import it?

     ^^This is where I run into problems, as iPhoto will not import anything without crashing.^^


Any help is greatly apprecitated,


iMac (21.5-inch, Late 2012), OS X Mountain Lion (10.8.2)
  • Terence Devlin Level 10 Level 10 (121,680 points)
    Currently Being Moderated
    Jan 24, 2013 11:01 PM (in response to JoryKing)

    Post the first 50 lines only of the crash report






  • steve626 Level 4 Level 4 (1,395 points)
    Currently Being Moderated
    Jan 25, 2013 10:45 AM (in response to JoryKing)

    I don't want to interfere with troubleshooting Mr. Devlin is already helping you with. However, there are some simple things you can do that might narrow the problem down.


    (1) Open iPhoto with the option key held down, create a new Library. Import some jpg files that are NOT FROM YOUR EXISTING iPHOTO LIBRARY into that new Library. I suspect some of the photos in your Library might be corrupted so use new or different jpg files. Work with them some in iPhoto. Does it work?


    (2) Log in as a different user, or create a new user and then log in as that user. Try using iPhoto without anything from your old Library. Does that work?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.