Previous 1 7 8 9 10 11 Next 194 Replies Latest reply: Feb 4, 2016 11:21 AM by computer dr Go to original post
  • WilsonGarr Level 1 (0 points)

    Thanks for your response. I did that with a mac genius at the Apple store in Grand Central. It worked for a bit. But what we learned in the process was that the cause of this was a DNS Changing virus that was extreamly deeply buried in the lap top somewhere. It was not the one that the DNS Changer virus Detecter could find. I ran that a lot and it could not detect it.


    The final solution for me was to back up every thing and erase the drive and restore the system software (10.7). Now my 6 year old 17" MacBook pro runs like it is brand new. I am so relieved!


    If you get the right Mac Genius this can be helped.

  • iPingu Level 1 (0 points)

    Any suggestions for the following?...


    iMac cannot connect to internet through browsers (Firefox & Safari). Several other devices iPhone/iPad/PCs all fine on home network with no recent changes made. Cannot obtain IP address through DHCP but assigned manual IP address and can ping local and internet address e.g. or


    Tried wireless and wired connection to router. Reboots of Mac and router etc. but no luck!

    iMac, Mac OS X (10.6.8)


    Also I've copied DNS server addresses that are being used on iPhone and there are no proxies set. Can ping router but not access it through browser.


    A real head scratcher hey?

  • Darin93 Level 1 (0 points)

    I am having the same issue.  Any luck resolving?

  • amcd134 Level 1 (0 points)

    Your solution worked perfectly for me! Thanks!

  • amcd134 Level 1 (0 points)

    Caleb96's solution solved my problem. It was easy and did the trick. Hope it works for you, too!

  • girl_tuesday Level 1 (0 points)

    I tried some of the tricks and tips here, as my iPad and iPhone still worked.  I found I needed to turn my router off and on and then disconnect and connect to the Internet on my MacBook.  Problem fixed.

  • mizzoug Level 1 (0 points)

    Just wanted to throw my solution in here in case it helps.  The other day, my daughter had trouble connecting to our home network with her new MacBook pro when she came home from college and just today (after an update), my other daughter's iphone 5 (which had worked fine since she bought it) was having the same problem.  Both would get an ip address from the router and say connected to our home network (WEP), but neither could surf.  I solved the problem by going into the router settings and finding the device in the list.  Both were listed as new-host-etc. I matched the ip addresses to figure out what was what and renamed the device in the router to match the device's actual name. The devices seem to think the connection is now secure and daughter one hasn't had the problem in a week and so far, so good with daughter #2.

  • bricriu1 Level 1 (0 points)

    Solution that worked for me was resetting the NVRAM:


    Probably shouldn't have fixed it, but it did.

  • mattfromsaint michael Level 1 (0 points)

    I am having the same issue as stated and I work in a school and slowly this week more and more of my computers are doing this. All computers so far are the older white macbooks running SL, and all computers were last updated summer of 2012 (most more recently). I have tried the two fixes mentioned with deleting the airport and deleting configuration from the library and this did work on some machines, but others nothing will work. This has happened with computers being turned on for the 1st time this school year, computers that have been working all school year, and computers that have been created recently from a good clean image.

    I have tried to superduper a working computer to another and the network settings do not follow.

    Looks like this issue has been around for sometime so I would guess there is not a bug/virus.

    I am sure I could rebuild a computer and make a new image, but this is hard mid-school year for student computers, and it is hard to netboot a computer that cannot connect to the network!


  • jconxus Level 1 (0 points)

    This worked for me.


    Go to Library > Preference > System Preferences




    I got it from:



    I don't know why it works, but it does.


    It worked on my Mac Mini and MacBook Pro.


    Good luck!

  • jayda187 Level 1 (0 points)


    Dont know if this will help anyone,but after reading the post,deleteing airport, system configurations,restarting and trying various other drastic steps etc,the ony thing that worked was a tip from a youtube vid (can't remember the link but it is on this thread somewhere.Its 2 parts.Sorry!) All I did was:

    go to system preferences> network>advanced>(click on your airport bit, mine was always green and said connected but it never connected fully to a page, would just hang for ages)

    >click advanced down on the bottom right

    >then click the TCP/IP tab>

    then theres a bit that says router:( this is the router address,mine was,copy and paste this.Then click the DNS tab.

    The router address should be in the DNs servers bit. If it isn't, apparently, thats what the problem is! So just press the '+' symbol, paste your router address and then click ok and then apply. It was that simple.

    After struggling for a week and going on various forums, this is the only thing that worked and now i'm up and running fine. I have a 5 year old macbook with version 10.5.8


    Hope this helps someone! good luck!

  • rdonald1 Level 1 (0 points)

    Ok BDAqua...I see you seem very knowledgeable. Can ping anything via address or hostname, but only resolve a few web addresses in Firefox. All other sites and browsers dead in the water

    I am running 10.6.8 - latest update

    I have Firefox, Safari, Chrome

    I have checked DNS and added


    I have tried at home, corporate network, at hotel...eliminating the router as a cause

    I've removed the battery...

    I've delete systemconfiguration in Preferences

    The weird thing is that I can open facebook and get updates in firefox and one other site. Otherwise ALL other browsers and sites are dead


    I've tried many of the fixes in the forum but am clueless as to what to try next. Any help you can provide would be awesome. I'm sunk here


  • rdonald1 Level 1 (0 points)

    Hey bud! thanks for the reply post. i've tried everything but a sledgehammer. Simple fix and worked for me.

    Much appreciated!

  • rdonald1 Level 1 (0 points)

    Hey BDAqua, disregard my request. It was an NVRAM issue! I figured something was hung up somewhere!


    Your time is better spent helping others.


  • gronkster Level 1 (0 points)

    Big thanks to Rigelface   for his solution on 1st page


    So simple and fixed my issue immediately. Even my ISP could fix it... 


    Now I have 90 old emails to go through

Previous 1 7 8 9 10 11 Next