Skip navigation

Help with numbers saving as PDF

2003 Views 17 Replies Latest reply: Oct 2, 2013 8:49 AM by guineapig RSS
1 2 Previous Next
Bdjohnson23 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 25, 2013 1:34 PM

Hi all,

 

I have an excel spreadsheet which I have sent to new ipad and opened in numbers. Now I know it will not support all features but the numbers version is working fine for what I need. (Electrical installation certificates)

My problem comes when I save to a pdf (this is how certificates are sent to clients), when saving to PDF the spreadsheet saves fine to one page but I then have another 3 pages containing some empty cells?

 

If anyone could advise I would greatly appreciate, I could send a copy which may explain exactly what I mean.

  • BigTarantula99 Level 2 Level 2 (470 points)
    Currently Being Moderated
    Jan 25, 2013 1:37 PM (in response to Bdjohnson23)

    This could have something to do with the fact that the original spreadsheet was Excel, not Numbers.  Try exporting to PDF right from Excel if possible.

  • BigTarantula99 Level 2 Level 2 (470 points)
    Currently Being Moderated
    Jan 25, 2013 1:53 PM (in response to Bdjohnson23)

    Unless you can recreate it into Numbers for iPad, you will probably have to export as PDF right from Excel.  Why does it "need to be sent to iPad"?  Was there a problem with Excel or something?  Just clarifying...

  • BigTarantula99 Level 2 Level 2 (470 points)
    Currently Being Moderated
    Jan 25, 2013 2:09 PM (in response to Bdjohnson23)

    I assume you're using the Email function right from Numbers to email as a PDF.  Try this, though I'm not sure if it will help any:

    Go to the App Store and download "Adobe Reader".  This is an app that gives you full control over PDF files.

    When fully installed, go back to Numbers and use the "Open in Another App..." functionality to export the spreadsheet as a PDF and enter it into Adobe Reader.  If everything looks fine now, email it right from Adobe Reader.  Hope this helps!

  • liet_MN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 25, 2013 2:25 PM (in response to Bdjohnson23)

    I have the same issue.  I believe it is the max page size allowed by iOS Numbers being probably smaller than what Mac Numbers allows:

     

    I developed a Logging spreadsheet in Mac Numbers which I want to use to email reports from the road from my iPhone.  It looks fine in Mac Numbers as a one-page document; all the Tables are on one Sheet, is 1-page in Print View, etc.  If I Export as PDF to my Mac and then open it, it is fine, one page.  If I open it in iOS Numbers it looks fine as well.  When I export it from iOS Numbers, however, it comes as 4 pages, with overflow parts of Tables on the pages 2-4.  What is the maximum "printable" area for a PDF export from iOS Numbers? 

     

    I will try reducing my form so it has more margin space to test this, but wonder if anyone has an idea of the max parameters.

  • BigTarantula99 Level 2 Level 2 (470 points)
    Currently Being Moderated
    Jan 25, 2013 2:35 PM (in response to liet_MN)

    Problably what I would do would be to keep all of the information in the top-left part, without scrolling down or right.

  • BigTarantula99 Level 2 Level 2 (470 points)
    Currently Being Moderated
    Jan 25, 2013 2:38 PM (in response to BigTarantula99)

    I just tested it - the theory is correct.  It will only export as a PDF within an 8.5 by 11 page.  Just narrow it down as best you can.

  • liet_MN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 25, 2013 3:02 PM (in response to Bdjohnson23)

    Non-sequitur.  1) We want Forms to look right and be layed-out nicely on the page for the client, not all bunched up in the upper-left corner;  2) Apple should have provided the size dimensions for the area you can place stuff on iOS Numbers for PDF 8.5x11, if it differs from Mac Numbers.  Someone might know and post this info here.

  • mkral Level 2 Level 2 (220 points)
    Currently Being Moderated
    Jan 25, 2013 8:50 PM (in response to Bdjohnson23)

    I might be missing something, but if everyhing shows up on the first page when you export as PDF, but then you have three blank pages, it sounds like the Table has too many rows and/or columns in Numbers. This frequently happens when you import a file from Excel to iPad Pages. Across the top and left side of the table, there will be white bars. If you follow those bars to the end (top bar to the far right/ Left side bar to the bottom), you will see what looks like a button. Click and hold on the button and drag it (up or Left) until it removes the rows/columns that you don't use.

     

    At this point, your table should not have any empty rows of cells. Now try exporting as PDF & see if it looks like you wanted it to.

  • mkral Level 2 Level 2 (220 points)
    Currently Being Moderated
    Jan 26, 2013 6:22 AM (in response to Bdjohnson23)

    BD, you mentioned that you have a copy you could send. If you don't mind, send me a copy at blahblahblah1235@live.com, then post a reply on here to let me know. (That's an account I use when I put an addy on the net, but I don't check unless I'm expecting something, to cut down on junk mail). I'd be happy to take a look & see if I can figure anything out. Aside from that, it's hard to think what lse could be causing this.

  • mkral Level 2 Level 2 (220 points)
    Currently Being Moderated
    Jan 26, 2013 8:16 PM (in response to Bdjohnson23)

    BD,

     

    There were three blank sheet coming across in the PDF. It was a combination of two things.

     

    1. The sheet is a little too wide for 1 page across. This was causing one of the blank pages. You can either shrink it a bit, or else use the option in Excel or Pages to auto-fit it to 1 page by 1 page. In Pages, you find this on the print preview screen, at the bottom right, just make sure Auto-Fit is on, that will shrink the document to fit on a page. In Excel, you can also choose "fit to x pages by x pages. On the Mac version, that option is on the ribbon, on the Layout tab. I'm not at work, so I can't verify where it's at on the Windows version of excel, but it's there as well. Once I clicked that on excel, it saved the doc to 94% size & it got rid of the one extra blank page.

     

    2. The other two pages are showing up because you have the sheet you are using, but also Sheets 2 & 3 in that document. Pages has an option "Page Numbers" that is set to on. Not sure if that is by default or is just set that way for your document. Either way, it is causing Sheet 2 & 3 to print out blank, but with a page # in the footer. If you aren't using Sheets 2 & 3, just delete them, that will be the easiest solution. If you do plan to use them, then you need to go into Print preview on iPad Pages, then click the little gear & turn 'Page Numbers' Off. once I did that, it printed to PDF as 1 page, with no blank stuff at the end.

     

    Hope this fixes it for you. Let me know if you stil have problems with it.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.