5 Replies Latest reply: Jan 30, 2013 8:29 PM by TheFirstRook
clint6c Level 1 Level 1 (0 points)

The external sound doesn't work for any videos.  As well as, the side volume controls don't respond.  Even though they are turned on in "settings".


iPhone 4S, iOS 6.0.2
  • 1. Re: No External Sound
    JimHdk Level 7 Level 7 (23,635 points)

    If you lose sound for keyboard clicks, games or other apps, email and other notifications, system sounds have probably been muted.

     

    System sounds can be muted and controlled in two different ways: either by the side switch (located next to the volume up/down controls) or in the Recent Apps tray. The initial default is via the side switch.

     

    Check the status of Settings > General > Use Side Switch to:. If this is set to Mute, the switch on the side of the iPad will mute system sounds.

     

    If this is set to Lock rotation then the mute system sounds control is in the Recent Apps tray. Double tap the home button and, in the tray which appears at the bottom, swipe all the way to the right. The speaker icon is on the left. Is it is crossed-out tap on it and mute will be turned off and system sounds will be turned ON.

     

    This Apple Support article explains in more detail how the side switch works.

    http://support.apple.com/kb/HT4085

  • 2. Re: No External Sound
    clint6c Level 1 Level 1 (0 points)

    Thanks bro, but my issue is the iphone 4s.  I did try to apply your tips though in a similiar fashion.  I doubled tapped the home key and scrolled over a sound bar that displayed the sound was turned all the way down.  I tried to manipulate that, but it was unresponsive as well. 

  • 3. Re: No External Sound
    JimHdk Level 7 Level 7 (23,635 points)

    Yep, that advice was for the iPad. Maybe another cip of coffee!

  • 4. Re: No External Sound
    clint6c Level 1 Level 1 (0 points)

    LOL, no worries.  I appreciate it anyway.

  • 5. Re: No External Sound
    TheFirstRook Level 1 Level 1 (0 points)

    I had the same problem as well for nearly 3 months.

     

    I had tried bring the Iphone into my phone carrier and they sent me to the AppleStore. When I brought it to them they hooked it up to the diagnostic machine and they told me just to restart the Iphone from the factory settings.

     

    This didn't work either. To complicate things more, other "solutions" seem to only yield temporary success. These temporary solutions included: blowing compressed air into every port, various restart combinations, various factory restore methods.

     

    I had nearly given up until I stumbled upon a support post on Apple's website that finally yielded success.

    http://support.apple.com/kb/TS1630

     

    The solution for me is listed as line 7, which reads:

    "Check the receiver mesh (which is on the top front of the device, above the display). If it appears blocked, use a clean, small, dry, soft-bristled brush to carefully and gently brush away any debris."

     

    Apparently, this cylinder shaped, mesh area is in some way tied to what triggers the headphones/speaker selection. I am not sure how, but I can say that after gently brushing it out my sounds are working again; specifically my music is now able to play directly off the speakers and my Iphone apps all play their sounds agian.

     

    Hope this helps you as well!