Skip navigation

Bug? Menu option has disappeared!

455 Views 11 Replies Latest reply: Mar 9, 2013 2:07 PM by snir RSS
superQuest Calculating status...
Currently Being Moderated
Jan 18, 2013 8:41 AM

Apologies for a duplicate posting, I started a discussion yesterday under the heading "Can't join tracks in iTunes 11" but there have been several discussions under that heading, and most of them have apparently been resolved by directing the poster to the new menu location. That's not my problem. I found the "Join Tracks" option in its new location and imported the first disk of an audiobook, but with every succeeding disk I've tried the menu option has disappeared. It's not greyed out -- it just doesn't show up!  Here's what I just posted to the old thread:


This appears to be a bug in iTunes 11 -- the menu option for "Join Tracks" doesn't appear under the "Options" menu. I'm not looking for the "Advanced" menu; I know the menus have changed in this new version. "Join Tracks" did appear for the first audio disk I tried since the upgrade, but doesn't anymore. I really use this feature of iTunes -- I listen to audiobooks on my iPod all the time, and it works best if I can join the tracks before importing.


I've tried with 4 separate audiobooks from the library -- the menu option doesn't appear with any of them.


I tried editing info on some of the CDs, thinking I might find whatever it is that triggers the menu option to appear. No luck so far, and I don't have the time to do this kind of experimentation, sorry!


Please help!

Mac mini, OS X Mountain Lion (10.8.2)
  • peepsulathegreat Calculating status...
    Currently Being Moderated
    Jan 20, 2013 7:11 AM (in response to superQuest)

    Had the same problem that started with one CD and then has never been resolved on any successive CD's.  My solution was to download an app call Audiobook Builder from the app store.  It joins the tracks and puts the file in books in my iTunes library.    My situation is even more complicated by the fact that my main machine is a new iMac w/o a drive so I am ripping on my older Mac Pro then home sharing single files to my new machine, then using audiobook builder.  In am more than curiouis as to what the trigger was.

  • Jimzgoldfinch Level 5 Level 5 (4,575 points)
    Currently Being Moderated
    Jan 21, 2013 9:20 AM (in response to superQuest)


    This is odd as joining tracks works fine for me. I tried both audio discs & music CD's. On first attempt, I did not highlight tracks to be joined and when I selected Options on top right hand corner, I only got options either to submit track names or get track track names. However once I selected the the apprpriate tracks, I now got option to join the tracks.


    I find it odd that Itunes 11.0.1 works fine for me but many others have reported anomalies such as this!!


    Have you tried deleleting Itunes plst file then relaunch itunes?



  • mommichief Calculating status...
    Currently Being Moderated
    Jan 25, 2013 12:19 PM (in response to peepsulathegreat)

    Thank you for posting this app!!!! I was just about to give up on being able to import books any more. I've lost join tracks and can't get it back. Thanks again!

  • Jimzgoldfinch Level 5 Level 5 (4,575 points)
    Currently Being Moderated
    Jan 26, 2013 12:08 AM (in response to superQuest)


    When I have joined tracks, I have always joined at time of import. I use this method on most of my classical CD's. I have only one Audiobook with 6 discs.


    I have never been able to join tracks after import - don't know if this was ever possible. The only way I have been able to do this is to use an App called "Join Together".


    It is strange that you have this problem!



  • Jimzgoldfinch Level 5 Level 5 (4,575 points)
    Currently Being Moderated
    Jan 26, 2013 8:43 AM (in response to superQuest)


    I have been been importing a few clasical discs recently. I had access to one set of audiobooks which I joined and added successfully.



  • Karens76 Calculating status...
    Currently Being Moderated
    Jan 30, 2013 2:29 PM (in response to superQuest)

    mine is no longer there either, this started last night, I was in the middle of a audio book on disk 6 when it suddenly was no longer there.

  • snir Calculating status...
    Currently Being Moderated
    Mar 9, 2013 1:59 PM (in response to superQuest)

    I deleted itune and all itune related preference files, then reinstalled. The join track option reappeared

  • snir Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2013 2:07 PM (in response to superQuest)

    And then disappeared again!

    Most annoying


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.