4 Replies Latest reply: Jan 26, 2013 7:58 AM by DLScreative
DLScreative Level 4 Level 4 (1,595 points)

As a general housekeeping practice, I check for offline images regularly.  Today I found 100 images and videos offline. They are all  from the same project, but only part of the project is affected. 

 

A spotlight search reveals that the images are exactly where Aperture thinks they are supposed to be.  Not only does Aperture think they are offline but it doesn't see them at all in the reconnect dialog. 

 

I've repaired permissions, repaired the database and rebuilt the database.  DiskUtility gives the disk a clean bill of health, and it's properly formatted.

 

I've never seen this.  Have you?

 

Still running 3.2.4 BTW

 

DLS


MacBook Pro, Mac OS X (10.7.4), 2.2GHz quad i7/8GB RAM/1GB VRAM
  • 1. Re: Offline images not offline/ can't reconnect
    DLScreative Level 4 Level 4 (1,595 points)

    Back at my workstation with fresh eyes, I find that I was mistaken about the results of the spotlight search.  The images were not on the primary drive but on the backup drive which has the same name as the primary drive with the word "backup" added. (this name was truncated in the search results) The drive was still connected because I had run backups earlier in the day.  Now I just have to figure out how the images were removed from a drive that I never manage in the finder.

     

    I'm also a little surprised that SuperDuper didn't remove the files from the backup drive if they weren't on the primary drive when I ran the backup.

     

    DLS

  • 2. Re: Offline images not offline/ can't reconnect
    DLScreative Level 4 Level 4 (1,595 points)

    On a side note, there were 20 other missing files that weren't related to the above issue.  These were unimportant test shots, but interestingly Aperture is looking for the memory card from camera to reconnect them.  This means that I imported them in their current location which I didn't think was possible when importing from a card.

     

    DLS

  • 3. Re: Offline images not offline/ can't reconnect
    Kirby Krieger Level 6 Level 6 (11,935 points)

    DLScreative wrote:

     

    I've never seen this.  Have you?

    No.  I was hoping someone would reply.  The only issue I can remember that seemed related dealt with encrypted drive(s).

    DLScreative wrote:

    Back at my workstation with fresh eyes,

    Now we're getting somewhere  .

     

    I still have nothing to add that you haven't thought of or are planning to do, to wit: clean up everything you can and be sure to get rid of the memory card stub.  Then copy the Library to a newly-formated drive, run Repair Database, and see what you end up with.

     

    Is there something in 3.4.3 that keeps you from upgrading?

  • 4. Re: Offline images not offline/ can't reconnect
    DLScreative Level 4 Level 4 (1,595 points)

    Kirby Krieger wrote:

     

    .

     

     

    Is there something in 3.4.3 that keeps you from upgrading?

     

    I only have one workstation these days, and I can't spend two days (my own estimate)  updating my library.

     

    DLS