3 Replies Latest reply: Jan 26, 2013 1:15 PM by léonie
SeAn3944 Level 1 Level 1 (0 points)

I have downloaded aperture last week and I have some major problems. I mean like it take like 5 min. to make simple edits. The program overall is very laggy !!!! I really need help because I edit a lot of photos. This have been happening even when i restart my computer and restart hte program and there is no updates avaibale. I was wondering if RAW could possibly be affecting the speeds but i have not taken alot of photos in RAW so i really dont know the problem.


MacBook Pro, OS X Mountain Lion (10.8.2)
  • 1. Re: Extreme lag problems
    léonie Level 9 Level 9 (51,740 points)
    I mean like it take like 5 min. to make simple edits.

     

    That certainly should not be the case, unless your images are Gigabyte sized scans.

     

    But we need to know more, to have an idea what might be going on.

    • Did you import large amounts of image files? Then Aperture may still be doing the inital processing. Show the activity window, to se recentlye what Aperture is doing.  (Main menu bar > Window > Show Activity).
    • Do you have enough free disk space? How full is your disk?
    • Where is your Aperture library located? On your internal drive or on an external drive, and how is this drive connected?
    • How much RAM do you have?
    • Also have a look at the "Activity Monitor" utility. You can launch it from the "Applications > Utilities" folder. It will show you, how much processing time, memory, disk outs Aperture is using, and if other applications are competing for the processing time. To see, if Aperture alone is needingall the resources I'd reboot and then check in the "Activity Monitor" what is happening, if Aperture is the only application running.
    • Is your Aperure library a new library, or are you using an iPhoto library, that you are now opening in Aperture?

     

    Regards

    Léonie

  • 2. Re: Extreme lag problems
    SeAn3944 Level 1 Level 1 (0 points)
    • I am not using Gigabyte sized scans.
    • I import about 80 files at ounce but it causese me to lag my whole computer as the same time.
    • I have 300gb of free space.
    • I have the file located on the internal hardrive.
    • I have 4gb of RAM (Macbook Pro late 2011).
    • My activity Monitor is blank.
    • My library has been switched over from iphoto two weeks ago.
    • As you can tell there is not a obvious reason because my macbook pro is fairly new
  • 3. Re: Extreme lag problems
    léonie Level 9 Level 9 (51,740 points)

    My library has been switched over from iphoto two weeks ago.

    Does your iPhoto library contain smart albums created in iPhoto? Then launch the Console.app from Applications > Utilities before you start Aperture and look, if you get diagnostic messages in the Console similar to this:

    8/6/12 6:22:32.589 PM Aperture: [<RKAlbum 0x1240e7a20> valueForUndefinedKey:]: this class is not key value coding-compliant for the key minImageDate.

    In that case it will help, to delete the iPhoto smart albums and to recreate them in Aperture, see this post by Alex Brown: Aperture 3.3.2 unresponsive if library contains old iPhoto albums - solution

     

    If the smart albums are not the problem, try, if you can work with Aperture at all: Create a new, empty library, import some images and try to edit. Is Aperture still unresponsive?

     

    To create an empty library launch Aperture with the options-key held down and select "other/new" from the panel.

     

    If Aperture works well with a new library, use the First Aid Tools to repair the Aperture Library:

    Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library

     

    Regards

    Léonie