Skip navigation

full text search gives more results than expected

739 Views 13 Replies Latest reply: Feb 26, 2013 3:50 PM by Koen van Dijken RSS
Koen van Dijken Level 1 Level 1 (15 points)
Currently Being Moderated
Jan 26, 2013 2:53 PM

When I enter a search string in the textbox above the browser I get some unexpected results.

 

full text search.jpg

 

Besides images with the keyword 'unid' I also get images which in not any of its metadata field the (sub)string 'unid' is contained. This is what the filter dialogbox shows:

 

filter.png

 

When creating a metadata view showing all metadata fields not any of the metadata fields contain the string 'unid'. This string is also not contained in any of the projectnames, foldernames, -paths etc.

 

I do not know why these images show up. Can anyone shed some ligth on this matter?

 

Koen

 

Aperture 3.4.3, OSX 10.8.2

  • Kirby Krieger Level 6 Level 6 (11,570 points)

    Check the Project description field ("⇧i" with a Project selected, or click the "i" superimposed on the Key Photo in Projects view).

  • léonie Level 8 Level 8 (46,510 points)

    That is an interesting puzzle, Koen.

     

    I tried your search in my own library and found that roughly 10% of my pictures show up, when I search for "unid" with "Text includes", but I do not see this string in any of the EXIF or IPTC tags, just like you. The funny thing is, I find exactly the same images, if I use the search rule "Place includes unid".

    The result are images from the United States, Spain, Australia, Great Britain. None of the place names includes this string.

    So I suspect, the string is hidden in the "Places" representation in the versions inside Aperture. I searched the original master files and the exported versions with exiftool, strings, grep and could not find the string "unid" anywhere.

     

    Do your "unid" pictures also have places assigned?

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,510 points)

    Clever idea, Kirby, but it does not explain my results. But not all images in a project are turned up by the search, at least in my case. So it cannot be something in the project description.

  • Kirby Krieger Level 6 Level 6 (11,570 points)
    Currently Being Moderated
    Jan 26, 2013 9:09 PM (in response to léonie)

    "Place" was next on my list  .

     

    In one of my Libraries in which I use Places, if I filter for "Place" "is empty" it get 2790 items.  These are the same 2790 items that _do not show_ if I filter for "unid".  From this I conclude that the string "unid" is added to Images which have a Place assigned, and that the text filter includes whatever field in which "unid" is written.

     

    I don't have time to do any further testing right now.

     

    Koen -- why did you filter for "unid"?

     

    --Kirby.

  • léonie Level 8 Level 8 (46,510 points)

    These are the same 2790 items that _do not show_ if I filter for "unid". 

    exactly - I have only one image that does show for the combined search "Place is empty" and "Text includes 'unid'", and this image has an IPTC tag: "Image City: Comunidad Yumani, Isla del Sol"

     

    Pure speculation: "unid" is a very common shortcut for "unique document identifier" or "unique image ID". Perhaps the "Places" database references "unid" tags to places objects.

  • Kirby Krieger Level 6 Level 6 (11,570 points)

    So (briefly) you have a solution, though it is a bit of work-around.  The string "unid" should be reserved by Aperture and should not be available as a Keyword.  Change your Keyword.  I find the auto-fill feature for Keywords very useful (it keeps me from making spelling errors).  Instead of something different (e.g. "NotID"), you can simply add to the string you already use.  Perhaps "unid'd"?  Since, after the change, "unid" will not be a Keyword, anytime you type "unid" (or perhaps even "uni"), Aperture should auto-complete to "unid'd".  (Apostrophes are just another character to the Keyword parser.)

     

    I find it helpful to capitalize all my Keywords (e.g. "Portrait", not "portrait").  I then input Keywords by typing in lower case, and let auto-complete fill in the Keyword and change the capitalization.  Periodically I open the Keyword HUD to look for problems.  Using this system, every Keyword that is not capitalized indicates a problem.

     

    The "unid" text search result is clearly (imho) a bug.  You should report it to Apple:  "Aperture➞Provide Aperture Feedback".

     

    (Added:)

    Do you have "unid" assigned to a Keyword button?  If so, you should remove it from the button before you change or delete it from your Keyword HUD.  Keywords assigned to buttons persist even if they are removed from the Keyword HUD.

     

    Message was edited by: Kirby Krieger

  • shuttersp33d Level 4 Level 4 (1,540 points)
    Currently Being Moderated
    Feb 18, 2013 4:12 PM (in response to léonie)

    Leonie, in your post you said you came up with an image with an IPTC tag - "Image City: Comunidad Yumani, Isla del Sol"

     

    ComUNIDad does have unid in it.

     

    Did a few more experiments. Do you guys find that if you put the whole string "unidos" in the search, you get the same images appearing? Or communidad for that matter.

     

    Seems like if you've dragged an image to a Place that, in Spanish, has the word unidos in it, it will appear in any search with unid. The United States is Estados Unidos in Spanish. Photos dragged to places in the UK may also appear, United Kingdom, etc.

     

    That's as far as I've gotten at this point...

  • shuttersp33d Level 4 Level 4 (1,540 points)

    Also, do you get the same results if you simply do a keyword search for "unid" as opposed to a text search?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.