5 Replies Latest reply: Jul 30, 2013 6:57 PM by JDW1
BobGuthrie Level 1 Level 1 (85 points)

...After updating to 10.8.2. Anybody else?.


iMac, OS X Mountain Lion (10.8.2)
  • 1. Re: The application Finder.app can't be opened. (-600)
    funkymonster Level 1 Level 1 (0 points)

    I was logged in as an admin, ran all of the updates for Mountain Lion, restarted, loaded Office for Mac, restarted and signed in as the end user (who has been set up to administer the account) and I now have the:

    The application Finder can't be opened. -600

    Also, none of the Office applications are available either.

    I have tried CMD + R and re-installed without any success.

     

    Any other idea's would be greatly apprecated!

     

    Thanks

  • 2. Re: The application Finder.app can't be opened. (-600)
    BobGuthrie Level 1 Level 1 (85 points)

    Trash the Finder.app preference files: /users/<username>/library/preferences/ (If you don't see the "Library" folder, go to the Finder, hold down the Option key, and select the "Go" menu).

     

    Drag "com.apple.finder.plist" and "com.apple.sidebarlists.plist" to trash.

     

    Log out or restart (you will lose your set Finder preferences, including the Sidebar. Go to desktop>menubar>finder>preferences to reset after restart/logout).

     

    Got rid of my -600 problem, hope this helps you. =)

  • 3. Re: The application Finder.app can't be opened. (-600)
    critichu Level 1 Level 1 (0 points)

    Thanks for the solution BobGuthrie.

    Just to add: no need to restart or log out, simply relaunch Finder

    (Apple menu on the top left -> Force quit -> select Finder and hit Relaunch)

  • 4. Re: The application Finder.app can't be opened. (-600)
    MentalMuffin Level 1 Level 1 (0 points)

    I found that this didn't work for me - I could not trash the finder.app preference files because I couldn't use finder with this problem.   What worked for me was to switch off, do a safe reboot, logged in as root and then did a restart. that sorted it

  • 5. Re: The application Finder.app can't be opened. (-600)
    JDW1 Level 1 Level 1 (0 points)

    Bob's solution was no solution for me, probably because after trashing those 2 PLISTs I decided to follow critichu's advice of relaunching the Finder rather than logging out or restarting.

     

    Let's face it.  When I have these Finder problems, I can always solve them by restarting.  But the reason I came to this forum in the first place was to find out how to prevent this from either happening again or solve it quickly so I don't need to logout or restart.

     

    What seems to cause Finder problems for me on a regular basis is my Time Capsule, which is connected to my 10.8.4 DuoCore iMac via Gigabit Ethernet (and shared in our office).  For whatever reason, while I am in the midst of copying files to/from the Time Capsule, the Finder will lockup with spinning beachball forever.  I have experienced this often in Adobe Illustrator too.  When saving a file from Illustrator to my Time Capsule, my entire Mac locks up and I am forced to restart.

     

    Anyway, the problem I have today was not caused by a document save to Time Capsule in Illustrator, but by merely copying files from my Time Capsule to my desktop.  The Finder locked up, so I tried to kill it and relaunch.  It wouldn't relaunch.  So I then started quitting all my open apps (including Illustrator and Outlook), and then mysteriously the Finder launched.

     

    Strangeness began though when I clicked on the Downloads folder sitting in my Dock.  I always choose "Show in Finder" when I right-click on that folder in my Dock.  But this time when I do that, I get a "Finder can't be opened" error -600.  But the Finder is already open!  However, when I hit Opt-CMD-ESC, I see two instances of the Finder in the dialog!  But in Activity Monitor, I only see one instance of the Finder.  And quitting that instance (which quits the Finder visually), still leaves one open instance inside the "Force Quit Applications" dialog!

     

    Yes, I've tried "killall Finder" in the Terminal, but that just gives me the following error:

     

    No matching processes belonging to you were found

     

    Is there really no rememdy for this other than to Logout or Restart?  Surely there must be.  This is getting quit painful.

     

    I'm also unsure when this started. I think I was still having this problem even under Lion, although exclusively in Illustrator (when saving to my Time Capsule), rather than in the Finder.

     

    I'm baffled.