Skip navigation

Having synced my ipod, there are certain artists missing from the list on the ipod, but the tracks are there under the songs list.  Any reason why and how do i correct this.  Thanks.

349 Views 1 Reply Latest reply: Jan 27, 2013 1:47 PM by the fiend RSS
StevieJ Calculating status...
Currently Being Moderated
Jan 26, 2013 11:44 AM

Having synced my ipod, there are certain artists missing from the list on the ipod, but the tracks are there under the songs list.  Any reason why and how do i correct this.  Thanks.

iPod 5th Generation (Late 2006)
  • the fiend Level 5 Level 5 (6,915 points)

    We'll assume for now, that all the songs and albums in your iTunes Library are correctly labelled (dangerous assumption, by the way!), and that a Compilation album is one with songs by different artists. Unfortunately, the music industry (bless their little cotton socks!) often mark an album by one artist, that has a collection of their songs from old albums, as a compilation! iTunes doesn't think it is!

     

    The missing artists will be those who only appear on Compilation albums. For example, if you have one song by Fleetwood Mac in your Library, and it's on a multi-artist Compilation album, then Fleetwood Mac will not be listed in the Artists menu. But, if you then import a Fleetwood Mac album (or even a Fleetwood Mac single) into your Library, then not only will Fleetwood Mac appear under Artists, but the song by them in the Compilation album will also be listed.

     

    One way to sort this out is to remove the Compilations option from the Main Menu and the Music Menu on your iPod. To do this, go to Settings/Main Menu/Compilations and press the Select (centre) button to turn off the tick. Then repeat this in the Settings/Music Menu/Compilations.

     

    You should now find the missing artists listed in the Artists menu.

     

     

    By the way, I now routinely check all albums I import from CD into my iTunes Library. Before I start the import procedure, I make sure that Compilation CD is turned on (highlight the album in the import window and right-click/Compilation CD) if it really is a multi-artist CD - and off if it's a single artist CD. Once imported, I manually change the album info to; (highlight album and select ) File/Get Info/Info/Album Artist has "Various Artists" in the box. Make sure it's the Album Artist box, not the Artist box.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.