Skip navigation

Canon MP620 printer scanner cannot be added as a device

5396 Views 18 Replies Latest reply: Jan 28, 2013 6:34 AM by italk2rocks RSS
1 2 Previous Next
italk2rocks Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 27, 2013 1:32 PM

I've been searching for and trying different solutions for over 5 hours now. I'm hoping someone can help me. This canon device should work similarly to the newer printer/scanners in this line. This device worked fine for me when connected directly to my iMac via USB. I recently upgraded to OS X 10.8 and connected the printer to an Airport Extreme so both PCs on our wireless network could access it. This worked fine, could print from both the Macbook Air and the iMac with no problems. Then I tried to scan something and went down the rabbit hole. Found that the printer was not properly connected to the wireless network, and I have been unable to re-run the wireless setup using the Canon IJ Network Tool. After numerous efforts of installing the original startup disk, restarting, restarting the printer, installing all new drivers and software from the Canon site, I'm now in a worse situation than when I started. Now the iMac doesn't see the printer at all.

 

I had cleared all devices in my efforts to reset and start over, but now I am unable to add the printer back to my printer queue. At this point it's connected directly from my printer to the PC, so there shouldn't be anything complicated here, but the PC doesn't see it. I'm completely stuck.

 

This thread had great information for my original problem, but by the time I found that thread, my efforts to fix it had made it worse and now I can't access the printer at all.

 

Please help! Best case scenario, I'd be able to use the printer/scanner on our wireless network. But at this point I'd be happy to just be able to use it with a direct USB connection to the PC. Right now it's an expensive door stop.

OS X Mountain Lion (10.8.2)
  • RodneyW Level 4 Level 4 (3,030 points)

    Ouch.  That hurts.  In the first instance I suggest that you open up the web-based printer administration service to see if your printer is still "hanging around" at a level that is not visible in System Preferences.

     

    Go to Safari and type in 127.0.0.1:631

     

    This will bring up the CUPS home page.  Then click on Administration, then Manage Printers.  Is it still listed?

  • Brij011 Level 2 Level 2 (150 points)

    Considering a new printer won't cost much more than a set of ink cartridges for your old Canon, is it really worth the effort?

     

    I personally wouldn't go for Canon though. I've recently bought the PIXMA 4250, one or the range of successors to the MP620 and it wasn't easy to set it up in our network. I bought it because it has airprint (enabling printing directly from an Apple iOS device) but getting a Mac and several PC's to connect wirelessly was problematic and it still has frequent communication problems meaning we have to reboot everything to get it working again, i.e. devices router and printer.

     

    We have many wireless devices and have never had problems before.

  • RodneyW Level 4 Level 4 (3,030 points)

    Ok, then its time for deeper surgery.  Do you have a current backup of your system?  If not then please take one!  Do you have any other printers installed?  This approach is going to try to remove them all.

     

    Then, go to the systemwide Library folder (select computer from the Go menu in Finder, then select your hard drive, then select Library).

     

    Inside this folder navigate to Preferences, and then move the file "org.cups.printers.plist" to your desktop.  Make sure that it is moved and not copied!

     

    Try to install again.

     

    If this doesn't produce results, then go back to the Systemwide library folder and go into the Printers folder and move the "InstalledPrinters.plist" file to the desktop.  Make sure that it is moved and not copied!

  • RodneyW Level 4 Level 4 (3,030 points)

    Doh!  Yes.  That would definitely be worth doing!

  • PAHU Level 6 Level 6 (14,400 points)

    At this point in time, is the printer connected via USB cable to the PC?

     

    If yes, then the restored printer on the iMac will not work, as it was using a different connection.

     

    So if you have the time I would like to take you back through the wireless setup so that all devices can connect to the MP620.

  • PAHU Level 6 Level 6 (14,400 points)

    Okay. The first thing to check is what is currently set in the MP620. There is every chance that it is still correctly connected to your wirless network.

     

    On the MP620, use the dial to select Settings then press OK.

     

    Then rotate the dial to select Device Settings and press OK.

     

    And then rotate the dial to select LAN settings and press OK.

     

    One of the options in the list should be Confirm LAN settings. Select this and press OK.

     

    The next thing you should see is wireless LAN setting list. Select this and press OK. This will show if the connection is active, the SSID (wireless network name) and the IP address it is using. Make a note of this IP address.

     

    So is the MP620 still connected to the Extreme network?

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.