2 Replies Latest reply: Jan 28, 2013 5:14 AM by a brody
nsanchezfrommd Level 1 Level 1 (0 points)

I have an IMAC and a Maccbook AIr and I just bought Dragon for Mac 3 and discovered that I cant use it because I must have at least 10.7 to be able to load it. Is there anyway to pay for an upgrade to the OS?


MacBook Air, Mac OS X (10.6.8)