Skip navigation

Mail.app crashes on launch consistently

30858 Views 34 Replies Latest reply: Feb 16, 2014 4:53 AM by TheLove RSS
  • ggirol Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 12, 2012 2:16 PM (in response to Norman Daniel)

    >You guys need to delete the folowing files from the Library folder

     

    >- com.apple.AddressBook

    >- AddressBook-v22.abcddb

    >- com.apple.preferencepanes.cache

     

    I don't even have these two files on my system:

     

    AddressBook-v22.abcddb

    com.apple.preferencepanes.cache

     

    It's crazy that a Mail.app issue can lock up the whole computer.

  • Funkey Monkey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 12, 2012 5:58 PM (in response to Funkey Monkey)

    Funkey Monkey wrote:

     

    David's advice worked like a charm for me.   I just got back from a 10 day vacation -- I was hoping Apple would've released an update or fix for this while I was gone, but David solved my problem.   Thanks.

     

    Well -- correction.   It worked for me for a few hours.  Mail downloaded all my messages from both my IMAP accounts and I didn't have to reset any of my settings except for default signature, for some reason.

     

    BUT -- I logged out and logged back in, and we're right back to where we started -- CRASHageddon. 

     

    I run Thunderbird on my Windows machine at work.   I guess I'll be a Thunderbird guy at home on my Mac, too.

  • ChefMikeG Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 29, 2012 3:53 PM (in response to Funkey Monkey)

    I have the same issue.  Started out with mail not auto completing addresses and morphed into freezing and then finally crash on startup of app.  I have been on the phone with Apple support for a total of about 6 hours with 3 different people.  All fixes are temporary and mail crashes again after a few days or even hours.  The "genius" solution was for me to do an erase and install and a manual migration of all my data (12 Tb) without the help of migration assistant.  Basically the worst case scenario in terms of a fix, but it would have been worth it if it indeed worked. It did nothing to solve the problem permanently.  If you have an important email you need to send trashing the com.apple.mail folder in the containers folder in the user library solves the problem temporarilly for me, but only for a short time.  There is obviously a bug that needs to be addressed here. Come on apple, I know you have your hands full with the Maps screw up, but mail working is about as important as it gets!

  • todd smith9 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 3, 2012 6:25 PM (in response to David Mccollum1)

    This worked for me too.

  • saint-georges Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 9, 2012 12:53 AM (in response to David Mccollum1)

    Great David,

    that solved this problem !

    I was getting nuts with that.  The fan was on all the time. I was trying to minimise the number of mail through gmail or other accounts.

    The MBA is working well now.

     

    I do wonder what is the use of  ~/Library/Containers that had been rebuilt well.

     

    Best

     

    A. St-Georges

  • Bicontinental Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 9, 2012 9:13 AM (in response to cozar)

    Thank you Cozar! I had the same problem. In my case it seems to have been a rotten message, apparently corrupted during the download process on that specific Mac. It did not cause a problem on my other Macs or iOS devices. After clicking on that message the spinning beach ball started to appear and Mail crashed. I forwarded the message from my iPad and deleted the original message, checked on one of my other Macs and made sure the message had been deleted. The forwarded message loaded fine, and on the affected iMac the Mail issue was resolved. It works fine now. I hope it stays that way. :) Great advice! Thank you!

  • T. Bone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 9, 2012 2:04 PM (in response to David Mccollum1)

    David Mccollum1 you are THE MAN.  After a clean install of ML and complete reinstallation of my old hard drive apps and data, mail was working perfectly for 3 days.  then, kaput.  ????  Your solution fixed it.  I have no idea what the problem was, but it worked.  thank you so much.

  • tatsuya Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 27, 2013 10:04 PM (in response to JadedEye)

    Hello,

     

    I got this problem too on a two week old MacBookPro. None of the suggestions on this post helped me, and at the Apple Store the Genius told me to completely reinstall the system. I decided to install Thunderbird instead, but before even starting using it, in a couple of days Mail went misteriously back to normal behavior.

     

    In my case, I noticed that it crashes everytime it tries to retrieve some new mail; if put offline, it opens without crashing. So I thought it was a problem triggered by a rotten message and I deleted all the unretrieved mail from iCloud through Safari. However it didn't help and the app kept crashing for a couple of days.

     

    When it finally started working again, I noticed that when I try to open a Smart Folder (the Unread folder or the VIP folder, which I imagine to be some structured like a Smart Folder) it crashes. If I don't open any Smart Folder, or the VIP folder, everything works perfectly. So, could it be an issue related to Smart Folders?

     

    BTW, on a MacBookAir and a MacPro with the same system (10.8.2) I never had this issue; it's only on my MacBookPro.

  • Maxwho Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2013 8:06 PM (in response to JadedEye)

    Mail.app just started crashing recently. If I take the email account offline real fast it stays up and I can send mail no problem. As soon as I take it online it crashes again.

     

    I tried all the fixes listed in this thread and nothing solved my problem. Finally  downloaded  the pop3 mail off my server with thunderbird. Once the server was empty Mail then started working properly.

     

    I have looked at the 50 emails to figure out which one could be the culprit but nothing stands out.

     

    Hope my experience helps someone else experiencing this frustrating problem.

  • tatsuya Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 8:32 PM (in response to Maxwho)

    Wow, Maxwho!

    I just deleted all the mail in the server and Mail started working properly! You made my day!

    I only tried that for five minutes or so, but at the moment everything seems to work smoothly. At the moment, yours appears to be the only working solution.

    Bravo!

  • Maxwho Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 9:51 PM (in response to tatsuya)

    I'm glad it worked for you.

     

    cheers

  • mrfoyboy Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 18, 2013 9:23 PM (in response to Norman Daniel)

    After much stuffing around with other suggestions, this worked for me straight away. Thanks Norman!

     

    It may also be worth noting that I had already removed the mail folder from my library as suggested in earlier posts. I don't know if this had any impact.

  • Maxwho Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 18, 2013 9:44 PM (in response to mrfoyboy)

    Didn't have any impact with me when I moved the folder.

     

    Glad you were able to get it working again.

     

    Cheers

  • Vik Rubenfeld Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2013 10:01 PM (in response to Maxwho)

    David Mccollum1's fix seems to have worked for me!

     

    David Mccollum1 wrote:

     

    I fixed it! I went to ~/Library/Containers. There I removed the entire com.apple.mail folder to the trash, emptied the trash and rebooted. Mail opened just fine and started populating with all my email. So, I'm back in business. I did make a copy of the file on an external USB thumb drive just in case, but it looks like I won't need that.

     

    Good luck.

  • cfsdoriga Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2013 5:22 AM (in response to Vik Rubenfeld)

    l

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.