Skip navigation

Asking for a solution

235 Views 5 Replies Latest reply: Jan 28, 2013 1:43 AM by joelJURASSIC RSS
Arham93 Calculating status...
Currently Being Moderated
Jan 27, 2013 11:56 PM

I am using an iphone 3G..ios 4.2.1.....this is lasr version of ios for ma iphone....im unable to install skype and viber....it requires ios 4.3....for being as an iphone user you should give us a best service.....i am asking you to fix this problem soon

iPhone 3G, iOS 4.2
  • Ethmoid Level 6 Level 6 (9,690 points)
    Currently Being Moderated
    Jan 28, 2013 12:53 AM (in response to Arham93)

    Who exactly is your comment "I am asking you to fix this problem soon" directed at?

     

    Remember that you are posting on a user to user forum so nobody can really help you.  If you want to give feedback to Apple, then contact them directly at http://www.apple.com/feedback.

     

    Also, if you have an iPhone 3G and iOS 4.2.1 is the latest software that you can install on your phone, then there is absolutely nothing that anyone can do to fix the problem if you want to install Skype that requires iOS 4.3 - what do you think anyone can magically do?

     

    iPhone 3G is a very old phone now and if you want to install Skype on your phone, then you need to go out and buy a new iPhone - either a 4s or a 5.  Nothing more to it.  Buy a new phone.

  • sberman Level 7 Level 7 (23,700 points)
    Currently Being Moderated
    Jan 28, 2013 12:55 AM (in response to Arham93)

    The iPhone 3G came out nearly five years ago. The highest version of iOS it will support is 4.2.1.

     

    There have been four generations of iPhone released since the 3G. Any of those four could run iOS 4.3 or greater.

  • Courcoul Level 6 Level 6 (11,160 points)
    Currently Being Moderated
    Jan 28, 2013 1:01 AM (in response to Arham93)

    Can you run Skype or Viber on Windows 95 or MacOS 9.5? Same thing here. Evolve or perish. Your phone is in its death throes.

  • ckuan Level 6 Level 6 (19,835 points)
    Currently Being Moderated
    Jan 28, 2013 1:37 AM (in response to Arham93)

    Skype and Viber are 3rd party apps, you need to contact them about releasing apps that you can use with iOS 4.2.1. Apple has no control to what iOS version the apps developers want to target.

  • joelJURASSIC Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 28, 2013 1:43 AM (in response to Arham93)

    Why do people only target Apple?

     

    As Courcoul said, windows 95 wouldnt run Skype, but i'm sure nobody is over their forums whinging about an issue that is only present because people are too cheap or stingy to actually upgrade their phones

     


    If you support Apple so much, why not get a phone thats not ancient?


    And on a technical level, the issue isn't that apple doesn't support it, its that the App Developer has only made the app available for 4.3 and up.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.