Skip navigation

Compressor 4.0.6 "flashes" every 5 seconds or so whilst working?

1067 Views 14 Replies Latest reply: Apr 15, 2013 5:40 AM by Ian R. Brown RSS
Ian R. Brown Level 6 Level 6 (17,445 points)
Currently Being Moderated
Jan 21, 2013 1:51 PM

I don't know whether anyone else has noticed this.


4.0.6 flashes every few seconds whilst working. I seem to get a fleeting glimpse of a warning message  .  .  . .  possibly asking about incoming connections.


I've deleted preferences etc. to no avail.


However, when I open the previous version (4.0.5) there is no instability of the interface at all.


I'm using OS X 10.6.8 and don't know whether it's that or something else causing the odd behaviour.


It seems to do the job OK but the flash every 5 seconds or so is rather irritating.

iMac, Mac OS X (10.6.8), Little knowledge... many opinions.
  • Russ H Level 6 Level 6 (12,875 points)

    Ian R. Brown wrote:


    I don't know whether anyone else has noticed this.


    I'm using OS X 10.6.8 and don't know whether it's that or something else causing the odd behaviour.



    FWIW, in one machine I'm running 10.6.8 and have no issues.


    If you don't have it, download and run COmpressor Repair from Digital Rebellion…amd check the trash prefs box.


    Good luck.


  • Warwick Teale Level 3 Level 3 (555 points)

    HI Ian, first place to look is in the /var/logs ( and use the global search for to see if its a UI issue. It maybe from another components. The logs SHOULD show this error. YOu may have to dig around a abit. Use the 'Find command now in too)


    YOu might want to consider upgrading the OS to something current if you can. 10.6.8 may be stable however the interation of the latest Compressor and Qmaster etc wit hthose frameworks etc in MACOSC 10.6.8 may not be clean.... just a guess too.


    Do you have Little installed and activated on this host? This is usually ok, however Qmaster may be asking the outside world for a look? could be. Little Snitch may have barred him form doing this.. just a thought. Litt;e Snitch message usually stay up in its UI.... just a guess.


    If the job is running and the backend is flashing these messages then search for QMASTER. You may also have DNS error message if your cluster is out hunting for other nodes.


    IF you are using QMASTER (submit with batch), then you might want to check the logs of those services via the SHARE MONITOR... I'd that this is not the source.


    The parms are not this issue me thinks.


    TRy this when you have time if you DONT need QMASTER on another host.


    Step 1: quiesce/ shutdown anything but COMPRESSOR and Qmaster.

    Step 2: turn off / disable you network on your mac. (use system prefs/network/ create a new SETTING "no network" and delete all the NICS.. apply this... = no network.

    Step 3: submit your batch again and determine the results


    See if you still get these flashing messages....


    IF not, then resinate your network (pull up the default system prefs settings for network) and apply.


    Post your results for others to see.


    Final Cut Pro X, OS X Mountain Lion (10.8.2), Motion5 , Compressor 4
  • Warwick Teale Level 3 Level 3 (555 points)

    Hi ian, yeah could be.  I'm  on Mac osx 10.8.2.  I'd hazard a guess that Russ is the same.


    There were some big changes under the covers in Lion 10.7


    And some more under 10.8 ML


    Could be your issue


    Of u can upgrade the os it might be a start


    In the meantime. Why not try and disable your network and also Qmaster and see if can at least get a job out


    If that works, leave the network off and fire up Qmaster and repeat


    Worth a try



  • Warwick Teale Level 3 Level 3 (555 points)

    Hi ian... Lol :) sounds like a good plan. 



  • Warwick Teale Level 3 Level 3 (555 points)

    Hi ian.. GeeZ that's annoying. Do you still want to try and resolve this?


    If so:

    Step 1) Can you check the /var/logs for any messages relating to Qmaster , and network?

    Step 2) Also, would you try funning with Qmaster stopped (disabled) then

    Step 3) Disable all your  network (set a network config to have NO NETWORK NICs), restablish Qmaster and try again.


    Post your results.


    FCPX issue.. Tackle that next..:)



  • Warwick Teale Level 3 Level 3 (555 points)

    Hi Ian, cool. A few notes....


    1) make sure "show log list" is selected pane view.. ... Then look for "All Messages" under the "system log queries" heading at the top left of the logs....


    Look for anything or search using the filter on the top right corner of the new "find" ( cMd+F) in the edit application menu.  You're looking for any global messages that your UI or underwear may have logged. I'm uncertain if compressor.Pp keeps any non-error logs in ~/library/logs ....however if prangs osx keeps partial dumps etc in crasheeporter .. You might se these if compressor locks up or fails. These are exposed in as well under the user dumps or application logs.


    Tip: in the's application VIEW menu, tick all the 'Show PID, Sender, etc" this pretties up the view and bolds up and icons the formatting a bit to make it easier to see stuff.


    While you're in there see if there's any Qmaster messages too.


    You can go in through the backdoor to see any RECENT messages that may be in ~/library/application support/apple Qmaster/logs/ . Now there are a dose of logs in there for the clustercontoller, service nodes etc. the will open and be formatted in or and also quickview.


    See what u can turn up..


    2) apple Qmaster: this will/may want to access resources on a network.. You MAY have it started and I'd so there may be a cluster looking for some "company" (some service node "mates" on the LAN.


    If so, simply shutdown Qmaster using the's "apple Qmaster" menu/share this computer/setup tab/untick the "share the computer" .. Wait 10 secs or so and Qmaster will terminate.


    Post your results for others to see.




  • Warwick Teale Level 3 Level 3 (555 points)

    ... Whoops neglected "step 3" .....  This is about organising a usage test without aNy network available to your host. I'm curious to see if u still get your nagging message.


    So,, rather than pull out cables and bugger around with airport etc... Simply set up another network configuration with "no network" and pl this.


    Simple steps: all this happens in system preferences/network pane ...


    Step 1) open your default network setting as a above . Look for the "Location" list box. Unless you have a few of these it's probably named "automatic"


    Step 2) gear down on the list box for "location" and click on "edit locations" and select the "+" sign in the lower left of the new pane ... This creates. New "untitled" location


    Step 3)'overripe the name of "untitled" and rename it "no-network". Then click on "done" ...


    Step 4) in location list, select the new "no-network" configuration.


    Step 5) lastly, serially select each of the network interfaces that are there and delete them using the "-" sign in the bottom left of the network pane. Delete them all an finally click on "APPLY" .. No you have no network.


    Try n see if you get any errors as I describe.


    When finished, just go back I to network pref and select your default configuration and "APPLY" it ? Your net work is reinstated!!


    Post your results for others to see.





More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.