Skip navigation

HT1752: Vintage and obsolete products

Learn about Vintage and obsolete products

HT1752 How to revert OS X 10.4.11 to OS X 10.3.5

560 Views 12 Replies Latest reply: Jan 29, 2013 2:29 PM by MlchaelLAX RSS
Alm1ghty55 Calculating status...
Currently Being Moderated
Jan 28, 2013 2:13 PM

How to revert OS X 10.4.11 to OS X 10.3.5 with out loosing existing files?

PowerMac G4 Fire Wire 800, Mac OS X (10.4.11)
  • MichelPM Level 5 Level 5 (7,125 points)
    Currently Being Moderated
    Jan 28, 2013 2:31 PM (in response to Alm1ghty55)

    Why would you want to do this?

    OS X Tiger OS X 10.4 is much better than OS X 10.3

    You would need to an external FireWire hard drive to backup all your Macs data using a data cloning app.

    There are two.

    Carbon Copy Cloner or Super Duper

  • MichelPM Level 5 Level 5 (7,125 points)
    Currently Being Moderated
    Jan 28, 2013 2:33 PM (in response to Alm1ghty55)

    What are the specs of your PowerMac G4?

    Year, CPU speed and amount of RAM?

  • MichelPM Level 5 Level 5 (7,125 points)
    Currently Being Moderated
    Jan 28, 2013 4:27 PM (in response to Alm1ghty55)

    The problem is that if you use this Mac for any Internet use, you are going to even more limitations on 10.3 than you maybe running into on OS X Tiger 10.4

    If you downgrade, anything that has been updated for OS X 10.4 will no longer work on 10.3 Panther and finding other apps that are compatible with OS X 10.3 will be even more an excersize in futility.

    Do you really need to run old OS 9 games?

    You could make your G4 more up to date and working, somewhat better on the Internet by installing OS X 10.5 Leopard.

    You can still find updates for 10.5 Leopard. It will at least  have your Mac G4 at the maximum OS that it can run.

    Ssomething to think about before you decide to attempt this.

  • MichelPM Level 5 Level 5 (7,125 points)
    Currently Being Moderated
    Jan 28, 2013 4:37 PM (in response to MichelPM)

    You have a dual CPU G4!

    You can contact Apple at 1-800- MYAPPLE and ask for retail software sales to see if they still have retail OS X 10. 5 Leopard discs. Tell them you have purchased an older iPad or iPhone.

    If they do not have these retail discs any longer here is one source for the OS discs

     

    http://www.amazon.com/Apple-Version-10-5-6-Leopard-VERSION/dp/B000FK88JK/ref=sr_ 1_2?ie=UTF8&qid=1359419599&sr=8-2&keywords=OS+X+10.5+Leopard

     

    I just think you are going to make things even more difficult for yourself if you downgrade the OS.

    There are plenty of games for OS X.

    If you actually use this Mac, you a going to make you Mac use even more difficult just because you want to play a bunch of old, obsolete games.


  • MichelPM Level 5 Level 5 (7,125 points)
    Currently Being Moderated
    Jan 28, 2013 4:50 PM (in response to MichelPM)

    PLus, I also forgot to mention, dude, you also have a FireWire 800 Mac!

    You could also STILL use brand new high speed external FireWire 800 hard drives and CD/DVD optical drives!!!

    Forget the OS 9 games, dude!

    Get this Mac up to it's full potential! I had a Single CPU 1.25 GHz G4 MDD that I used for almost 10 years!!

    This Mac will still be fine for most things and on the current Internet with some limitations, but you might be able to get around those if you ask questions in these forums.

  • Texas Mac Man Level 8 Level 8 (44,220 points)
    Currently Being Moderated
    Jan 28, 2013 6:46 PM (in response to Alm1ghty55)

    Here's the spec page on your G4 http://www.everymac.com/systems/apple/powermac_g4/specs/powermac_g4_1.42_dp_mdd. html

     

    It will not boot into OS 9 and can only run classic mode in OS 10.4 and below. Panther, OS 10.3 will not allow you to boot OS 9.

     

    It's true that most OS 9 games will not operate properly in classic mode. That's because the game software wants to control the Mac, but it can't because you're not booted in OS 9.

     

    If you want to run the games, get an old iMac that will boot OS 9.

     

     Cheers, Tom

  • MichelPM Level 5 Level 5 (7,125 points)
    Currently Being Moderated
    Jan 28, 2013 8:12 PM (in response to Alm1ghty55)

    I assumed that this was your primary Mac.

    Many people, like me up to a less than a year, ago, are still using older Macs Both G4 and G5, so my bad.

    My 1.25 Ghz G4 ran OS X 10.5 pretty well on 2 GBs of RAM,  upgraded 256 VRAM video card, 3 internal HDs and lots of PCI FIreWire and USB 2 cards It was heavily upgraded and it ran pretty well on the Internet. If the videos weren't wrap in Adobe Flash code and I was watching Internet video that had 720p versions, I could watch these on my Mac with only mild issue. 1080p video, of course, was out of the question on this old a Mac.

    It was a great Mac for me for a long time.

    Like you, I finally bought a used 2009, 27 inch iMac because I finally got tired of fighting issues with newer video codecs on the Internet and I couldn't stream Netflix from my older PowerPC Mac.

    The CPU is three times faster ( 3.06 Ghz), video is the same as I had a 256 VRAM video card in my G4 and the iMac is loaded with 16 GBs of RAM.

    I can't update the OS past OS X 10.6.8 Snow Leopard , though, because I have a lot of PowerPC software that still runs under Rosetta as I have a lot of older, still expensive software that I can't afford to update to Intel versions.

    So, I completely understand where you are coming from.

     

    The reason OS X is a lot more stable than Windows is that Apple places limits on legacy hardware support  so it doesn't have to sacrifice stability and security by trying to keep up with 10 year old or more obsolete hardware.

    This is Windows Achilles heel, IMHO.

  • Glen Doggett Level 4 Level 4 (1,780 points)
    Currently Being Moderated
    Jan 28, 2013 8:54 PM (in response to Alm1ghty55)
    ... affter I upgraded to Tiger w/OS 9 Classic installed I just found out that a lot of classic OS 9 games and even early PPC games don't run right with Tiger as the OS. After much research I've discoverd Panther would solve all these problems.

    Both Panther and Tiger would need to run the same Classic emulation layer for OS 9 games on a FW800 G4.  Only the earlier FW400 G4 models can actually boot into OS 9.

     

    You might be able to find some updates for OSX native versions of software if you are lucky, check the developer support web sites for updates.  (like Oni from Bungie, for example)  But unfortunately many good OS 9 games were built to operate only on a booted OS 9 system and do not work under Classic mode, even though the native OS9/X Carbon libraries were built to ease this transition for developers for some time before OS X was released.  Some of those old OS 9 games may be considered primitive by modern standards, but  remain enjoyable nevertheless.  Nanosaur, for example, Diablo 2, Tie Fighter/X-wing, and some  flight simulators like Fly!2K and F-18 Hornet. 

  • MlchaelLAX Level 4 Level 4 (1,550 points)
    Currently Being Moderated
    Jan 29, 2013 2:29 PM (in response to Alm1ghty55)

    Consider SheepShaver to run Classic games on your Intel Mac:

     

    Risk II.png

                                     [click on image to enlarge]

     

    Here is a recent post that I assembled that explains running Classic on Intel in more detail:

     

     

    With the newer Intel Macs, you have to run a Classic emulator such as SheepShaver, which requires you to extract the Mac ROMs from your older Classic Mac and then install Mac OS 9.

     

    A related program is Chubby Bunny, which comes bundled with all of that included.

     

    More information on SheepShaver:

     

    http://www.emaculation.com/doku.php/sheepshaver_mac_os_x_setup

     

    and

     

    http://www.everymac.com/mac-answers/mac-os-9-classic-support-faq/run-macos-9-on- intel-macs.html

     

    and more information about Chubby Bunny:

     

    http://www.macwindows.com/OS9_on_Intel_Mac.html#092408b

     

    and

     

    http://hackthemac.blogspot.co.uk/2008/08/chubby-bunny-old-virtual-machine.html

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.