Skip navigation

Max OS X ML Network Printing DRP-1020

228 Views 1 Reply Latest reply: Jan 28, 2013 11:15 PM by Xandris RSS
ck_iphone Calculating status...
Currently Being Moderated
Jan 28, 2013 10:35 PM

I hv Mac book pro i5 Retina and want to connect to Epson L100 printer wirelessly using D link DPR 1020 connected to wireless router. When go to add Printer, I can see 1020 Bonjour, after I add printer, select driver and done. But I still can't print. I've tried IPP, LPD, HP Jectdirect, still fail. Im sure my network is working perfectly as I can login to DPR-1020.

  • Xandris Level 2 Level 2 (160 points)
    Currently Being Moderated
    Jan 28, 2013 11:15 PM (in response to ck_iphone)

    That print server only shows support on the DLink website up to 10.4.X.  Its possible it will not work with the OS.  Otherwise, it seems as though it SHOULD work, if the OS is not an issue.  Maybe try a newer print server?  Or, you might be able to set the printer up on another computer in your house, and share through that computer, but that is decidedly LESS convenient. 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.