9 Replies Latest reply: Jan 6, 2014 7:29 AM by agorn
HopeZN Level 1 Level 1 (0 points)

Recording external instruments using GarageBand on iPad (3rd gen), I have disabled the metronome in playback, but it's still faintly audible in the background. The instrument was lined in directly using iRig (not using a mic), so it can't be bleed through headphones.

 

Any suggestions?


GarageBand (iPad), iOS 6.0.2
  • 1. Re: Metronome bleed on playback (iPad)
    Zman_2013 Level 1 Level 1 (0 points)

    I had the same problem. It happens because you are recording the metronome that's playing through the speaker onto the track you are recording. I've found using headphons when you use the the external mic will eliminate this problem, if your not using the external speaker the mic won't pick up the metronome or other tracks.

  • 2. Re: Metronome bleed on playback (iPad)
    HopeZN Level 1 Level 1 (0 points)

    Thanks, but that's the problem - I AM using headphones, not the speaker. I'm also not using the external mic, I've lined the instrument in directly. It makes no sense that this should be happening.

  • 3. Re: Metronome bleed on playback (iPad)
    Zman_2013 Level 1 Level 1 (0 points)

    That is strange, maybe try laying a track of just metronome, then record your track & then deletethe metronome track.

  • 4. Re: Metronome bleed on playback (iPad)
    jfchessa1 Level 1 Level 1 (0 points)

    I get he same problem on my imac computer (headphones and direct in - no mics).  I wonder if it is the DI and not the program. I use a Tascam US-122.  I also get feedback through my headphones when I raise the distortion. 

  • 5. Re: Metronome bleed on playback (iPad)
    goominim Level 1 Level 1 (0 points)

    What kind of instrument are you using?

  • 6. Re: Metronome bleed on playback (iPad)
    agorn Level 1 Level 1 (0 points)

    I just submitted similar question-I use external instruments (Roland and Korg) via Alesis Multitrack USB interface with MAC Pro via GB 6.0.4. My External Mics are definitely off during instrument recording. Although the same phenomenon does NOT happen if I do a test track with an internal soft wear instrument! Therefore this Ghost Metronome I'm getting on all tracks must be related to some outside feedback!. Thus, when I record a track with Metronome, then mute it on playback, I'm still getting very faint ghost metronome track!. I'll try the idea of recording a Metronome track seperately in the mean time. Thanks

  • 7. Re: Metronome bleed on playback (iPad)
    agorn Level 1 Level 1 (0 points)

    did you ever resolve problem? I'm having smilar issues

  • 8. Re: Metronome bleed on playback (iPad)
    HopeZN Level 1 Level 1 (0 points)

    It was a hardware problem, and apparently a common problem with the iRig interface. It sounds like you might be having the same issue. The metronome and any other tracks already recorded actually feed into the unit itself during recording.

     

    The only way I've found around it is to pre-record my piano track on the built-in sequencer on my piano, and then record the track into GarageBand without using the metronome. Otherwise I just use drum samples to keep time. It's not ideal, but it works.

     

    Hope you find a solution.

  • 9. Re: Metronome bleed on playback (iPad)
    agorn Level 1 Level 1 (0 points)

    thanks, might try both ideas, also perhaps try recording a click track, then mute it and see if that works! At least I know I'm not crazy!!!